Cyberpunk 2077

REDmod modding tool - All you need to know

  • Comment
Cyberpunk 2077 has just had a new update and the game is now more integrated than ever with its modding community. REDmod has been released as a modding tool DLC for the game and allows compatible mods to be run with the game via a new launcher.

Cyberpunk 2077 is, if you don’t already know, a single-player open-world first-person RPG set in the futuristic Night City where cybernetic modifications have taken over. The game was developed by CD Projekt Red, the minds behind the critically acclaimed “The Witcher” games series.

In this article, we’ll bring you up to speed by sharing with you the changes that come with this release as well as the effects it will have on your game and your mods. Here are the basic points.

  • REDmod is available as an optional DLC on GOG, Steam and Epic. An offline version is available on GitHub and the Cyberpunk website.
  • New mods will require a specific format to be compatible with REDmod.
  • At the same time, Cyberpunk mods following the old format will still work just fine, but they will not appear in the REDmod menu.
  • REDmod is a command line application which will apply and remove the compatible mods, as well as check for conflicts.
  • REDlauncher has a user-friendly UI which will have an on/off toggle for all installed compatible mods, as well as launch the game.




We have been in contact with the Vortex extension community developers to make them aware of the update and to make sure that the extension will continue to be compatible with all Cyberpunk mods we host. In order to differentiate the new types of mods, we have added a “REDmod” tag which we recommend for mod authors to apply to mods following the new REDmod format.

What this means for our community.

For our users:

The most important thing to know is that your old mods will still work. The only change to be aware of when modding your game is whether the mods you are adding are REDmod compatible or not - if they are, then they will create their own mod entries with toggles in the REDmod/REDlauncher. If they are not, they will still work fine when installed through Vortex or manually, but they will not show up when using the new REDmod/REDlauncher.

For mod authors:

REDmod will load mods from a new “Mods” folder and will work for new scripts, sounds, animations and other assets. Each mod will have its own sub-folder and the top level of each sub-folder will have an info.json file to identify the mod and provide more metadata. 

You can find more information in the documentation and the FAQs on the Cyberpunk website.

We are working to make sure Vortex will be able to manage REDmod compatible mods so that users can be guided to making sure their setup works before launching the game. Users will be warned about whether they are missing REDmod requirements and Cyberpunk 2077 will be launched from Vortex with REDmod enabled by default.

The Cyberpunk modding community is one of our largest and most impressive communities who have shaped the game in many new and exciting ways since the game’s launch and we can’t wait to see what else they come up with going forward.

127 comments

  1. Spartantano
    Spartantano
    • member
    • 76 posts
    • 0 kudos
    How to install RedMod if store page on steam is pulled off in my region? 
    Or how to install offline ver of redmod? 
    1. Cafe008
      Cafe008
      • member
      • 22 posts
      • 0 kudos
      +1
    2. slingshotnetworks
      slingshotnetworks
      • premium
      • 319 posts
      • 4 kudos
      In the article above you'll find a link to the Cyberpunk website. There it tells you what to do...
    3. ThisWebsiteSucksfrfr
      ThisWebsiteSucksfrfr
      • member
      • 4 posts
      • 0 kudos
      slingshot there is nothing there about the github download, instead of spewwing misinformation maybe don't comment at all.
    4. bran3l
      bran3l
      • member
      • 1 posts
      • 0 kudos
      +1 si alguien sabe como instalar redmod sin conexion, ayude porfa
    5. T8ski2541
      T8ski2541
      • supporter
      • 1 posts
      • 0 kudos
      Bruh did you even read it? It absolutely says you can download it directly from GitHub or the Cyberpunk Website -1 reading comprehension 
    6. tizerone
      tizerone
      • member
      • 2 posts
      • 0 kudos
      No github link
    7. tizerone
      tizerone
      • member
      • 2 posts
      • 0 kudos
      Not written 
  2. Badgeur
    Badgeur
    • supporter
    • 587 posts
    • 9 kudos
    update 1.6 has broken so many peoples game (like mine ) where 1.5 was running perfectly with Mods and now wont even run, people use mods to personalize the game play and now you dont have the choice to play an RPG your way that choice is gone,so was it a good thing? no it was not, why it wasn't offered as an option if people wanted it is just beyond common sense, and 50 Gigs!!!!!! really so sadly I have uninstalled it as it is basically useless even though it was a great game.
    1. ShankNinja
      ShankNinja
      • member
      • 27 posts
      • 2 kudos
      What mods aren't working? I have everything working just fine with 1.61. I had to clean up my install and reinstall some mods but now everything is working better than ever.
  3. Rogdodge
    Rogdodge
    • premium
    • 1 posts
    • 0 kudos
    If you have having issues in Steam, please do this:
    1) Right Click the game and click "Properties"
    2) Look for "DLC" and click it on the next menu.
    3) Make sure the box is checked under "Install".  For some dumb reason, it didn't auto DL for me.  

    It might not auto install even if your other DLC normally does.
    1. Badgeur
      Badgeur
      • supporter
      • 587 posts
      • 9 kudos
      Normally it will auto up date as soon as you try to launch the game because there is no option NOT to update which is why so many peoples games are are broken now.
  4. DaWul
    DaWul
    • member
    • 260 posts
    • 2 kudos
    No matter what CDPR offers, it will never change because no one takes the first step, because no one dares to try.Let me explain.

    REDMod currently includes many of the frameworks we are using: redscript, red4ext, ArchiveXL, Native Settings UI, Mod Settings, TweakXL, Input Loader, etc.

    But instead of at least trying, one small step for a modder and one giant leap for the community, it's easier to just patch it to be compatible with 1.6, rather than update mods to REDMod, or even to the new folder to use for Mods.

    Unfortunately, we will continue to be tied with each update until the frameworks are updated to be able to use the mods.

    As someone can see, it is normal to have to install 6 Mods to be able to use only 1 Mod simply because the previous 6 are mandatory frameworks.

    REDMod, frees all this, allowing a single framework that is also part of the game and that is updated with each update of the official game, without having to wait for some modder of signs of life to update it, not to mention that it is not have abandoned. Many Mods stop working simply because some update of a framework leaves some function aside and that mod stops working forever, like the companions Mod, which has stopped working because the function that made the companions follow you is now changed in the CET and therefore the Mod has been destroyed and the creator no longer shows signs of life to update it.

    What will happen when there are 2 Mods, one that uses REDMod and the other that uses redscript, what will be the solution?

    I think it's time to take the first step, to move into the future and stop depending on unnecessary frameworks now that CDPR has given us REDMod.
    I'm tired of having to install 3 or 4 frameworks to be able to use only 1 Mod that interests me

    This is just my opinion, I may be confused in some aspects or in all, but it is my opinion and in the same way that I have respected the opinion of all during the previous versions, I hope that my opinion will be respected in the same way.
    1. DaWul
      DaWul
      • member
      • 260 posts
      • 2 kudos
      ?What will happen when there are 2 Mods, one that uses REDMod and the other that uses redscript, what will be the solution?

      Now need a Compatilibity Mod for RedMod and redscript ( cybercmd )... yeah... more more more more more framework Mods for using more Mods

      And the Cyberpunk 2077 Vortex Support at Modding Tools - Nexus Mods crash when you try to install a REDmod Mod?
    2. DaWul
      DaWul
      • member
      • 260 posts
      • 2 kudos
      Yeah more inconsistencies.

      Now need to have two Mod Menus:
      Native Settings UI at Cyberpunk 2077 Nexus - Mods and community (nexusmods.com)
      Mod Settings at Cyberpunk 2077 Nexus - Mods and community (nexusmods.com)

      Yeah, more and more frameworks for only install some mods, and maybe another compatibility Mod framework for join these 2 frameworks?
    3. DaWul
      DaWul
      • member
      • 260 posts
      • 2 kudos
  5. 19ATIKIN94
    19ATIKIN94
    • member
    • 35 posts
    • 0 kudos
    у меня тоже не подерживает ред мод в россии но я изменил в стеаме регион на турцию и тоже самое не как мод не показывает не каких файлов даже в другой стране и все што это такое я думаю вам бракованую фигню вам насеивают прожект ред и все
  6. stormwind81
    stormwind81
    • member
    • 4 posts
    • 0 kudos
    I have no clue but this tutorial in how to install it must be old or faulty.
    If I add the DLC in gog nothing is happening. My game folder doesnt update and I dont have a /tools folder.
    I am stuck at the very start of how to install REDmod and dont know what to do.
    Can someone help?
    1. akki1995
      akki1995
      • member
      • 2 posts
      • 0 kudos
      Please check this video, this helped me to install the redmod but I have the game on steam but the video shows steps for both GOG and Steam version.
      https://www.youtube.com/watch?v=XO6Z68NOJ64&ab_channel=Apoqsi
    2. bleys900
      bleys900
      • premium
      • 22 posts
      • 0 kudos
      Agreed - When I got to the step in GoG to "Manage Installation">> "Configure" - there is no "Features" Tab - it's all in the one page, and there's no checkbox to "Enable mods". 
    3. Maplicious
      Maplicious
      • premium
      • 40 posts
      • 0 kudos
      That video helped out a lot, thanks so much. Glad he went over the GOG process as well.
  7. LeeHelck
    LeeHelck
    • supporter
    • 336 posts
    • 19 kudos
    i am on gog and i can't get red launcher to actually launch. i got it to work once about a month ago but since then it won't work. i've scoured the internet looking for a resolution yet all i find is how to launch the game without it. as it stands any new mods for it that i add aren't detected by the game.
    1. bleys900
      bleys900
      • premium
      • 22 posts
      • 0 kudos
      I've recently had that problem. Gog was working okay a few days ago, but over the past few days, whenever I try to launch from Gog, it crashes.

      I CAN however launch the game from the "Launch Cyberpunk 2077" shortcut. No idea if that still syncs the saves or not.

      Also, after trying a few times and rebooting, I can usually get it to work, usually by keeping my mods to a bare minimum.
  8. TritonsWrath
    TritonsWrath
    • member
    • 307 posts
    • 2 kudos
    been using REDmod since it came out, recently though i have noticed that my game seems to crash whenever i do anything such as, Opening inventory/scanning or hacking/ Pause Menu/ buying or selling. If i disable the mods via the launcher the game loads and i can play it for hours and never get a crash when i do the things i mentioned before.
     I have only two mods in my mod folder and those are:
     https://www.nexusmods.com/cyberpunk2077/mods/5167 - Bike Overhaul and 
    https://www.nexusmods.com/cyberpunk2077/mods/5266 - Materials and Texture Override.
    My game is up to date at version 1.6, those two mods are up to date as well. I am also using Redscript and for that i also have this mod https://www.nexusmods.com/cyberpunk2077/mods/5176 - Cybercmd to make both REDmod and Redcsript work together.
    I have been asking around on discord but nobody seems to be able to properly help. My only main solution is to disable the mods icon via the launcher but i really want to use both the Bike Overhaul and the Materials mod. Can anyone assist me?
    1. jeannot555
      jeannot555
      • member
      • 30 posts
      • 0 kudos
      There is 2 version of CyberCmd , and one is for user of cyber engine tweak , check if you have the right one .
      Also do you any more mod instaled in the archive/pc/mod path ? Bin/x64 path ?
  9. xsandevistanx
    xsandevistanx
    • member
    • 1 posts
    • 0 kudos
    GUYS can someone make body building MOD that'll be so good pls
  10. zzundeadzz
    zzundeadzz
    • supporter
    • 232 posts
    • 0 kudos
    I hope we can have a proper third person mod. All those character customization and clothes go to wasted, because most of the time we can only see in first person.