File information

Last updated

Original upload

Created by

anygoodname

Uploaded by

anygoodname

Virus scan

Safe to use

About this mod

No more crowd panic caused by stealth grab takedowns or body pickups.

Requirements
Permissions and credits
Changelogs
Positively verified against the game v2.1+

While the game v2 patched most of false panic cases, some still exist and may negatively affect story and action immersion.
This mod helps in these cases.

This simple mod eliminates false crowd panic caused by stealth grab takedowns or stealthy body pickups.

The mod patches absurd in-game scenarios e.g. when taking down an enemy in an empty room causes crowd panic outside, ruining the immersive experience and drawing attention to the game tech glitches.

This is especially noticeable during stealth quests - you take down an enemy stealthily only to find part of the crowd in panic, the other part dancing and hostile NPCs remaining indifferent.

For the best immersion experience please combine it with the companion mod: Immersion patch - No crowd panic form using devices.

Before:



After:




This mod is a follow-up to my other mod patching similar weird game behavior.
Although this one does not completely eliminate crowd panic to avoid creating another unrealistic scenario - where the crowd ignores your illegal actions in front of it while hostile NPCs do not.
Instead, it reduces the crowd's sensitivity to your stealth actions.
As a result, if you take down an enemy in a room and pick up its body, the crowd outside will no longer panic.
However, if you carry the body outside and get too close to the crowd, they may still react with panic as if they were witnessing an unlawful act.


Two editions are available: CET and redscript.

Which edition should I choose?

The choice between the two editions depends on your personal preference.
Both editions provide the same functionality.

The differences come from dependencies:

CET edition:

Requirement: Cyber Engine Tweaks

- Requires only one dependency (CET)
- Easy to manage and troubleshoot while the game application is running
- Easier to troubleshoot
- More susceptible to being disabled by game updates due to its CET dependency
- More likely to experience CET-related issues during gameplay

redscript edition:

Requirement 1: redscript
Requirement 2 for REDmod support (optional): cybercmd OR RED4ext  Please select one of the two as together they may cause issues.
If you choose the cybercmd, make sure to install the standalone version if you don't have Cyber Engine Tweaks installed.

- Requires two dependencies if used in combination with REDmod or with the game v2.x
- Requires a game application restart for management and troubleshooting
- Troubleshooting may be more difficult
- Less susceptible to being disabled by game updates
- Less likely to experience code execution issues during gameplay.


What if I install both editions?

There is no harm in installing both.
The CET edition will detect the presence of the redscript edition and remain inactive.


Compatibility info:

Game v1.6+through 2.1+  with corresponding requirement versions depending on the edition installed.
Not tested against earlier versions.
CET 1.29.0 is not supported due to numerous issues in this version.
CET 1.30.0 is not supported due to issues in this version.


Issue reporting:

If you experience some unexpected mod functionality on the supported game and requirement versions please first verify it with all other mods disabled (with the exception for the required scripting platforms) before reporting.
The mods types that may affect this one functionality typically are:
  • CET scripting platform disabled due to versions mismatch or misconfiguration,
  • the redscript mod files in the \Cyberpunk 2077\r6\scripts folder
  • the CET mod files in the \Cyberpunk 2077\bin\x64\plugins\cyber_engine_tweaks\mods folder
  • REDmod mods in the \Cyberpunk 2077\mods folder
Please note I don't provide support for the required modding platforms or plugins.
If you find any issue with the requirements please contact their vendors.

Please note 99% of issues come from incompatible mods, corrupted data in game saves, unhealthy game install base or corrupted mod install.
I reserve the remaining 1% for unknown yet mod bugs.


Install or update:

automatic - use Vortex manager. Please note it may sometimes not work properly due to the Vortex  issues.

manual - drop extracted folders into your game folder. Allow to overwrite files if asked.

Uninstall:

automatic - use Vortex manager if it was installed by Vortex.

manual - remove the folders:

...\Cyberpunk 2077\bin\x64\plugins\cyber_engine_tweaks\mods\No Crowd panic from stealth activity
...\Cyberpunk 2077\r6\scripts\No Crowd panic from stealth activity


The Immersion patch mod series so far:

Immersion patch - No crowd panic form using devices.
Immersion patch - No crowd panic from stealth activity
Immersion patch - The Hunt quest missing audio restore
Immersion patch - Skippy animations restore

Credits:

Scissors123454321
 for a hint that prompted me to take on the issue again while turning my focus on to specific part of the game code.
jac3km4 for the redscript and the cybercmd
yamashi and the whole CET Team for the Cyber Engine Tweaks