Subnautica

File information

Last updated

Original upload

Created by

newman55

Uploaded by

newman55

Virus scan

Safe to use

717 comments

  1. newman55
    newman55
    • member
    • 884 posts
    • 68 kudos
    Locked
    Sticky
    Don't forget to reinstall qmod.
  2. yamamoto114
    yamamoto114
    • member
    • 25 posts
    • 10 kudos
    Locked
    Sticky
    Can't quite get over how robust and thoughtful this addition to the game is. There's a lot of small game design details I'm noticing that make it feel like a natural and balanced feature, in ways that I'm honestly surprised aren't in the description.

    - You don't get a directional arrow until you craft the compass
    - Topography only reveals itself when you're near ground level
    - Fog of war reveal changes size depending on what vehicle you're driving -- smallest when on foot, medium-sized in Seamoth and PRAWN, and massive when in Cyclops
    - Scanner room reveals fog of war
    - Scanner room's radar indicator shows the exact range based on upgrades

    It's all really smart design, and I imagine that less committed modders would have just done the simplest implementation without trying to make it as balanced as this. I dig it.
  3. newman55
    newman55
    • member
    • 884 posts
    • 68 kudos
    Updated
  4. OSubMarin
    OSubMarin
    • supporter
    • 312 posts
    • 13 kudos
    Hello again everyone, I made a new fix here. EDIT: I removed the link because the mod has been updated.
    This fix is fully working with latest Subnautica update :) (built for QModManager v4.0.1).
    To install it, simply replace the file in the folder at "C:\Program Files (x86)\Steam\steamapps\common\Subnautica\QMods\SubnauticaMap"

    PS: Remember that you will have to download the official update for this mod when it's available.
    1. CrestonOO
      CrestonOO
      • premium
      • 6 posts
      • 0 kudos
      Thank you, kind sir! :)
    2. ArdiPINK
      ArdiPINK
      • member
      • 60 posts
      • 0 kudos
      Nice!
    3. bewareofcat
      bewareofcat
      • member
      • 1 posts
      • 0 kudos
      Perfect! Thanks!
    4. akrobred
      akrobred
      • member
      • 4 posts
      • 0 kudos
      Very nice, thanks!
      Already downloaded your first fix and glad that you kept working on it. - Appreciate that!
    5. stakdrone
      stakdrone
      • member
      • 8 posts
      • 0 kudos
      Thanks!
    6. kajb139
      kajb139
      • member
      • 376 posts
      • 1 kudos
      worked for me... thank you. please let us know as soon as u have a more permanent fix, sadly i lost the map that was explored before but its ok... this is gonna be a lot easier with red baron installed now
  5. Rigssuss
    Rigssuss
    • member
    • 1 posts
    • 0 kudos

  6. TonyCOD
    TonyCOD
    • member
    • 3 posts
    • 0 kudos


    W
     


    Hello newman55,
    Subnautica has been updated (official update).
    There is now a missing method:

    MissingMethodException: void Radical.DestroyChildren(UnityEngine.Transform)
    at SubnauticaMap.Controller.Run () [0x00685] in <7d1d15ee29bf4fd59a5a9f5b498e9f1c>:0
    at SubnauticaMap.Controller+<Start>d__58.MoveNext () [0x00087] in <7d1d15ee29bf4fd59a5a9f5b498e9f1c>:0
    UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    UnityEngine.Logger:LogException(Exception, Object)
    UnityEngine.Debug:LogException(Exception)
    SubnauticaMap.<Start>d__58:MoveNext()
    UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)

    You can fix by implementing this (for example):


    public void DestroyChildren(object obj)
    {
    if (obj != null)
    foreach (Transform tr in obj)
    if (tr.GetType().ToString() == "Transform")
    UnityEngine.Object.Destroy(tr);
    }



    Where do you implement that though?



    for me that file that OSubMarin uploaded does not work, when i start the game a red message appear that says that the map mod can not be loaded
    1. Didorf
      Didorf
      • member
      • 5 posts
      • 0 kudos
      this fix doesn't work for me either, I'm sorry, the map was extremely useful
    2. UserPro66
      UserPro66
      • member
      • 23 posts
      • 0 kudos
      Same error message for the fix here too :-(
    3. OSubMarin
      OSubMarin
      • supporter
      • 312 posts
      • 13 kudos
      There are quite a lot of errors introduced by latest update so maybe there's another conflict that I couldn't see with your setup, possibly with another mod. If the temporary fix does not work for you you can try to disable other mods, but it is better to just wait for an official update of the map mod.
    4. UserPro66
      UserPro66
      • member
      • 23 posts
      • 0 kudos
      Ok, thank you nevertheless @OSubMarin
      ... uppps doubble post
    5. UserPro66
      UserPro66
      • member
      • 23 posts
      • 0 kudos
      Ok, thank you nevertheless @OSubMarin
    6. Didorf
      Didorf
      • member
      • 5 posts
      • 0 kudos
      you need to install the latest version of qmods, and the map will work
    7. UserPro66
      UserPro66
      • member
      • 23 posts
      • 0 kudos
      There is no way to make QModManager 4.0.1 setup work correctly. Actually on some systems it cannot be installed.
    8. OSubMarin
      OSubMarin
      • supporter
      • 312 posts
      • 13 kudos
      I made a new fix here. EDIT: I removed the link because the mod has been updated.
      This fix is fully working with latest Subnautica update and QModManager v4.0.1.
      To install it, simply replace the file in the folder at "C:\Program Files (x86)\Steam\steamapps\common\Subnautica\QMods\SubnauticaMap".
  7. justinds89
    justinds89
    • member
    • 5 posts
    • 0 kudos
    W
     


    Hello newman55,
    Subnautica has been updated (official update).
    There is now a missing method:

    MissingMethodException: void Radical.DestroyChildren(UnityEngine.Transform)
    at SubnauticaMap.Controller.Run () [0x00685] in <7d1d15ee29bf4fd59a5a9f5b498e9f1c>:0
    at SubnauticaMap.Controller+<Start>d__58.MoveNext () [0x00087] in <7d1d15ee29bf4fd59a5a9f5b498e9f1c>:0
    UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    UnityEngine.Logger:LogException(Exception, Object)
    UnityEngine.Debug:LogException(Exception)
    SubnauticaMap.<Start>d__58:MoveNext()
    UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)

    You can fix by implementing this (for example):


    public void DestroyChildren(object obj)
    {
    if (obj != null)
    foreach (Transform tr in obj)
    if (tr.GetType().ToString() == "Transform")
    UnityEngine.Object.Destroy(tr);
    }



    Where do you implement that though?
    1. OSubMarin
      OSubMarin
      • supporter
      • 312 posts
      • 13 kudos
      EDIT: Modified this message because I released a new fix. See below.
    2. justinds89
      justinds89
      • member
      • 5 posts
      • 0 kudos
      Thanks for the help! I appreciate the quick response.
    3. Wizzrd
      Wizzrd
      • member
      • 3 posts
      • 0 kudos
      You sir, are a gentleman.
    4. Neo3846Niyck
      Neo3846Niyck
      • supporter
      • 18 posts
      • 0 kudos
      Thanks a lot OSubMarin! :)
    5. AbrasaxDrake
      AbrasaxDrake
      • member
      • 82 posts
      • 3 kudos
      I can confirm that OSubMarin's fix works for me, following the micro update, with QMM 4.0.1 and SMLHelper 2.8.

      Thanks, OSubMarin.
    6. Algushelm
      Algushelm
      • member
      • 3 posts
      • 0 kudos
      The .dll works with the QMod 4.0.1 and SMLHelper 2.8. Now I can explore the lava zone! Thanks mate!
    7. OSubMarin
      OSubMarin
      • supporter
      • 312 posts
      • 13 kudos
      New fix here. EDIT: I removed the link because the mod has been updated.
      Fully working with latest Subnautica version and QModManager v4.0.1.
      Simply replace the file in "C:\Program Files (x86)\Steam\steamapps\common\Subnautica\QMods\SubnauticaMap".
  8. justinds89
    justinds89
    • member
    • 5 posts
    • 0 kudos


    super weird, i have not any other mod but the map. I have replaced the .ddl provided in the map mod folder is this correct?


     
    Shouldn't be a conflict than.
     
    That's all I did. I went into the QMOD folder into the SubnauticaMap (I believe that's the correct name) folder and replaced the existing .dll with the new one.
     
    One thing I would make sure of is that your QMOD version is the latest. I know they just release version 4 not too long ago which is what I am using.
     
    You may still be on 3.5 or something. Not sure if that could cause issues, but worth a look.
    1. Didorf
      Didorf
      • member
      • 5 posts
      • 0 kudos
      thank you very much,I did not know that there is a new version,if it were not for the problem with the map, I would not have climbed there
  9. justinds89
    justinds89
    • member
    • 5 posts
    • 0 kudos


    Yeah, thanks justinds89, updating Qmod worked!


     
    No problem Tony! Good to hear it worked.
     
    I bet that is the same issue a few of the others are experiencing to and they probably need to update QMod as well.
  10. TonyCOD
    TonyCOD
    • member
    • 3 posts
    • 0 kudos
    Yeah, thanks justinds89, updating Qmod worked!
  11. TonyCOD
    TonyCOD
    • member
    • 3 posts
    • 0 kudos
    super weird, i have not any other mod but the map. I have replaced the .ddl provided in the map mod folder is this correct?
  12. justinds89
    justinds89
    • member
    • 5 posts
    • 0 kudos
    That's odd that a few reported the fix didn't help them.
     
    It worked right away for me thankfully.
     
    I am using a few other mods, but nothing that probably would interfere with this mod.