Stardew Valley

File information

Last updated

Original upload

Created by

Ben and ParadigmNomad

Uploaded by

gizzymo

Virus scan

Safe to use

650 comments

  1. hiuyee
    hiuyee
    • member
    • 4 posts
    • 0 kudos
    Is the language in this mod can only choose English?
  2. FarmerGeorg
    FarmerGeorg
    • member
    • 1 posts
    • 0 kudos
    Compatible with SVE (Stardew Valley Expanded) mod?
    1. gizzymo
      gizzymo
      • member
      • 259 posts
      • 24 kudos
      Yes
  3. Makuto3
    Makuto3
    • member
    • 2 posts
    • 1 kudos
    Is there any reason this mod would not be compatible with Stardew valley Expanded?
    1. gizzymo
      gizzymo
      • member
      • 259 posts
      • 24 kudos
      It's compatible. However, while I'm personally impressed with Flashshifter's amazing work, none of my content acknowledges FlashShifter's content. My dialogue only keeps vanilla SDV in mind as its basis for inspiration.
    2. JamesiaInc
      JamesiaInc
      • premium
      • 47 posts
      • 4 kudos
      Perhaps a small version that DOES, indeed, mesh with it is possible sometime in the future? :P
    3. gizzymo
      gizzymo
      • member
      • 259 posts
      • 24 kudos
      I'd been thinking about it for over a year. Last winter, I took a look at the game's files so I could start making some small adaptations based on what I saw. I didn't really get any ideas whatsoever for any lines to write, so I figured I just needed to spend some time playing the game legitimately, waiting for inspiration to strike.
      So then, earlier this summer, I started playing through SVE; unfortunately, I just couldn't really get into it. I think what FlashShifter has done is amazing, but for some reason I just have a very strong preference for vanilla SDV. After months and months of trying to come up with interesting things for characters to say about SVE content, I just haven't been able to come up with a single line of dialogue that I'm excited to write.
      Sorry to say this; I just don't think I should lead on anybody's expectations any longer.
  4. ElectricDreams
    ElectricDreams
    • member
    • 4 posts
    • 0 kudos
    This is probably a very stupid question, but does this mod remove any vanilla lines?
    1. gizzymo
      gizzymo
      • member
      • 259 posts
      • 24 kudos
      Not a stupid question at all.
      About 98-99% or more of all vanilla lines are still in my version and look exactly the same. No lines have been outright removed, but the remaining 1-2% have mild edits in order to cram two text boxes into one. This should be apparent with rainy day dialogue with the villagers. By cramming two text boxes into one, it allowed me to create two separate dialogue messages for the same condition, with a 50/50 chance of getting either one.
      The same thing applies to some of the marriage dialogue.
      Lastly, to contradict myself a little bit, there are a couple of lines that I outright changed. For example, I think there was one where Lewis says the old bus hasn't worked for decades, but that contradicts the story when Pam "gets her old bus job back" as soon as it is fixed. So I think I changed "decades" to "some time" or something like that.
  5. Jon8RFC
    Jon8RFC
    • supporter
    • 5 posts
    • 0 kudos
    This is great. I'm new to the game but added this mod from the start and kind of forgot about it because everything fits so well. I really enjoy going up to the various people, and the interactions are fun and well-written. Thanks for making this--you did a great job!
    1. gizzymo
      gizzymo
      • member
      • 259 posts
      • 24 kudos
      Thank you for playing with it! It makes me very happy to hear that from you. :)
  6. kkkyoumi
    kkkyoumi
    • member
    • 1 posts
    • 0 kudos
    How to download the localization version
  7. Chasm88
    Chasm88
    • member
    • 2 posts
    • 0 kudos
    Hi, I see that the bachelorette version of this mod only changes the pronouns and stuff. Is there a good mod that can work with this one so there can be new dialogue? Something like Invatorzens Dialogue Change? Right now I am using the combined girl mod for the portraits and sprites.
    1. gizzymo
      gizzymo
      • member
      • 259 posts
      • 24 kudos
      The bachelorette version of this mod should have 99% of the dialogue that 1.2.11 has, plus pronoun changes. Is that more or less what you're after?
    2. Chasm88
      Chasm88
      • member
      • 2 posts
      • 0 kudos
      I got it figured out. Thank you.
  8. RatchetTea
    RatchetTea
    • member
    • 2 posts
    • 0 kudos
    Hello! Love this mod
    Would you ever consider adding dialogue to characters from Stardew Valley expanded? Like Victor and Sophia etc
    1. gizzymo
      gizzymo
      • member
      • 259 posts
      • 24 kudos
      Thanks for playing with my mod! To answer your question, I'm sorry but I probably won't add any dialogue to SVE characters. I took a look at FlashShifter's dialogue files and they're already pretty substantially filled in. That is, SVE characters have the same or even more dialogue than the average character from vanilla+my mod. Thus, if I added more dialogue to them, it wouldn't make much of a difference.
  9. jagermeister92
    jagermeister92
    • member
    • 5 posts
    • 0 kudos
    Hi, I believe I asked this earlier but I cannot find it now. It has been a month in-game but there does not appear to be any change in dialogue. SMAP says it loaded the mod successfully but could not load Content Patcher . . . does that mean it will not work?

    It says Content Patcher must be updated but I have it on the latest version of 1.9.2.

    EDIT: It also says this mod is called Canon-Friendly Dialogue Expansion for Content Patcher 1.2.11 . . . does that mean THAT'S the version of Content-Patcher I need to have installed? DO I also need an earlier version of SMAP?
    1. gizzymo
      gizzymo
      • member
      • 259 posts
      • 24 kudos
      Hmm, yeah, if Content Patcher doesn't load, this mod won't appear in the game. I'm not entirely sure what would be preventing Content Patcher from loading, though. As long as you have the latest versions of Content Patcher and SMAPI and they're both installed correctly, it should work. If it's not, that'd be a question to ask at the Content Patcher board.
    2. jagermeister92
      jagermeister92
      • member
      • 5 posts
      • 0 kudos
      Here is my error log: https://smapi.io/log/1c515b985d5f4bde8752c00010cd868f

      Is it possible your mod requires an earlier version of ContentPatcher? It says "Canon-Friendly Dialogue Mod FOR CONTENTPATCHER 1.2.11" (Emphasis mine). However, I can't find a Contentpatcher of that particular version, just the 1.2 version
    3. gizzymo
      gizzymo
      • member
      • 259 posts
      • 24 kudos
      Sorry, it's all Greek to me. It looks like a Content Patcher issue. I don't see my mod being the cause of this error.
    4. jagermeister92
      jagermeister92
      • member
      • 5 posts
      • 0 kudos
      Okay, shoot, well I asked the guy who runs contentpatcher.
    5. jagermeister92
      jagermeister92
      • member
      • 5 posts
      • 0 kudos
      All right, I figured it out. Apparently ContentPatcher's version system is weird. Version 1.14.1 IS the newer version, not 1.9.2.

      I found it listed as "Main File" on the Files page.
    6. gizzymo
      gizzymo
      • member
      • 259 posts
      • 24 kudos
      Glad to hear it!
    7. kirisong
      kirisong
      • member
      • 1 posts
      • 0 kudos
      It's almost like 14 is a bigger number than 9.
  10. ExnoticTest
    ExnoticTest
    • member
    • 71 posts
    • 2 kudos
    Does this mod work with Immersive Festival Dialogue? Or should I get rid of it since this mod adds festival dialogue?
    1. gizzymo
      gizzymo
      • member
      • 259 posts
      • 24 kudos
      Yes, they are compatible. It's up to you whether you'd like to use them together.