Stardew Valley

File information

Last updated

Original upload

Created by

Gervig91

Uploaded by

Gervig91

Virus scan

Safe to use

48 comments

  1. Delianneb
    Delianneb
    • member
    • 4 posts
    • 1 kudos
    Sadly your mod also won't work with Starblue Valley World Recolor. I have no idea what's conflicting there, but all animations (except furniture) stop when you leave the house. I'm pretty sure the fault lies in Starblue mod, but I'm just warning anyone who might have a similar problem.
    1. Gervig91
      Gervig91
      • member
      • 224 posts
      • 86 kudos
      I'm pretty sure it's the same problem that Gweniaczek identified. If the mod uses the token "IsOutdoors", any items in the springobjects tilesheet will stop being animated (Furniture is not on this tilesheet).
    2. Delianneb
      Delianneb
      • member
      • 4 posts
      • 1 kudos
      Yes. You are indeed correct, thank you. I got rid of all path and craftable recolours, and now it works. Not a perfect solution, but most of what I love in Starblue mod stays, and I don't have to choose between the two.
    3. sorcerawr
      sorcerawr
      • member
      • 1 posts
      • 0 kudos
      I'm having the same problem with Starblue, do you think you could tell me what you did that made it work? Like where and how did you remove the path and craftable recolours? Thank you !!
    4. Delianneb
      Delianneb
      • member
      • 4 posts
      • 1 kudos
      Well, I just removed completely all of "Flooring" and "Craftables" from content.json inside of the Starblue folder. As I said, not a perfect solution, but it works. Remember to backup your file, before trying to do anything.
    5. Cypherscape
      Cypherscape
      • member
      • 10 posts
      • 0 kudos
      You don't have to erase or get rid of any line in content file, just go to the config in Starblue Valley and set what you want to "false". that way you dont change the mod, you just turn off certain settings
    6. Delianneb
      Delianneb
      • member
      • 4 posts
      • 1 kudos
      I tried to set it to false before removing it, it just didn't work for me. So I was forced to delete it.
  2. thanksofia
    thanksofia
    • member
    • 19 posts
    • 1 kudos
    hello there! this mod is just lovely and adds even more life to the game. thank you for making it!!
    anyway, i was wondering if you plan on adding the new fish from SVE? seeing just those poor creatures lying limp in my collections screen is quite saddening lol.
    no biggie if you dont plan on doing it tho! just didnt see anyone addressing it, so why not ask it myself and get rid of the doubt?
    love your work <3
    1. Gervig91
      Gervig91
      • member
      • 224 posts
      • 86 kudos
      I don't have any plans on doing it because I don't use SVE. I will however look into it, no promises
    2. Gervig91
      Gervig91
      • member
      • 224 posts
      • 86 kudos
      Ok I did it! Mod can be found here.
    3. thanksofia
      thanksofia
      • member
      • 19 posts
      • 1 kudos
      oh my! wasnt expecting it to be done so quickly and efficiently, thanks so much for the continued great work <3
  3. sameerxxe
    sameerxxe
    • member
    • 13 posts
    • 0 kudos
    Hey,
    Love your work. Brings a new life to the game, especially this mod since I focus more on fishing.

    I am here today to make a request. I was hoping you could make animations for the fish from More New Fish mod (https://www.nexusmods.com/stardewvalley/mods/3578). I know you will need permission from the creator and a lot of time and work, but I am leaving the suggestion here just in case this ever becomes a reality. Don't let it bother you though, if it doesn't happen.

    I will look forward to see more of your work here.

    Best of luck to you and take care!
    1. Gervig91
      Gervig91
      • member
      • 224 posts
      • 86 kudos
      Great idea! I will see what I can do, no promises.
    2. Gervig91
      Gervig91
      • member
      • 224 posts
      • 86 kudos
      I did it Uploaded the mod here!
  4. ezeliastarsong
    ezeliastarsong
    • member
    • 24 posts
    • 1 kudos
    Strange how after your updated animation mods stopped working. I set Gwen's Medieval Craftables' sprinkler to false in the config files, but only the house decor still functions :( Sad that the fishy, gems and food don't move anymore...
    1. Gervig91
      Gervig91
      • member
      • 224 posts
      • 86 kudos
      Does the old version work for you? If not, it might be another mod conflict. You can test this by running the game with only the required mods.
    2. ezeliastarsong
      ezeliastarsong
      • member
      • 24 posts
      • 1 kudos
      I've switched to an older patch, and still come up with the same issue. Animations stop once I leave the house, which is odd. I'll have to test out which mods may conflict with them. Have any ideas to help me narrow it down? I am using SVE, Immersive Farm, Mermaid Island, CP, JA, PFM, PPJA, TMXL, JsonAssets, CJB, clothing mods, Elle's new animals... list goes on :(
    3. Gervig91
      Gervig91
      • member
      • 224 posts
      • 86 kudos
      Did it work with only the required mods? Can you try and send me a link of your SMAPI log. https://smapi.io/log
  5. xWhyss
    xWhyss
    • member
    • 9 posts
    • 0 kudos
    Hey thanks for your mods i love it ! But i've an issue, when i get out my farm everything from your mods stop moving (except furnitures). Any idea? I'm using a lot of mods so it's problably a conflict. There is my log: https://smapi.io/log/f6cd9d68bb9c4977858babfed387ac47
    Sorry for my bad english.
    1. xWhyss
      xWhyss
      • member
      • 9 posts
      • 0 kudos
      I fixed my problem by disabling Sprinklers replacement in Gwen's Medieval Craftables... Still don't understand but your mods work fine now <3
    2. Gervig91
      Gervig91
      • member
      • 224 posts
      • 86 kudos
      Glad you got it working. Yea, I still haven't figured out what is causing some of the mod conflicts
    3. ariasonata
      ariasonata
      • member
      • 19 posts
      • 1 kudos
      I'm having the same problem, all the animated ones are stopping as soon as I leave my farmhouse... had to take them down for now until I can figure out why... awesome work though :)
    4. Gervig91
      Gervig91
      • member
      • 224 posts
      • 86 kudos
      Try and run the game with only the required mods. If it works that way, you'd know it's a mod conflict.
    5. ariasonata
      ariasonata
      • member
      • 19 posts
      • 1 kudos
      I tried what xWhyss did, and he's right, Gwen's sprinklers somehow messes with the animations. That turned off, and everything works fine. Strange, but I'll take it lol.. your work is too awesome
    6. RustyButt
      RustyButt
      • member
      • 5 posts
      • 0 kudos
      Same thing happened to me but from the looks of it the sprinklers are just messing up content patcher animations mod so I don't think there is anything you can do to fix it in your mod
    7. Gweniaczek
      Gweniaczek
      • member
      • 363 posts
      • 325 kudos
      I heard about the incompatibility and tested quite a lot. Seems like the problem is that CPA doesn't like "IsOutdoors" token and if it's used in springobject edit it makes all animated items from that tilesheet stop moving :c I checked for both this and other mods. I'm going to change my craftables mod coding to not use "IsOutdoors" for sprinklers so the incompatibility will be solved in my next update. Till then just disable sprinklers in my config.json cx
    8. Gervig91
      Gervig91
      • member
      • 224 posts
      • 86 kudos
      Thanks Gwen! <3
  6. Squirrelman1020
    Squirrelman1020
    • member
    • 25 posts
    • 1 kudos
    Holy! Another new animation mod again. I love it. <3
    1. Gervig91
      Gervig91
      • member
      • 224 posts
      • 86 kudos
      Thank you! It’s comments like yours that make me do what I do
  7. xXDarkDragon7Xx
    xXDarkDragon7Xx
    • member
    • 2 posts
    • 0 kudos
    hey thanks for the great mod! just noticed an issue though where I get quite a bit of screen stuttering when using the mod (even when there are no animated fish displayed on screen). I only have this mod installed (as well as SMAPI, CP and CPA obviously). do you know what might cause this kind of performance in the mod?
    1. Gervig91
      Gervig91
      • member
      • 224 posts
      • 86 kudos
      That is strange, I was able to run all my animation mods on my potato laptop with a stable 60 fps. Does the stuttering go away when you remove this mod? If not, it might be something else that is the issue. Have you checked that your drivers are updated? Maybe try changing between fullscreen and windowed borderless (I've read that some people fixed performance issues like that). Hope this helps, would love to hear back from you
    2. mewgulf1314
      mewgulf1314
      • member
      • 3 posts
      • 0 kudos
      lt can not work with your another animated mods,?Animated furniture and stuff,Animated slim eggs and loot.which made me so upset
    3. Gervig91
      Gervig91
      • member
      • 224 posts
      • 86 kudos
      All my mods are compatible with each other, could you maybe upload a SMAPI log and send me the link? https://smapi.io/log
    4. mewgulf1314
      mewgulf1314
      • member
      • 3 posts
      • 0 kudos
      Https://smapi?Io/log/ 4d7c21575aeb47f79e8e1af8a518b758
    5. Gervig91
      Gervig91
      • member
      • 224 posts
      • 86 kudos
      I haven't tested it on android, so that might be why it's not working. I can't see any problems in the logs. Is it just the animated fish mod that isn't working?
    6. mewgulf1314
      mewgulf1314
      • member
      • 3 posts
      • 0 kudos
      yes,only the animated fish cannot work,Animated furniture and stuff and Animated slime eggs and loot can work,
    7. Gervig91
      Gervig91
      • member
      • 224 posts
      • 86 kudos
      Maybe there is a conflict. Try and run the game with only SMAPI, Content Patcher, Content Patcher Animations and Animated Fish. If it works then you’d know it’s another mod that is the problem.
  8. yamabukaza
    yamabukaza
    • member
    • 4 posts
    • 0 kudos
    https://www.nexusmods.com/stardewvalley/mods/4922

    Cannot be used together
    1. Gervig91
      Gervig91
      • member
      • 224 posts
      • 86 kudos
      Yes unfortunately that mod is not compatible with content patcher animations, which is required for all my animation mods
  9. Kaed31
    Kaed31
    • member
    • 40 posts
    • 1 kudos
    You need to reach out to a content creator that reviews mods dude no joke.
    1. Gervig91
      Gervig91
      • member
      • 224 posts
      • 86 kudos
      That would be cool, but I'm kinda shy So I don't really reach out to people. That being said, all of my mods allow users to upload images and videos using my mods, without my permission.
  10. Kaed31
    Kaed31
    • member
    • 40 posts
    • 1 kudos
    If your running out of animation Ideas you could give ore and bars a sorta Glint to them like a shine just a suggestion maybe to go with some new weapons animations. Anyway just some suggestions keep it up.
    1. Gervig91
      Gervig91
      • member
      • 224 posts
      • 86 kudos
      undare's Animated Gemstones mod has some reskinned ores and bars. I love this mod and it inspired me to go on this modding rampage :P Been waiting to see if he or she would update to animate them. But yea I might make my own version of animated gemstone with ores, bars and stuff. Keeping the default art from the game like my other mods.

      As for weapons, I do want to animate some more weapons. I don't know if I should upload a new mod or update my old Animated Prismatic Galaxy Sword mod and add it there. I'm afraid if I just do updates, the mod will go under the radar for most people.