File information

Last updated

Original upload

Created by

Moolgogi

Uploaded by

proarmine

Virus scan

Safe to use

Tags for this mod

About this mod

Dawnguard Required

Skyrim version has to be 1.9.32.0 or higher

Permissions and credits
Top