18612 comments

  1. schlangster
    schlangster
    • supporter
    • 1,107 posts
    • 1,236 kudos
    Locked
    Sticky
    Thanks to everyone who has shown their support for this project, either by making a donation, or in any other way. We truly appreciate it!
  2. schlangster
    schlangster
    • supporter
    • 1,107 posts
    • 1,236 kudos
    Locked
    Sticky
    Uploaded version 5.1.

    Changes from last version:

    5.1:

    [General]
    - Brought back previously removed category icon themes for item menus.

    [ModConfigurationMenu]
    - Updated API to version 4.
    - Added text input option type.

    [AlchemyMenu]
    - Fixed layout issues in the effect list.

    [EnchantingMenu]
    - Fixed wrong soul level info for partially filled soul gems. Actual fix comes with next SKSE update.

    5.0:

    [General]
    - Updated SKSE version requirement to 1.7.3.
    - Improved various icons.

    [FavoritesMenu]
    - Fixed issue with equipping two identical armor base items that have different names.
    - Less eager purging of invalid group data to avoid unwanted group resets.

    [ModConfigurationMenu]
    - Tweaked mod registration timing.

    [AlchemyMenu, CraftingMenu, EnchantingMenu, SmithingMenu]
    - Initial release
  3. schlangster
    schlangster
    • supporter
    • 1,107 posts
    • 1,236 kudos
    Locked
    Sticky
    If you're getting a "SKYUI ERROR CODE X" message and you don't know what to do, please have a look at this page first.

    Common question: I don't like the new crafting interface (or any other part of SkyUI). Can I disable it?

    Yes. There's a mod called SkyUI-Away, which contains the original UI files. Extract those original menu files you want back to Data/Interface.
  4. Halo3paulieD
    Halo3paulieD
    • member
    • 2 posts
    • 0 kudos
    Every time i try to unequippe a peice of armor in my menu, my game crashes. Send halp
    1. Shubal
      Shubal
      • premium
      • 3,243 posts
      • 63 kudos
      If it is the chest piece you have a skeleton conflict I believe.
  5. metko
    metko
    • supporter
    • 55 posts
    • 2 kudos
    hi, i have an odd problem ( not serious ) and just wanna know what could fix it.
    Its been half a year since i played skyrim and today i wanted to start again. The "Favorite" hotkey seems to be the "Pause" button but the the hotkey in the MCM is set to Default "F"
    and changing and reasigning it didnt solve the Problem.

    The only thing that changed was that i reinstalled my OS on my Computer and updated mods from Enai Siaion and added some armor mods( kept everything in NMM load order intact )
  6. CodeNamed1
    CodeNamed1
    • premium
    • 135 posts
    • 0 kudos
    I need some HELP. For some reason when i use the group function. Press like F2 and IF i have made For example the armor piece stronger So that after it name there reads something in [xxx] For some reason it dosen’t dress those pieces and i have to manually dress them. Anyone know why this happens??

    It only hapens on this enhanced armor or weapons Not in some non enhanced pieces
    1. Vyxenne
      Vyxenne
      • premium
      • 2,116 posts
      • 111 kudos
      This is a well-known issue- it's called the Ghost-Item issue and is the only known bug (as far as I know) in SkyUI-5.2SE. It happens when you temper an item that is Favorited and Grouped. The new [Legendary] or [Flawless] item appears in the group but will not equip with the group because the group mistakenly "thinks" the original item (before you tempered it) is still there so it tries to equip that. There are two workarounds- one to avoid the situation entirely , and the other to fix it when you fail to avoid it.

      To avoid Ghost Item due to Tempering it: Never Temper an item without removing it from all groups that it is in first. As an additional precaution, Un-Favorite the item as well. After Tempering the item, Favorite it again and add it back to whatever groups you want it in. Yes, I know this is a royal pain. If you think it's too much trouble, you won't want to bother reading the next section at all.

      To fix a Ghost Item due to Tempering:
      1. Remove the Tempered item from all groups that it appears in
      2. Un-Favorite the item
      3. Obtain a duplicate copy of the item- that means the untempered item. If you can't afford to buy it, use the console to poof it into your inventory- you can always throw it away after you fix the problem if your conscience bothers you over "cheating" the item into your bags.
      4. Favorite the untempered item
      5. Put the untempered item into whatever groups the Tempered item was in. Do this even if you no longer wanted the item in a particular group.
      6. Sprinkle fairy dust around your computer and click your heels 3 times.
      6 for real this time. Wait a couple of minutes for SkyUI to catch up to what you just did, then change cells- fast traveling to another hold should do it
      7. Remove the untempered item from all the groups you put it in. Do this even if you want that dagger in that group after all.
      8. Un-favorite the untempered item
      9. Re-favorite the Tempered item and put it in whatever groups you want it in
      10. Equip one of the groups the Tempered item is in and give cdcooley a Kudo when it equips normally.
      11. From now on, follow the avoidance strategy above. Failure is not an option.
    2. CodeNamed1
      CodeNamed1
      • premium
      • 135 posts
      • 0 kudos
      OMG Okey For now on i will do all i can to avoid this Thx For advice and info
    3. Vyxenne
      Vyxenne
      • premium
      • 2,116 posts
      • 111 kudos
      I forgot to mention that there have been a few reports that weapons don't equip reliably from Equipment Groups regardless of not encountering the Ghost Item bug. I haven't experienced this myself, but others have. What I have done in my game to be on the safe side is hotkey my weapons instead of putting them in Equipment Groups. Works great for me because I only use 2 weapon configurations: bow and dual-daggers. Unfortunately, there's no way that I know of to hotkey dual daggers- only one will equip. and if you hotkey both of them (say, 1 for the right and 2 for the left) both hotkeys will equip their respective daggers to your right hand. So if you hit #1, that dagger will pop into your right hand, then if you hit #2 it will replace the #1 dagger in your right hand. There is no left-hand-equip hotkey.

      However, if you manually equip your daggers (left and right hands) and then press your bow hotkey, of course it will replace both daggers, but here's the great part- with your bow equipped, if you press your bow hotkey again, it will not only unequip your bow, but BOTH daggers will re-equip themselves into your left and right hands! So I'm able to manage 3 weapons on one hotkey.
  7. Arlyana
    Arlyana
    • supporter
    • 29 posts
    • 0 kudos
    for some reason my NMM does not want to activate this mod for me after i uninstalled it and reinstalled it to make sure i have the most current version.
    1. Vyxenne
      Vyxenne
      • premium
      • 2,116 posts
      • 111 kudos
      Some people have to run NMM as an Administrator in order to get it to successfully write to Plugins.txt. I gather from your post that NMM normally installs and activates everything just fine and it's only SkyUI that refuses to stay activated. That being the case, you're probably going to have to explicitly set Skyrim.esm as a Master for SkyUI.esp. Here's the easiest way to do it:

      Spoiler:  
      Show





      Blow me a kiss as you enjoy your game.
    2. TheAwesomeTRex
      TheAwesomeTRex
      • member
      • 621 posts
      • 9 kudos
      It's always useful to look over these comment sections! I've recently decided to reinstall my game and I kept running into this problem where ModOrganizer would not install the thing properly, some "error 5" message kept popping up making the installation process shut down on its own! Somehow the last thing in my mind at the moment was to run ModOrganizer as the Admin, even though I'm 100% sure I've done that multiple times before! This time I just forgot, you effectively kept me from doing some stupid crap and breaking the whole thing by some dumb mistake. Thanks! And I hope you have lots of sex tonight!
    3. MistakenMystic
      MistakenMystic
      • supporter
      • 1,502 posts
      • 45 kudos
      If you find yourself having to run MO, or any other tool on your system, as admin then you need to look closely at your system and find out why.
      Windows 10 is known to stuff up users with its over-the-top UAC features that seem to exist even when you turn them off.
      Basic rule of thumb should be: never run anything as admin unless it is to make system-wide changes to your machine. Since modding or playing a game does not fall under that description there is no reason to do it.
    4. Vyxenne
      Vyxenne
      • premium
      • 2,116 posts
      • 111 kudos
      @TheAwesomeTRex:
      Thanks! And I hope you have lots of sex tonight!
      You're welcome! And I think I love you!

      @MistakenMystic:
      Windows 10 is known to stuff up users with its over-the-top UAC features that seem to exist even when you turn them off.
      Make that 'all versions of Windows since XP,' not just Windows 10. And forgive me for respectfully pointing out that this statement quoted above contradicts the rest of your post! Windows UAC is out of control- Microsoft has dumbed down its OS to protect users from themselves. You would think they wouldn't care, since they offer no actual support whatsoever to non-megacorp users other than Windows Update, but when you realize that they have been moving toward "Windows as a Subscription-Based Service" instead of a one-time purchase that you then own an unlimited license to use, you understand why it is important to them to essentially remove the (implied: stupid) user from the equation by establishing draconian, intrusive, unruly, uncontrollable UAC and to hell with what the users want. In a "Windows as a Service" environment, it is very much to their benefit to completely "protect" the system from users by denying us the right to control it. Establishing Windows as a Service is why they tried to give away Windows 10 absolutely free, even stooping to deception and trickery to force users into "upgrading" from Windows 7 to 10. The primary new feature of Windows 10 is complete removal of any user control whatsoever over which updates are applied to our systems and no ability to reject those we don't need or want. Under Windows 10, you will get them all and stuff it if you don't want a huge Mandarin Chinese crapdate on your computer as a housewife in Iowa- you're getting the bloatdates anyway.

      Once all Windows machines are configured exactly the same with no user control whatsoever, supporting all of them (as a Subscription Service) requires only knowing how to support ONE of them since they're all the same, whether we like it or not.
      Basic rule of thumb should be: never run anything as admin unless it is to make system-wide changes to your machine. Since modding or playing a game does not fall under that description there is no reason to do it.
      I'm resisting the urge to comment on how apt your user name is. This is just wrong. You yourself stated that Windows UAC is out of control and operates regardless of choices that users may make to control it. So there is every reason for users to have to run installers and tools as Admins given the facts of user-hostile, unpredictable, absurdly-restrictive Rogue UAC in Windows.
    5. MistakenMystic
      MistakenMystic
      • supporter
      • 1,502 posts
      • 45 kudos
      Hey @Vxyenne
      Let me correct you on one or two points.
      I stated Windows 10 has over-the-top UAC features because that version of Windows seems to exercise more control of how they are set than all other versions. I am fully aware of UAC being a feature in all previous versions, that is not the intent of my comment.
      I also did NOT say "Windows UAC is out of control", which is why I am making the assertion the user CAN get control of their system IF they know of how insidious MS's reach is. Part of this "taking control" is making sure the user never needs to run any gaming tool as admin.

      I've been reading your posts in a number of mod pages and you are clearly better than this. Don't resort to trying to humiliate others to reinforce a stance you take. Let's not make this a flame war, I actually admire what you do. You have no inherent investment in these mods other than you use them and want to help others do so. Why demean what you do by cheap shots at me?

      This topic could probably be debated at length but let's not clutter this forum with that. If you really feel the urge to, you can PM me, though I am not that invested in doing so. However I will reassert my stance: using admin privileges to bypass issues is not a good method of computer management.
      In the long run though, it's your system you can do what you want.
      You too enjoy your game. ;)
  8. Theoras183
    Theoras183
    • member
    • 4 posts
    • 0 kudos
    Why i push "F3" and "F4" nothing happened for activate the group 3 and 4?
    This butto is actived in the configuration.
    I dont understand why?
  9. Sayo97
    Sayo97
    • member
    • 6 posts
    • 0 kudos
    I had problems earlier in which I kept getting error 5 with SkyUI, I then found out that an 60FPS interface was causing it so I disabled it then uninstalled and reinstalled SkyUI. SkyUI is working but now my skill tabs is gone as if I installed Enderal which I did not. I have no idea why this is happening and it's really frustrating, it's literally been one problem after another all day and I'm sick of it. I even tried searching this up but the only results were for people who downloaded Enderal. Any idea what has been causing this?
    1. Vyxenne
      Vyxenne
      • premium
      • 2,116 posts
      • 111 kudos
      it's literally been one problem after another all day and I'm sick of it.

      Spoiler:  
      Show




      There. Now that we've got you all calmed down, take a look in your Data\Interface folder and delete (or move to another folder for safekeeping) any swf files you see there because apparently one of them is not playing nice with SkyUI.
  10. NexusKnight
    NexusKnight
    • supporter
    • 503 posts
    • 6 kudos
    Unfortunately I have almost the same problem as Vyxenne but I haven't sold or lost any items. Like, whenever I attempt to equip a weapon or hotkey a weapon near a particular tower that I haven't identified yet (it's hostile), my game CTD's without fail. I found other similar online comments that identified the problem to be associated with this mod, and Vyxenne's problem seems to support this. I've checked my version is up-to-date but I haven't played for ages due to playing Fallout 4 instead. (I'm waiting for an F4SE update and ended up here...what luck.) Anyway, just wanted to bring this to everyone's attention in case it helps towards a potential fix (if it is SkyUI related).
    1. Vyxenne
      Vyxenne
      • premium
      • 2,116 posts
      • 111 kudos
      Although I'm sure that everything posted on the interwebs by people like us who don't really know what we're talking about is 100% true blaming SkyUI for CTD when you simply get near a tower and equip something seems a bit far fetched no matter how many people think it's SkyUI's fault. Also, from what you posted, this is not even remotely similar to the 'ghost item' issue, which does not cause a CTD but instead simply fails to reliably equip that item. The only time I've seen CTDs related to SkyUI is when loose swf files (from other mods or previous SkyUI installations) are erroneously left in Data\Interface, and the fix for that is easy- delete them because all of SkyUI's menu files are in the bsa, not loose in Data\Interface..

      If you'll give me the name of the tower (you can look it up on UESP if you are unable to sneak close enough to it to "ding" it as discovered) I'll go see if I get the same issue, but I seriously doubt that SkyUI could do that just because of the mere proximity of some map point, NPC, landmark or terrain feature, simply because SkyUI doesn't interact with any of those things except some NPCs and only if they're vendors.
    2. NexusKnight
      NexusKnight
      • supporter
      • 503 posts
      • 6 kudos
      @ Vyxenne... Can I take that last post back plz? I apologize for my hasty and faulty assumption above. It wasn't meant as a criticism of this fine mod. The fact is I didn't have time to do the proper research and thought it would be quicker to make a simple post here. I should've known better as I endorsed this mod a few years ago and haven't had any problems from it since. This morning I found the fort in question to be Fort Dunstad, which google reveals to have several similar CTD problems posted about it. Had I the time to do this before the above post, I wouldn't be in hot water with you now. I apologize, I was the idiot in this case. I didn't even get the poster's name I was referring to, right! Yep, this was stupid of me...sorry. So now having the proper culprit in hand I'll do some more digging and see if I can resolve the issue myself. This is how it should have gone anyway, sorry to trouble you with this...I've just gotta stop over-reacting to minor issues. However, I'll check back later in case you have any experience with this area or other advice, and thank you for your quick reply.
    3. Vyxenne
      Vyxenne
      • premium
      • 2,116 posts
      • 111 kudos
      in hot water with you now
      *hugs NexusKnight warmly*

      No worries, I was tired (or slightly wine-buzzed) when I stumbled on your post and somehow my snark is more easily triggered in the wee hours... I'm pretty sure it's not the wine... Sorry if I seemed harsh.
      I was the idiot in this case.
      Almost all of the best times of my life have been while, or immediately after, I was being an idiot. And yes, I did sometimes regret it in the morning... briefly... I am such a bad liar...

      I'm still SO going to Ft. Dunstad later though, just to see if I crash on approach... So thanks for that tip.
    4. NexusKnight
      NexusKnight
      • supporter
      • 503 posts
      • 6 kudos
      I understand...it must be difficult sometimes dealing with so many people from many cultural differences and some with attitude . It helps to laugh it off with a good sense of humour I find (or a glass of wine). Anyway, I appreciate you being here to listen to my problems and your understanding. It gets lonely playing by yourself sometimes and when things break, you just wanna reach out. It's nice to know someone is there, I do appreciate that. Kudos to your dedication for being the main help here. Hope fort dunstad treated you nicer than it did me...still crashing!
  11. r131
    r131
    • member
    • 386 posts
    • 3 kudos
    Strange bug - Never had it noticed before:

    I had a game started, all is fine, some favorite weapons were assigend to hotkeys
    Bug started 'probably' after I sold a favorited weapon ... (probably!)
    I CTD as soon as I open the favorite menu

    I compensated that issue by switching to "Categorized Favorites Menu" - at least, now I have a usable faborites menu again
    But I CTD whenever I try to reassign any hotkey

    Any hint, how I coud try to fix either of that or where I could read more?

    Where and how are the assigned hotkeys stored anyway?

    Thank you!

    ​PS: I tried an older save and even there (native SkyUI, no CFM) I crash as soon as I want to reassign a hotkey to a weapon.
    1. Vyxenne
      Vyxenne
      • premium
      • 2,116 posts
      • 111 kudos
      Try this- obtain an exact duplicate copy of the item you sold. Use the console if you can't afford to buy it. If the one you sold was Tempered, temper the new one to the same level (Flawless, Legendary, etc.) If the old one was Enchanted, put the same enchantments on it, and rename it too if you had done that with the old one. Your objective is to create an exact duplicate of the Favorited>Hotkeyed item you sold.

      Now, with an exact duplicate of the item in your inventory, open your inventory and Favorite the item. DO NOT OPEN YOUR FAVORITES MENU! Close the inventory and wait a few moments, change cells to force reloads of everything (fast-traveling to another Hold is best), then open the Inventory and unfavorite the item. Close the inventory again and wait a few moments again, then fast-travel to a different hold again.

      Now try to open your Favorites menu. If you're lucky, the "ghost item" has been removed from your hotkey records and all will be well. Plus, as a bonus, you now have not one but TWO of the weapons. Be sure to un-hotkey (assign that hotkey to any item you're not selling) and un-favorite the item before you sell it!
    2. r131
      r131
      • member
      • 386 posts
      • 3 kudos
      Thanks! Will try that
    3. r131
      r131
      • member
      • 386 posts
      • 3 kudos
      It didn't work as I had hoped for.
      Pretty sure, my exact copy was not that exact as it was needed. So I will try that again.

      But isn't there a simpler approach in SkyUI to reset that whole favorite system? I don't mind to assign everything from scratch again.
      Something similar to that "setstage skiconfigmanager ....." , perhaps?

    4. Vyxenne
      Vyxenne
      • premium
      • 2,116 posts
      • 111 kudos
      cdcooley said several months ago that there is a way to clear out all stored favorites and grouped items including ghost items, but he never explained how to do it. Here is the exact quote and the full cdcooley post:
      The best after-the-fact fix [to a ghost item created by tempering the item while it is in an Equipment Group] is to get a second copy of the original item you improved or enchanted. With it in your inventory you can correct the favorite group problems. There's also a way to clear that particular script of its values but that will wipe out all of your equipment groups.


      So there is such a method to clear ghost items, but I don't know it. Sorry.
    5. r131
      r131
      • member
      • 386 posts
      • 3 kudos
      Thank you anyway. So I will have to wait patiently until that solution is posted somewhere
    6. Vyxenne
      Vyxenne
      • premium
      • 2,116 posts
      • 111 kudos
      As I thought some more on this issue, I don't believe it is necessary to temper and enchant the "new" item you are acquiring to try to clear an "identical" ghost item... I think if you just get the same base item it might be sufficient to clear the ghost item because it has the same FormID.

      As you can see from the quote and the full cdcooley post, he just said to get a "second copy" of the item you tempered or enchanted, but he doesn't say that we should temper and enchant it to match our newest version of the stuck item- in fact a literal reading of his words implies the opposite. The item that got "stuck" in my inventory (in SSE using SkyUI_SE) was a pair of my bright white Converse Shoes low-top sneakers (I'm all about the Lore ) that stopped equipping from the Groups when I tempered them, and I fixed it by re-acquiring an untempered pair.

      So I think the answer is that we should acquire a "second copy" of the item as it was when we originally Favorited and/or placed it into a Group.
  12. RonianTheGreat101
    RonianTheGreat101
    • member
    • 6 posts
    • 0 kudos
    There's no upcoming SkyUI Updates? That's sad :c
    1. Vyxenne
      Vyxenne
      • premium
      • 2,116 posts
      • 111 kudos
      Actually, it's great news! It means (almost) all the bugs have been worked out, the only anomaly remaining can be easily avoided and there's no need for new features because the current ones are astonishingly popular and meeting everyone's needs.
  13. djiscool4545
    djiscool4545
    • premium
    • 4 posts
    • 0 kudos
    hey there im prob the only with prob when i open my inventory it takes and extra 3 to 4 seconds i know to some people thats big deal but its bugging me any help would appreciated .
    1. Vyxenne
      Vyxenne
      • premium
      • 2,116 posts
      • 111 kudos
      hey there im prob the only with prob
      So, "prob" means both "probably" and "problem" too? What about "probation," "proboscis," "probate," "probiotic" and "probing?" We could say "prob" to mean any of those and more! Hey, this is a great trend, let's whittle down all the words in the English language to one word - "glunk" - so from then on we can just go "Glunk, glunk! Glunk glunk glunk & glunkitty glunkish glunks!" to each other and nobody will have to actually study or read a book to find out what words mean because they will all mean the same thing: nothing. Whee!

      And no, you're not the only prob with the same prob in your prob while you're probbing (sp?) - both you and Jennibolen posted the exact same issue on the exact same day, except s/he used actual words . Please see my response to him/her.
REPORT BUG
Top