Mount & Blade II: Bannerlord
0 of 0

File information

Last updated

Original upload

Created by

ZiggiBoy101

Uploaded by

ZiggiBoy101

Virus scan

Safe to use

169 comments

  1. Freewar
    Freewar
    • member
    • 60 posts
    • 4 kudos
    Locked
    Sticky
    Very interested in testing this. Will report back with my results. 
    1. Freewar
      Freewar
      • member
      • 60 posts
      • 4 kudos
      THE RESULTS ARE IN. THIS IS THE ACTUAL SIEGE FIX WE HAVE BEEN WAITING FOR.
      Siege towers actually work now. Like 80% of the time you will see all three lanes at max capacity with only minor gaps between usage.

      I had one situation where some bots at the foot of the siege tower all decided at the same time they needed to go somewhere else and that blocked everybody else who wanted to climb, but that lasted only for a minute or so, but issues such as defenders climbing down, attackers climbing back down and general under usage are really gone with this mod outside of the situation I have just described. This fix is absolutely insane, we waited 565 days for this. Thank you very much ZiggyBoy!
    2. ZiggiBoy101
      ZiggiBoy101
      • member
      • 18 posts
      • 8 kudos
      Thank you so much! I hope the community will get as much joy and excitement from this mod as you will!
  2. suchek
    suchek
    • member
    • 2 posts
    • 0 kudos
    Locked
    Sticky
    It worked properly in 1.6.3, but it seems that there is a problem in 1.6.4.
    Soldiers ignore ramp completely and just push into a wall.
    1. ZiggiBoy101
      ZiggiBoy101
      • member
      • 18 posts
      • 8 kudos
      Yeah.. This is not my mod. I have tested it and it can happen with and without my mod.
      But i see this problem on mostly on 1.6.4 and sometimes on 1.6.3
      Even the small ramp towers navigation stops working sometimes, and i have not changed anything on that.

      The towers basically have their navigation broken and from what i have been able to figure out, it is from some invisble physics object that spawns in the way of the ramps navigation mesh. But again, i haven't added that, so i really don't know how to fix that, and believe me when i said i have tried.

      My mod works better in 1.6.2. So if you want a more stable experience, i can recommend reverting your game version.
  3. Androme
    Androme
    • member
    • 190 posts
    • 1 kudos
    Thank you for your service. Thank you for forcing Taleworlds lazy ass to fix the sieges themselves.
    o7
    1. Joker860
      Joker860
      • member
      • 855 posts
      • 7 kudos
      Did they do it?
    2. Androme
      Androme
      • member
      • 190 posts
      • 1 kudos
      Seems that way, yes.
  4. ieatlasagnawithcheese
    ieatlasagnawithcheese
    • member
    • 17 posts
    • 1 kudos
    Been using this mod on 1.6.4 for multiple weeks now and no issues so far.
  5. Misguidedcolt88
    Misguidedcolt88
    • member
    • 9 posts
    • 0 kudos
    Is really is a shame this mod broke so soon after releasing. 
    I tested in 1.6.5 beta and all my troops just sat at the base of the wall next to the siege tower. 0% of troops got on the siege tower. During the same scene in vanilla, troops used the siege towers as normal with towers being around 30% full.
    But i only tested 1 scene. 
    1. Lndbrghwrstlr
      Lndbrghwrstlr
      • member
      • 1 posts
      • 0 kudos
      My troops stand around at the base of the tower in vanilla mode and do nothing so that's not a bug from this mod alone. 
  6. RedBaronFlyer
    RedBaronFlyer
    • member
    • 5 posts
    • 0 kudos
    It's weird, I was testing it in 1.6.4 to see how it was broken, and the towers seem to work fine on the maps I was testing. All three ladders of the siege tower were being used, and units can get onto the walls fine but with a little bit of a delay. I don't know if a hotfix between your announcement of it not working with 1.6.4 and now fixed it or what. I will need to do more testing to make sure. The only time I saw wonkiness was a small traffic jam that lasted a few seconds in the middle of the siege tower because the battle had reached the point where some of the infantry were starting to rout, but retreat hadn't been called.

    Is the invisible physics object only occurring on certain maps, or is it just a random chance it happens?
  7. gabasos
    gabasos
    • member
    • 1 posts
    • 0 kudos
    HI ZIGGI BOY !!
    thank you so much for your work! really appreciated... BUT... you say that works better in 1.6.2. wich fortunately i have; and it does not work at all... yes i tried several times and in different maps.... Any advise?? wish you good fortune. 
                                                                                                                                      gabo.
  8. Joker860
    Joker860
    • member
    • 855 posts
    • 7 kudos
    Could anyone update this mod?
    1. Ping827
      Ping827
      • member
      • 278 posts
      • 0 kudos
      ^ please do . Im on 1.6.4 and can’t stand the siege towers etc
    2. Joker860
      Joker860
      • member
      • 855 posts
      • 7 kudos
      TW should have fixed this bug, in the next update.
  9. Sebdur91i
    Sebdur91i
    • supporter
    • 14 posts
    • 0 kudos
    Sur 1.6.3, c'est bien, mais alors sur 1.6.4, c'est 50/50, possible de revoir cela ?  
    1. ieatlasagnawithcheese
      ieatlasagnawithcheese
      • member
      • 17 posts
      • 1 kudos
      Translation cuz im a good damn genius: "It's good in 1.6.3, but in 1.6.4 it's a 50/50. Any way to fix this?
  10. irulannaba
    irulannaba
    • supporter
    • 1,132 posts
    • 14 kudos
    1.6.4 stable? is it working there?
    1. MephistoXVI
      MephistoXVI
      • member
      • 1 posts
      • 0 kudos
      It seemed to work fine for me on 1.6.4, no crashing or discernable severe performance problems. Like it says on the tin, there's still weirdness now and then because of Taleworld's pathfinding but they use all three ladders of the siege tower in every siege I've led, it just takes them a moment to hop on sometimes.

      Edit: Although I just read in the description that there's apparently a problem in 1.6.4 on TW's part that stops the fix from functioning. It's strange because even after the hotfix for 1.6.4, I haven't noticed a single time that the AI remained bunched up on one ladder. I must've been very lucky, or only certain region's castles have this issue. If it means anything, all of my siege battles with the fix so far took place entirely in Vlandia, Battania and Sturgia.
    2. ZiggiBoy101
      ZiggiBoy101
      • member
      • 18 posts
      • 8 kudos
      It may sound like a weird question. But which ones of the files did you download?
    3. Zafermagnes
      Zafermagnes
      • member
      • 1 posts
      • 0 kudos
      I just tested it in 1.6.4 and I can confirm that it works as intended. I guess not all regions are affected by this issue. I downloaded the ''SiegeTowerFix(Core module) Version 1.1.0'' file if that's what you are asking about.
    4. Joker860
      Joker860
      • member
      • 855 posts
      • 7 kudos
      Anyone else could share his experience?
  11. Cyraxmon
    Cyraxmon
    • member
    • 5 posts
    • 0 kudos
    I'v been playing for awhile now on 1.6.4 stable and until now i can't find any issue with the mod.
    I'm using the SiegeTowerFix(Core module) Version 1.1.0-3345-1-1-0-1633669074.
  12. Rhyagell
    Rhyagell
    • member
    • 80 posts
    • 1 kudos
    Of course TaleWorlds created a problem that breaks the mod that fixes their own problem. What a joke of a game company. An absolute joke. 
    1. RikimaruLDR
      RikimaruLDR
      • supporter
      • 275 posts
      • 9 kudos
      It's ok, in their next dev update they announced multiplayer changes!  
      ...  
      ... 
      Where are you going??
    2. Joker860
      Joker860
      • member
      • 855 posts
      • 7 kudos
      Did they fix this damned bug?