Mount & Blade II: Bannerlord
0 of 0

File information

Last updated

Original upload

Created by

Vendarr

Uploaded by

YaVashRotEbal

Virus scan

Safe to use

67 comments

  1. Andizzzzy
    Andizzzzy
    • premium
    • 262 posts
    • 5 kudos
    1.72 or 1.80?
    1. Wyvernboy
      Wyvernboy
      • member
      • 477 posts
      • 3 kudos
      +1
  2. krazeeee
    krazeeee
    • member
    • 301 posts
    • 3 kudos
    Doing God's work!
    1. krazeeee
      krazeeee
      • member
      • 301 posts
      • 3 kudos
      The folder name for mod should be "NPCRevamp" if you will unpack zip as it is, the launcher won't work.

      Also, will this work in Sandbox as well? 
      Its missing <DependedModule Id="SandBoxCore" DependentVersion="e1.7.0"/> and <DependedModule Id="Sandbox" DependentVersion="e1.7.0"/> in SubModule.xml
    2. YaVashRotEbal
      YaVashRotEbal
      • member
      • 27 posts
      • 0 kudos
      Thanks for note, miss this bug when write script. I will fix it now
      About SandBox. You can try it by yourself, I am not familiar with Bannerlord mod system, I just apply workarounds from posts and upload ready to use version. 
    3. krazeeee
      krazeeee
      • member
      • 301 posts
      • 3 kudos
      Please add also <GameType value = "Sandbox"/> for sandbox since nobody plays the campaign anyway also it would be good to mention that this mod must be put before Native to work in the load order.
      Thanks
    4. YaVashRotEbal
      YaVashRotEbal
      • member
      • 27 posts
      • 0 kudos
      Could you check please that it not works in Sandbox without this line. 
      I've tried to start sandbox a minute ago and check few faces and it seems to work well as is.
      If it will not work for you, I will add this line and test it again.
    5. gmarth
      gmarth
      • premium
      • 12 posts
      • 0 kudos
      The correct GameType for Sandbox is Campaign. The Campaign you mean has the value CampaignStoryMode.
      Loading this Mod before Native should not work. That would lead to loading this Mod first and then overriding all Faces from the Sandbox Module.
  3. CustoMOyuncU
    CustoMOyuncU
    • member
    • 3 posts
    • 0 kudos
    is working on 1.7.1?
    1. Rodnyi
      Rodnyi
      • member
      • 9 posts
      • 0 kudos
      working?
  4. aceboy21
    aceboy21
    • premium
    • 318 posts
    • 0 kudos
    Thank you for the update.

    I have a request.  Is it possible to make a face code, "Simple txt-file with only the face codes and body data for the revamped NPCs"?  Thanks.
    1. YaVashRotEbal
      YaVashRotEbal
      • member
      • 27 posts
      • 0 kudos
      I already have such file. I've uploaded it.
    2. aceboy21
      aceboy21
      • premium
      • 318 posts
      • 0 kudos
      Thank you for uploading the codes.
  5. jelf
    jelf
    • premium
    • 113 posts
    • 1 kudos
    Thanks a lot for the update.

    Is this mod supposed to be used with DCC, DCC + Additional Sliders, or Vanilla? (i.e. which one I should use such that there won't be any weird body shapes)
    1. YaVashRotEbal
      YaVashRotEbal
      • member
      • 27 posts
      • 0 kudos
      I use it with vanilla, but I think you can use it with any other character mode, need just keep right mod ordering. So just test it in few runs with few mod combos and choose better one.

      P.s.
      This mod is very simple. Basically  mod just override only one value (face code) in lords.xml for 90+- lords. No more logics or mechanics or code. 
      So in my opinion this mode should not conflict with any other modes. I use it in different builds and with different mod packs and it just working. It looks more like a modified vanilla than a standalone mod.
    2. jelf
      jelf
      • premium
      • 113 posts
      • 1 kudos
      Thanks for the response.

      It is just that previously if NPC Revamp is used with DCC there will be some NPCs who would have extremely thick body, thighs, etc (likely due to NPC Revamp not having the variables for the extra sliders introduced by DCC).

      Just wondering if it'll be the same case here, and if I want the characters in their intended look as determined by the author of the mod, is using vanilla (i.e. without DCC) best?
    3. YaVashRotEbal
      YaVashRotEbal
      • member
      • 27 posts
      • 0 kudos
      I think original author use DCC to create this mod. I will have some time for this soon. I will try this mod with DCC, and if there will be simple issues, I will try to fix them and upload another version.
  6. samarai999
    samarai999
    • member
    • 14 posts
    • 1 kudos
    Hello! This mod crashes the game for me. 
    When I try to start the game, I get an error: "battletemplate attribute is not declared"

    I think this might be because in the mod manager, I am not able to drag it above the Native and Sandbox modules (I don't know why). 
    Can anyone help me with this?
    1. YaVashRotEbal
      YaVashRotEbal
      • member
      • 27 posts
      • 0 kudos
      Are you sure that you download latest version? Because  "battletemplate attribute is not declared" issue appears with old version. 
      Mod list should be free to rearrange by drag&drop and look like this: 
      Spoiler:  
      Show
       
  7. lukangamer
    lukangamer
    • member
    • 578 posts
    • 3 kudos
    now the non-official update needs a non-non-official update.

    (just a small joke, cool you did this and cool maker made it, understandable with non-stop game updates).
    1. YaVashRotEbal
      YaVashRotEbal
      • member
      • 27 posts
      • 0 kudos
      I made an update :)
    2. lukangamer
      lukangamer
      • member
      • 578 posts
      • 3 kudos
      :D
  8. XlSwiftbladelX
    XlSwiftbladelX
    • member
    • 66 posts
    • 0 kudos
    Edit* Nvm. Found my answer
  9. lc19
    lc19
    • member
    • 36 posts
    • 0 kudos
    Thank you so much for the update <3
  10. KivanAumar2
    KivanAumar2
    • member
    • 2 posts
    • 0 kudos
    Guys... how can anybody play the game without this mod? :_( I need it!