Monster Hunter Rise

File information

Last updated

Original upload

Created by

Haato

Uploaded by

headshet

Virus scan

Some manually verified files

652 comments

  1. headshet
    headshet
    • supporter
    • 806 posts
    • 35 kudos
    Locked
    Sticky
    PLEASE READ THE FAQ BEFORE POSTING YOUR ISSUE.
    F.A.Q


    Windows is asking me to install .NET 6, what do I do?
    HunterPie requires the .NET 6.0 Desktop Runtime to run properly, you can download it from Microsoft's official site here.

    Will there be a damage meter?
    That's been added in v2.2.0 :)

    Moving and scaling Widgets
    To move a widget you can either use Design Mode (togglable by pressing the default hotkey: ScrollLock) or set the absolute coordinations in HunterPie's settings.
    To scale a widget, you can go to HunterPie's settings for that widget and use the Scale slider.

    Why aren't my settings saving?
    Make sure your HunterPie's folder is NOT in Read-Only mode, if that doesn't work, try moving HunterPie to another folder.

    My auto update is getting stuck
    Same as issue #4, make sure your folder is not in Read-Only mode, if that's not the issue, try moving HunterPie to another folder or even drive.

    My HunterPie isn't starting up or is crashing on start up
    You probably extracted its files to a special/protected folder which is causing HunterPie to crash due to lack of permissions, move it somewhere else (somewhere that is NOT your Desktop, C:\Program Files or C:\Program Files (x86)) and try running it again.

    My HunterPie isn't showing health bars
    You probably changed the HunterPie theme to Minimal instead of default, the minimal hides the health bars, hence why it's called minimal. Just change it back to default in your HunterPie client's settings. If that's not the issue, then you're probably forgetting to target a monster using the in-game target system.

    If you need help with anything else related to HunterPie, feel free to join the official Discord Server.
  2. tioherman
    tioherman
    • member
    • 44 posts
    • 0 kudos
    seems like the most recent update broke something , it does works well but after 2 hunts or so it stops tracking the stats and stuff stats moving around by itself
    1. headshet
      headshet
      • supporter
      • 806 posts
      • 35 kudos
      What's your HunterPie version? v2.6.0.137 had an issue where it would freeze the application because it was reading invalid sharpness values, but that was fixed in v2.6.0.138.

      By the way, if you don't know what the version was at the time of your report, please test v2.6.0.156 and let me know if you still have that issue
    2. tioherman
      tioherman
      • member
      • 44 posts
      • 0 kudos
      yeah it was the 2.6.0.137, but the patch from late yesterday fixed the problem for me ^^

      Also current version is 2.6.0.156, no problems so far

      edit : nope, the problem showed up again, also when it happens the hunterpie starts using a lot of my cpu and lags the game
    3. headshet
      headshet
      • supporter
      • 806 posts
      • 35 kudos
      I've been trying to debug that issue as some people have reported a similar thing, but it hasn't happened to me so far, even after 5 hours of continuous hunts my HunterPie been working normally. Do you have any other mods other than HunterPie?

      Also, when this happen again, do the following:


      1. Open cmd and run the command:dotnet tool install --global dotnet-gcdump
      2. After it tells you that the tool is installed, open the task manager, click on the details tab and look for the HunterPie.exe process, that tab should also have a column named PID, that's HunterPie's process id
      3. Run the following command in the cmd replacing <HunterPie-PID> with it's actual PID from the previous step: dotnet gcdump collect -p <HunterPie-PID>
      4. It will generate a memory dump of HunterPie, please send that file to me on Discord (Haato#0001 or in the Discord server) so I can analyze it and see what went wrong


      EDIT: Added troubleshooting details
  3. uhhkillem
    uhhkillem
    • member
    • 12 posts
    • 0 kudos
    Failed to replace old files, make sure hunterpie has permission to move files? i run it as administrator but still doesn't work, and i can't update it.
    1. headshet
      headshet
      • supporter
      • 806 posts
      • 35 kudos
      That's not how it works, running something as administrator doesn't override the folder's required privileges. If you extracted the files to desktop or C:/Program Files, that might cause issues due to lack of privileges to access files. Extract the files to a folder that's not considered as special by Windows (e.g: Documents folder) and make sure that the folder is not in read-only mode, or try using the installer instead of downloading the zipped file.
  4. bushuozanghua
    bushuozanghua
    • member
    • 2 posts
    • 0 kudos
    why I can see damage and all the other things except monster's healh
    1. headshet
      headshet
      • supporter
      • 806 posts
      • 35 kudos
      You probably either changed HunterPie's theme to minimal (that theme hides monster's health), or you enabled the "Show only target" and isn't targeting any monster with the in-game lockon.
    2. valloittaja
      valloittaja
      • supporter
      • 16 posts
      • 1 kudos
      I had this same problem, like it changed settings on by itself or something but after updating manually the program from the post above it fixed this for me.
    3. bushuozanghua
      bushuozanghua
      • member
      • 2 posts
      • 0 kudos
      thanks
    4. headshet
      headshet
      • supporter
      • 806 posts
      • 35 kudos
      like it changed settings on by itself

      Hmm, it's impossible for it to change settings by itself because nothing in HunterPie changes settings's values, that sounds like the program was missing permissions to write to files so it couldn't save your config.json with the settings you set it up from the settings window.
  5. FukushiZero
    FukushiZero
    • member
    • 1 posts
    • 0 kudos
    Hello! Just wanted to ask about a new update for the new Free Title Update 3 for MHR: Sunbreak(Just now they added the patch), hoping for an update for HunterPie V2(It didn't detect the address bc it's already in a different version I think, correct me if I'm wrong). Much love from the community that uses this <3
    1. QuackingKiryu
      QuackingKiryu
      • member
      • 5 posts
      • 0 kudos
      I think it's the correct version, but it can't find the address. I'm having the same issue.
    2. headshet
      headshet
      • supporter
      • 806 posts
      • 35 kudos
      I added support for v13.0.0.0 now, some of the new monsters are still unmapped but I'll push a fix for that soon too
    3. deikidesu
      deikidesu
      • member
      • 2 posts
      • 0 kudos
      Thanks for the update.
      However no function of the latest version (2.5.0.80) can work. Neither monster HP nor DPS showed up.
    4. headshet
      headshet
      • supporter
      • 806 posts
      • 35 kudos
      Thanks for the update.
      However no function of the latest version (2.5.0.80) can work. Neither monster HP nor DPS showed up.

      v2.5.0.80 isn't the latest version though, it is v2.5.0.114, your HunterPie is outdated
    5. deikidesu
      deikidesu
      • member
      • 2 posts
      • 0 kudos
      The program failed to update by itself.
      So I wonder if it is possilble to upload the 114 version.
    6. headshet
      headshet
      • supporter
      • 806 posts
      • 35 kudos
      Then it probably is missing permissions to download the files (this can happen if you extracted it's files into C:\Program Files or in Desktop). As for the latest version, you can find it here.
  6. MaverickEXE
    MaverickEXE
    • member
    • 5 posts
    • 0 kudos
    quick question, I made an account before TU3 and now I can't access it, was wondering if you did away with accounts or if I should just make a new one.
    1. headshet
      headshet
      • supporter
      • 806 posts
      • 35 kudos
      I don't touch people's accounts, so if you can't access it then you're either putting the wrong credentials or your HunterPie is failing to reach the APIs. You can try reseting your password in the log-in screen though.

      If you still have problems, contact me on Discord (Haato#0001 or in the official discord server)
    2. MaverickEXE
      MaverickEXE
      • member
      • 5 posts
      • 0 kudos
      I was asking because when I click "Forgot Password" it would say "NOT_FOUND" at the bottom when I entered the Email associated with the account, I'll just make a new account tho lol less work for everyone.

      edit: spelling mistakes
  7. iTzfreaky17
    iTzfreaky17
    • member
    • 17 posts
    • 0 kudos
    Könnten Sie eine Hp anzeige und Namen der kleinen Monster hinzufügen ?

    LG
    1. headshet
      headshet
      • supporter
      • 806 posts
      • 35 kudos
      I don't see any point in doing so, adding health bars for small monsters would be a lot of effort for something that's pretty irrelevant in the game
  8. goyu
    goyu
    • supporter
    • 37 posts
    • 0 kudos
    Could you add the Adrenaline Rush widget?
    1. headshet
      headshet
      • supporter
      • 806 posts
      • 35 kudos
      I can add support to that buff in the abnormality widget, but I'm not going to add a whole exclusive widget just for it.
    2. goyu
      goyu
      • supporter
      • 37 posts
      • 0 kudos
      Thank you for your reply. Yes I know you dont add a exclusive widget.
      Im looking forward to adding this in the abnormality widget !
  9. galloff
    galloff
    • member
    • 2 posts
    • 0 kudos
    Well, i noticed while playing in a high frame rate the overlay locks you in a 60hz thick rate, despite having more than 200fps.
    You can change that by swapping from software loading engine, to hardware, which probably forces your gpu to load the overlay but at the cost of a HUGE AMOUNT OF PROCESSING of your gpu.
    So, despite having more than 60fps, while using your overlay it only shows 60fps.
    Made this tests with lots of screen cap.
    I love your tool, but my eyes can't stand 60fps anymore >_>
    1. headshet
      headshet
      • supporter
      • 806 posts
      • 35 kudos
      Let me address some points here:

      1 - The overlay does not lock your hertz, that's Gsync/Freesync syncing your monitor refresh rate to the window that's on top most, which is in this case, the overlay, there are some workarounds for that but it's an issue that's been reported to WPF devs for over 3 years now and that hasn't been fixed yet, which I can do nothing about because WPF is made by Microsoft and not by me. It seems like they added it to the .NET 7.0 milestone, but until then, there's really nothing I can do about it.
      As a workaround, you can go to your NVidia control panel and under the G-SYNC configurations, select the "Enable for fullscreen mode" only instead of windowed too, that way your GPU will stop picking up HunterPie's overlay as the window to sync to.

      2 - Changing to hardware does make it so HunterPie will be rendered by the GPU instead of CPU, I don't know what a "HUGE AMOUNT OF PROCESSING" is for you, but on my RTX 3070ti it uses less than 5% of my GPU, which is fairly reasonable considering how animation intensive HunterPie is.
  10. spence0892
    spence0892
    • member
    • 31 posts
    • 1 kudos
    Have I done something wrong setting hunterpie up? I have set it to world in settings, but when I'm trying to set up my abnormality tray it shows everything from Rise, I can't seem to find the mega demondrug drink nor the armor variant of it, perhaps they were condensed into the powder variants?
    1. headshet
      headshet
      • supporter
      • 806 posts
      • 35 kudos
      Both mega demondrug and armorskin are infite and therefore aren't tracked by the abnormality tray
  11. doskcjsuwnr
    doskcjsuwnr
    • member
    • 1 posts
    • 0 kudos
    monsters ailments and moster pars is not displayed even after setting
    and It is still visible even after turning on show only target
    how can i setting it?
    1. headshet
      headshet
      • supporter
      • 806 posts
      • 35 kudos
      I don't quite understand what you're saying. But to display ailments and monster parts you need to target a monster using the in-game target system, and that will ONLY display the targeted monster. If you enable "show only target", it won't target the monster automatically for you, you still need to do it manually.
    2. colestormhold
      colestormhold
      • member
      • 31 posts
      • 0 kudos
      Well, the same thing happens to me and I think I can explain it, basically the monster display worked fine until a few updates ago, now, at least for me, only a box appears with the icon of the three monsters, neither life nor the altered states, nor the parts to break, absolutely nothing. Well, taking advantage of the momentum, I am Spanish-speaking and many updates ago I saw that some monster names were in Spanish, did that happen or was it just a mistake? Because, for example, Aurora Sommnacanth in Spanish is Sommnacanth Aurora And now, but for example Scorned Magnamalo in Spanish is Magnamalo Humillado, I don't know if it can be done as is, I mean, are the monster parts already translated?
    3. headshet
      headshet
      • supporter
      • 806 posts
      • 35 kudos
      Well, the same thing happens to me and I think I can explain it, basically the monster display worked fine until a few updates ago, now,
      at least for me, only a box appears with the icon of the three monsters,
      neither life nor the altered states, nor the parts to break, absolutely
      nothing.

      Oh, now I understood the issue, you probably changed the theme to "Minimal" instead of "Default", the minimal theme will basically hide everything related to monster health and just display their crown, names and icons, that's not a bug and has nothing to do with recent updates either. If you want to see monster parts, just change it back to default in the Client settings.

      I am Spanish-speaking and many updates ago I saw that some monster names were in Spanish, did that happen or was it just a mistake?

      Every text HunterPie displays (with some exceptions that are hardcoded in english) are directly associated to the localization you configured in your HunterPie. I think there are some text missing in the spanish localization file though, feel free to localize them and open a PR on Github to add them though. You can read more about localizations in the official documentation.

    4. colestormhold
      colestormhold
      • member
      • 31 posts
      • 0 kudos
      Ok, and I'm already working on the Spanish update, thanks