MechWarrior 5: Mercenaries
Help us shape the future of the Vortex mod manager by taking our survey
0 of 0

File information

Last updated

Original upload

Created by

Mechcommander Mercenaries Modders

Uploaded by

MechcommanderMercs

Virus scan

Safe to use

Tags for this mod

106 comments

  1. AguynamedDM30
    AguynamedDM30
    • member
    • 5 posts
    • 0 kudos
    Just installed this mod today, and I'm extremely impressed with what you guys have managed to do with the game. Turning a shooter into an RTS is something I never would have expected to see, so well done on that and great job on what you've managed to achieve so far!

    Now just in case it helps, I do want to list out a few bugs I came across from my first few missions of play. If they're repeats of ones you already know about then my apologies, but just in case here they are. Most of them are fairly minor, plus one that's a bit more problematic:

    -- Doors on the Leopard for Mason's mech don't open, trapping that mech inside until the dropship takes off, at which point the mech drops out and falls, taking damage to the legs. Has happened on 100% of missions starting from the Leopard so far.
    -- Mech pathfinding on 'Guard' commands is a bit finicky. A lot of the time the "guarding" mechs will start running in the opposite direction of the mech they're supposed to be following, then loop back when they get too far and catch back up, then repeat.
    -- Enemy vehicles were frequently getting stuck and not moving toward friendly mechs or defence objectives, so I'd have to go out to hunt them down
    -- Objective markers not appearing on main screen. They do appear on the radar minimap though.

    And now the big one:
    -- mechs ignoring move orders. Not sure if this is a bug or just an artifact of the default game's AI causing issues, but it's the biggest blocker keeping me from fully getting into this mod right now. Occasionally after giving a move command out of combat a mech will just stand still and not follow the move. IN combat virtually all move commands I gave were ignored. Damaged mech that I want to pull back? Nope, it stays in the fight and keeps circling. Just finished an assassination and want my fastest mech to head to the extraction before my more damaged front-line mechs get shredded? Nope, ignores the command completely to keep fighting and my mechs get destroyed. Using the "force" option on movement with Alt doesn't have any effect that I can see.

    I did have a couple of other mods still active at the time of playing (though all of them were QOL stuff for outside of missions like paint scheme saver and starmap stuff, nothing affecting the main mission gameplay), but I'll try it again later with a clean slate to make sure they weren't a factor.


    Other non-bug comments:
    -- On mech movement, if it's possible to do: Can the default move command make the mechs move at formation speed (like using 'G' in the regular game), and then have a separate keybind for running at full speed? Would be very helpful for keeping lighter mechs from getting too far ahead without needing to use guard or babysit them.
    -- And an extra comment on the known issue of Mason's mech not firing its weapons at full potential, I can add some confirmation to your suggestion of messing with the weapon groups: It seems like weapon groups 1 and 2 are the main culprits for some reason. When I had him in the Centurion at the start, the only thing he fired was his missiles. As a hunch I added the AC and lasers to 4 and 5, and in the next mission he was firing them. I've just been setting all mech weapon groups as normal with '3' as the new starting point instead of '1', and now it seems like Mason's mech fights normally like the other AI mechs do no matter which mech I put him in.


    Again, I want to reiterate how impressed I am with what you guys have accomplished so far, and I hope that some of these kinks can be smoothed out to make it even better (as far as the modding tools allow, anyway). Hope you guys keep up the great work!


    Update:
    Tried again with all remaining mods disabled. Still ran into the same issues. For the one on move orders during combat I also found out that if I spam-click the move order incessantly then my mechs do gradually move in the direction I want them to, but if I ever stop clicking they revert to their combat circling behaviour so it looks like that behaviour is taking too much priority over movement.
    1. MechcommanderMercs
      MechcommanderMercs
      • member
      • 37 posts
      • 1 kudos
      Thanks for taking the time to write all of this feedback.

      I did track down the issues with move orders getting ignored (I think?). There was a setting missing that didn't cause move orders to cancel combat mode properly. I've fixed that locally and will be testing some other AI tweaks before the next update. I'm planning on looking into formations in general, which would include move speed for the group probably. Guarding the slow mech is the closest workaround for now, but it uses the base game's follow command right now, which lets them move around for combat instead of sticking close.

      Mason should be shooting properly as of 1.2 or later. He gets replaced by a stunt double, which is why the leopard doors don't open. That will all get cleaned up with the next editor update from PGI.

      Vehicles spawning in terrain or getting stuck is a carry over from the base game.
    2. AguynamedDM30
      AguynamedDM30
      • member
      • 5 posts
      • 0 kudos
      Appreciate the reply. Good news about the AI fix!

      For Mason, I was aware of the switch and that does make sense for the dropship. As for the weapons, you're saying that with the character swap his mech should be firing all weapons normally? Because it definitely wasn't firing groups 1 or 2 at all in the first few missions I played. Only after I switched to the 3/4/5 groups on his mech specifically did the other weapons start firing.

      And yeah, I figured the vehicles not moving was a vanilla game problem. I mainly included it because I was noticing it more here than in my previous playtime before the mod (though the new higher up POV might be a factor there), and wondered whether the changes made to put an AI in the player mech might have confused them somehow. Included just in case, but all good.
    3. MechcommanderMercs
      MechcommanderMercs
      • member
      • 37 posts
      • 1 kudos
      Yes, all weapon groups *should* be working for AI. I have a sneaking suspicion people are having issues with LRMs due to another issue, but the weapon groups were working when I've tested it.
    4. AguynamedDM30
      AguynamedDM30
      • member
      • 5 posts
      • 0 kudos
      Very strange. Well, if it's working on your end then I won't worry about it and just wait patiently for the next update to see if that sorts it out for me. Really excited to see where you go with this!

      Also, I would like to report another bug that I just encountered that I didn't see mentioned anywhere yet: When I went to drop reinforcements in my last mission, instead of dropping one of the mechs I had in reserve it dropped a duplicate of one of the mechs I already had on the field.

      Mechs that I started the mission with: Centurion, Spider, Firestarter, Panther
      Mechs in reserve: Griffin, Javelin
      No other mechs currently owned in mech bay

      When I went to drop in the Griffin and Javelin, instead of dropping the Griffin, it dropped a copy of the Firestarter. When I tried to select it the HUD would show the icon for the original Firestarter and its pilot, the blue wedge would appear over the first Firestarter instead of the new one, and I couldn't give it any orders. Also couldn't add it to control groups. However, if I drag-selected it I could command it normally as part of a group of mechs. Was very unexpected, but also entertaining having a free second Firestarter running around (though not having that extra Medium was a bit of a bummer).

      Not sure what contributing factors could have led to the bug. It was my first time using the reinforcements so I can't comment on frequency of it. It was at the start of a defence mission before I triggered the objective, and there was no combat going on or anything.
    5. MechcommanderMercs
      MechcommanderMercs
      • member
      • 37 posts
      • 1 kudos
      I've had a couple of reports of it happening. I've got to do a little extra work checking which units are deployed and getting data for the reserves.

      Someone reported it only happened on subsequent missions, not the first one played that session. I'll be looking into for the next update.
    6. SMGHunter16
      SMGHunter16
      • member
      • 17 posts
      • 1 kudos
      ive gotten duplicates every mission during the last 6. but it isnt me being surprised by it, i'll have my dragon (A-1), catapult (A-2), blackjack (A-3), and javelin (A-4) as the main lance (i usually have my bigger mechs at the left side of the lance deployment and go down in tonnage to the right). hunchback (B-1), griffon (B-2), vindicator (B-3), assassin (B-4), centurion (C-1), rifleman (C-2), phoenix hawk (C-3), and jenner (C-4) in reserve, and it will randomly replace one or two of the reserve mechs and their paperdolls in the reinforcements menu with one of my starters. generally, it will be b-4 and c-4 getting replaced with copies of a-3 and a-4, but this last mission copied mason's mech. on top of that, the copies are selectable, can be put in ctrl group 0, and will follow orders, but they wont have paperdolls, wont have chevrons, and when you select the copy, it will highlight and chevron the original. i can try to clarify if that was too confusing
    7. MechcommanderMercs
      MechcommanderMercs
      • member
      • 37 posts
      • 1 kudos
      This will be fixed in the next update. The widget wasn't updating the available units correctly. Also doing some work to make sure they actually save state properly when they die, along with some other bug fixes. I'll push it out once everything is finished and some testing.
    8. corpseharvester1
      corpseharvester1
      • member
      • 10 posts
      • 0 kudos
      yup can confirm as well. also not showing the last 1-2 mechs in reserve (only showing 6 reserve mechs instead of 8 when ive got a full 12 outfitted)

      btw, was gonna make a full new post but seems the bugs i was gonna mention are already here. so just wanna say, as well, freaking LOVING this mod. its making me gaf about mw5.
      ive been tinkering with multiple difficulty increasing mods (as now were dropping 12 mechs with no tonnage limit) that include...

      Damage Is Damage (with 12 mechs, we dont need PGIs damage reduction handholding with pilot stat buffs)
      TTRulez_DifficultyMod for added realism and AI
      and
      TTRulez_SpawnMod_Hard which changes random patrols to be more light mechs than swarms of vehicals

      personally, im also using 'Salvage is Battletech' which does many things but including instant (but NOT free) armor repair..beacause.. battletech.. works very nicely fielding a full company

      lastly, ive tried using 'AI Objective Capture' mod but doesnt work with current modlist. no idea whats stopping it but seems might be a solid addition to this MC mod

      completely looking forward to the further development of this mod!
    9. MechcommanderMercs
      MechcommanderMercs
      • member
      • 37 posts
      • 1 kudos
      AI objective capture is built into MCM. It only works for members of the initial drop lance (an not mason's stunt double, unfortunately). I spun it out because someone requested it.

      More friendly units will be able to capture stuff in MCM after the next editor update, as I currently can't flag units as members of "the squad".
  2. weiyentan
    weiyentan
    • member
    • 1 posts
    • 0 kudos
    I can't play this game in the early levels as there no way points like navpoint alpa showing so no objectives.
    ....the mechs get trapped inside the dropship...
    This mod has promise and I cant wait to play it but at the moment it is unplayable. I am using Beta v1.2
    1. corpseharvester1
      corpseharvester1
      • member
      • 10 posts
      • 0 kudos
      its totes playable. just gotta get used to the quirkiness of a mod in beta.
      the navs will pop up after you hit esc, then f6 to leave the 1st person veiw that esc puts you in.... then "b" to get rid of the battlemap.
      its a bit much but you only have to do it once each mission.

      the trapped mech only stays until the DS takes off. no biggy
  3. Ayyl13n
    Ayyl13n
    • member
    • 2 posts
    • 0 kudos
    This is going to be an insane mod when it is done! Just wondering if we will still be able switch from RTS mode to FPS mode on the mechs or is it strictly RTS with the FPS mode removed?
    1. MechcommanderMercs
      MechcommanderMercs
      • member
      • 37 posts
      • 1 kudos
      You can already swap back/forth to the player mech cockpit at any time with the F6 key. It's got some bugs still, but it does work. Sometimes you have to hop out and back in to get full mech control, for example. Few other keys don't quite work because they are mapped to things in the RTS, etc.

      We might prototype an alternative that's more RTS friendly for direct control, but that's a ways out and we're not sure if it will even be feasible from the mod (what we want to do). But until we have another solution that works, first person is staying in. Even then, we'll see if it is something we can make optional?
  4. corpseharvester1
    corpseharvester1
    • member
    • 10 posts
    • 0 kudos
    wait, how many lances can you field??
    1. XStormforgeX
      XStormforgeX
      • supporter
      • 71 posts
      • 0 kudos
      12 mechs, as many as you can prep in the hangar. 2 lances as reinforcements.
    2. MechcommanderMercs
      MechcommanderMercs
      • member
      • 37 posts
      • 1 kudos
      Three lances (plus any allies the mission gives you)...so far. ;)
    3. corpseharvester1
      corpseharvester1
      • member
      • 10 posts
      • 0 kudos
      oh ma gaaawd
    4. corpseharvester1
      corpseharvester1
      • member
      • 10 posts
      • 0 kudos
      hate to be a bother, curious if anything from my current mod list is a no-go, redundancy, not recomended with your MC mercs mod
      as well as if theres any you recomend that you use with your mod

      MW5 Mercs Reloaded
      Yet Another Weapon
      Yet Another Mech
      Conflict Zone Difficulty Mod
      Salvage is Battletech
      TableTopRulez_Enemy AI Mod
      and its TTRulez_SensorMod
    5. MechcommanderMercs
      MechcommanderMercs
      • member
      • 37 posts
      • 1 kudos
      All of those should work as far as I know. I'm not familiar with the Sensor one, but I assume it works if he messed with the file I think he did.

      As far as recommendations, you should always have the FPS fix mod installed just in case another mod doesn't have it. It cleans up a bunch of sound objects that vanilla doesn't yet. Saves a ton on longer missions with lots of AC fire.

      Some of the sound and effect mods (like Kh0rnz sound mod and the Hellfire and Brimstone Mods) look/sound great in RTS mode.

      Everything else is pretty well quality of life (paint saver, etc) that you would use with or without mechcommander to taste.
    6. corpseharvester1
      corpseharvester1
      • member
      • 10 posts
      • 0 kudos
      wicked, ill slap em all together and give er a whirl. thanks for the input, mate!
  5. billythepunk
    billythepunk
    • member
    • 1 posts
    • 0 kudos
    I just want to say, regardless if you work on this for the next 10 years, or don't touch it again, thank you.

    I didn't even know something like this would really be possible with this game.
  6. spider9473
    spider9473
    • member
    • 14 posts
    • 0 kudos
    I installed the mod and ran into some problems. The camera was hard-wired somewhere in Mason's mech, scrolling with the mouse does not work, bringing the mouse to the edge of the screen also does not give anything (the camera is hard-wired for some reason). F6 doesn't help.
    Version from EGS
    1. MechcommanderMercs
      MechcommanderMercs
      • member
      • 37 posts
      • 1 kudos
      Are you using any other mods?
    2. spider9473
      spider9473
      • member
      • 14 posts
      • 0 kudos
      Yes, but disabled all mods that at least somehow conflicted. Left: weather mod, cancellation of the ship jump animation. At first I thought that AI mods were to blame, but disabling them didn't give me anything new.

      Just now I tried it completely without mods, only with mechcommander, the same problem.
    3. MechcommanderMercs
      MechcommanderMercs
      • member
      • 37 posts
      • 1 kudos
      So strange. Did any other controls do anything at all? (like pressing R opening the reinforcement menu) Might try double clicking on control group A and see if it will pan itself out correctly.

      Have you tried other missions?

    4. mungaloid
      mungaloid
      • member
      • 35 posts
      • 0 kudos
      I also have this issue. Disabled all mods except for compatibilty patch. Started a new campaign. Upon mission start the camera is stuck facing downward about 10 m from the ground. No camera related controls work. Mason is not replaced by stunt actor. The mech he should be piloting is found in the reinforcement menu. Deploying mason's mech from the Reinforcement menu does not solve camera issue. Selection and move commands appear to work as normal the mechs will walk into the cameras location. Camera anchor doesn't work either. Thats all I have, hopefully this info will helpful in some manner.
    5. MechcommanderMercs
      MechcommanderMercs
      • member
      • 37 posts
      • 1 kudos
      That's good info, thanks. Now I'm wondering if one of the story missions gets broken by the stunt double spawn mechanism. I'll do some testing with a new campaign as soon as I can and see if I can reproduce the problem.
    6. spider9473
      spider9473
      • member
      • 14 posts
      • 0 kudos
      Yes, from what I've tried or noticed:
      - There is no copy of Mason. Not even its mech in the selection window. The camera is tied to the mech, but its model is not. Pressing F6 causes the camera to move slightly and you can see the inside of the mech, while controlling the mech is impossible - it just doesn't work (wasd, shooting - all useless).
      - In RTS mode, you can rotate the camera by holding the mouse wheel, but zooming by scrolling or changing the camera position by moving the cursor to the edge of the screen is not possible. For a moment, bringing the cursor to the border of the screen, the cursor changes to another one (like now the camera will go there), but then the old cursor returns, the new one no longer appears.
      - Control of the remaining three robots is possible. I can highlight them and poke them back and forth. However, it is constantly output that I only have 3 mech, not 4.
      - This occurs on the first mission, any, so try what's next, somehow could not :)
      - I didn't use any third-party mods in my last attempts.
    7. spider9473
      spider9473
      • member
      • 14 posts
      • 0 kudos
      I tried again, and Mason's mech appeared in the reserve window. I called him, he landed somewhere, got a couple of blows, but ran to the place of the camera. The camera remains attached to a single point even when you press F6. It can only be rotated.So there are two specific problems left:
      1) Why is Mason's mech in reserve?
      2) Why is the camera hard-wired to the point where Mason's mech should originally be?
    8. MechcommanderMercs
      MechcommanderMercs
      • member
      • 37 posts
      • 1 kudos
      I've tested a new campaign with only the mod installed on my copy. Works fine.

      But, it sounds like there's some edge case where spawning the stunt double takes too long (or fails), then blocks the rest of the logic there. Is it installed on an SSD or HDD?

      I'll take a peek though my logic and see if there's an obvious pitfall that can cause this to happen.
    9. spider9473
      spider9473
      • member
      • 14 posts
      • 0 kudos
      The game is installed on HDD.
    10. MechcommanderMercs
      MechcommanderMercs
      • member
      • 37 posts
      • 1 kudos
      Yup, looking through the logic, if mason's stunt double fails to load in properly it will cause the camera control to fail to spawn. I'll see if there's a way to work around it. Might be a bit. Worst case, 1.1 from the old files here should still work with derpy mason until I can get another update out.
    11. spider9473
      spider9473
      • member
      • 14 posts
      • 0 kudos
      So, in theory, everything should work well on SSD? I don't really want to reinstall the game on SSD. And the error occurs, as you can see, not only for me.
    12. MechcommanderMercs
      MechcommanderMercs
      • member
      • 37 posts
      • 1 kudos
      I'm not sure. My rig is an M2 drive, I was just curious. Everything happening at the beginning of the level is in events that happen in different threads, so a slower drive or different CPU could cause one to finish before it does on my machine, etc. I've identified the most likely place that the logic is failing on your rig, I just have to figure out a smooth way to handle it so I can pack a new update, etc.
    13. spider9473
      spider9473
      • member
      • 14 posts
      • 0 kudos
      I played in version 1.1, Everything is done very interesting, but there are bugs that, as I read the changelog, are fixed in version 1.2 (for example, a very stupid and teleportable Mason).
      We will wait for the new version. The mod is great.
    14. spider9473
      spider9473
      • member
      • 14 posts
      • 0 kudos
      Oh, and one more question. Can I show this mod on the game stream? :)
    15. MechcommanderMercs
      MechcommanderMercs
      • member
      • 37 posts
      • 1 kudos
      I don't know what would stop you from streaming it. :)
    16. spider9473
      spider9473
      • member
      • 14 posts
      • 0 kudos
      Still, it was better to ask. This can be said to be a completely different game, and you are its developer. :)
    17. MechcommanderMercs
      MechcommanderMercs
      • member
      • 37 posts
      • 1 kudos
      I think I have a fix for the issue you were having. It finally happened to me in the editor so I could poke around debug. If mason's stunt double fails to spawn, i think it will pick another mech to be "your" mech for the purposes of F6, which would let you bring Mason's mech in as a reinforcement still. I don't want to put much more effort into fixing around it because it's a temp fix until PGI's next editor update anyway.

      Testing build now, I'll try to get it up everywhere later today if it doesn't break everything horribly.
    18. mungaloid
      mungaloid
      • member
      • 35 posts
      • 0 kudos
      Ok, tested the fix. Problems still persists.sometimes Mason's stunt double will spawn but bump one of my lance mates to the reinforcement tab. F6 fix works but the RTS camera logic is still borked on my machine. I can Confirm that the issue likely has to do with the loading time of a system with an HDD. My system is pretty strong over all, but I skimped on the storage drives. More bang for the buck elsewhere at the time lol. Well I've been putting off grabbing an SSD/M.2 might be the time lol.
    19. XStormforgeX
      XStormforgeX
      • supporter
      • 71 posts
      • 0 kudos
      Is the Better Spawns mod possibly in your paks folder? This is what was causing it for me.
    20. mungaloid
      mungaloid
      • member
      • 35 posts
      • 0 kudos
      Hi back again. I hadn't thought to check the pak folder for conflicting mods. (Sorry) Indeed CONFIRMED! conflict with "Better Spawns" mod. Dunno if its how the new update spawns the Mason's stunt double, or if its conflicting with the reinforcements coming in by drop ship. None the less removing the better spawns mod fix the camera issue. 100% fully functional. Thanks for the tip XStormforgeX. Unfortunate Better Spawns is the conflict but between the two, right? lol.
    21. MechcommanderMercs
      MechcommanderMercs
      • member
      • 37 posts
      • 1 kudos
      Crazy, I wouldn't have thought it would cause any issues with better spawns. Of course, to spawn the stunt double, I create a dynamic spawn point at Mason's location and spawn in the duplicate mech (after deleting mason). I guess better spawns overrides dynamic spawn and tries to do something else. Thanks for checking it out folks. Glad it got pinned down.
  7. thewisewarlord
    thewisewarlord
    • member
    • 4 posts
    • 0 kudos
    i cant see the menu anyone else has this problem?
    1. MechcommanderMercs
      MechcommanderMercs
      • member
      • 37 posts
      • 1 kudos
      What menu? When/how?
    2. thewisewarlord
      thewisewarlord
      • member
      • 4 posts
      • 0 kudos
      the main menu where u can select to start a campaign
    3. MechcommanderMercs
      MechcommanderMercs
      • member
      • 37 posts
      • 1 kudos
      Weird. I've never ran into that problem before. There's a modlist.json file in you install's mods folder. You can edit it in notepad and turn the mods to false. That'll let you disable mods and get back into the menu. I wonder if it is another mod conflicting, which would be odd.
    4. thewisewarlord
      thewisewarlord
      • member
      • 4 posts
      • 0 kudos
      i only tried your mod i made a fresh new mod folder dropped your mod into it. then activate it in the menu. Then i restart the game and then i dont see the menu want me to make a screen shot if that helps?
    5. MechcommanderMercs
      MechcommanderMercs
      • member
      • 37 posts
      • 1 kudos
      Do you have the most recent updates to MW5? EGS or XGP?

      I don't get this bug ever, but I only have EGS version to test on.
    6. AkiraR
      AkiraR
      • supporter
      • 17 posts
      • 0 kudos
      Just letting you know I'm running the XGP version here and have not seen this issue.
    7. thewisewarlord
      thewisewarlord
      • member
      • 4 posts
      • 0 kudos
      yeah could be me not blaming anyone i downloaded so maybe thats the problem?
    8. megakos
      megakos
      • member
      • 1 posts
      • 0 kudos
      the same... did y solve the problem? when i start the game i have only 3d mechs and no menu
    9. Lecnik
      Lecnik
      • member
      • 18 posts
      • 0 kudos
      +1
      same problem.
      who will find a solution, write to the topics, how to fix it...
    10. localghost
      localghost
      • member
      • 4 posts
      • 0 kudos
      +1
      Same here...
      Start new game with only this mod.
      No In game start/load/option menu
      Only showing 4 mechs with free camera movement
    11. MechcommanderMercs
      MechcommanderMercs
      • member
      • 37 posts
      • 1 kudos
      Which store did you get the game from, Xbox Game Pass or Epic Games Store? I haven't been able to reproduce this issue with EGS version locally, and Akira claims it is working on the XGP version. Have you turned on auto updates?
    12. MechcommanderMercs
      MechcommanderMercs
      • member
      • 37 posts
      • 1 kudos
      If the answer is "neither", there's really nothing I can do to help you.
    13. Bloodplague
      Bloodplague
      • premium
      • 359 posts
      • 10 kudos
      no support for pirated games here sry.....
  8. XStormforgeX
    XStormforgeX
    • supporter
    • 71 posts
    • 0 kudos
    Really, Really enjoying this mod! Using TTrulez Enemy AI without any real problems. Too bad about Commander Mason. Been putting him in lighter mechs with enough armor to last. Wish I could just yank him from that pilot slot and replace him with another pilot.
    1. MechcommanderMercs
      MechcommanderMercs
      • member
      • 37 posts
      • 1 kudos
      Someone tested it with a mod that lets you swap in different pilots. That's not the problem. I'm going to try a crazy fix for him this week and see if I can make it work for the next update.
  9. natebell3050
    natebell3050
    • premium
    • 1 posts
    • 0 kudos
    I'm only playing with the MCM atm and besides Mason and IFF blunders, hats off to the mod devs. I've made it to the campaign point where I'm awarded the Warhammer 6R, and having fun dropping in FPS to wail ppc death then exiting back to RTS to give move and target commands! Oh, and I went with a psuedo-BW var with 2 ppc, 2 ac/2 BF, and 4 dhs! good times! I'm having random issues where a mech or two will fall through terrain, then come crashing back to Earth, damaging their legs. Amusing since I remove all JJs! Another neat bug is I'll be zooming along looking for the way point, clicking the mouse wheel to change face and asdf to side step, while in RTS mode, and somehow the clicks and keys will teleport mechs to random spots. I turned the Hero Quickdraw into a variant-primitive Rifleman with 2 ac/10 BF and 2 med lasers! It's a blast! No heat bugs yet. Pathing can be difficult for 1 mech, usually. The mw just can't seem to find it's way out of the spot. I have to click behind it in specific spots to generate interest to turn the mech around and disengage from the sticky point. Random turrets will be ignored. Last thing I can think of is the friendly AI will not hold fire when their firing solution places terrain in their way of the target. The AI doesn't register the terrain.
    Thank you again Devs for good times and I'm awaiting future revisions!
  10. strikebrch
    strikebrch
    • member
    • 1 posts
    • 0 kudos
    Is it compatble with mods like Reloaded or AImods from TTrulez ?
    1. MechcommanderMercs
      MechcommanderMercs
      • member
      • 37 posts
      • 1 kudos
      This works with Reloaded pretty well. There's a couple of features from Reloaded that don't quite work in the cockpit if you're using MCM.

      AI mods from TTrulez are hit/miss. The enemy AI mod seems to be working in my local test playthrough fine. The lancemate AI conflicts a bit with issuing orders correctly in MCM.