Fallout 4
0 of 0

File information

Last updated

Original upload

Created by

dm

Uploaded by

BigAndFlabby

Virus scan

Safe to use

Tags for this mod

159 comments

  1. BigAndFlabby
    BigAndFlabby
    • premium
    • 1,885 posts
    • 108 kudos
    Locked
    Sticky
    There is information as to one reason why Bethesda implemented the new version change in the plugin header. This has to do with the change to support compacting FormIDs in the range of 0x001 - 0x7FF. Previously compacting a plugin for ESL usage only compacted in the range of 0x800 - 0xFFF which only provided a record space of 2047 instead of the 4095 that was "advertised" with the implementation of the light plugin system.

    This F4SE plugin does what it advertises it does, which is allow older game exe versions to load plugins with the newer header version. However if those plugins are using FormIDs in the range of 0x001 - 0x7FF, and those records are not intended to be hardcoded overrides, then they will malfunction. This is not a bug of this mod or the author of the mod being used. This is the limitation of using an old game version that does not properly support the newer produced content. Since the VR version of Fallout 4 was never updated, this will always be the case until Bethesda does so.

    The behavior prior to game exe version 1.10.162 was to use forms in that range as hard coded overrides even if they weren't explicitly set as overrides of the hard coded FormID. An example: A new plugin creates a form, ID = 7. The engine would still treat it as an override of 0x0000007 even though it might be loaded as 0x4B0000007.
  2. Anqayas
    Anqayas
    • member
    • 907 posts
    • 22 kudos
    Locked
    Sticky
    Plugins created/loaded and saved in the latest version of the Creation Kit (CK) will not work for older versions of the game. Meaning you either have to use an older version of the CK to match the older version of the game that you have, or update your game to match the updated CK you have. There's a third way which is to change the version number found in the header of the plugin manually using F4Edit. If you have a lot of mods and/or you're always skipping game updates for whatever reason (most likely you don't want to break FO4SE and FO4SE-dependent mods) this mod will make it so the game will bypass that checking step making your life a lot easier.

    I hope I'm not misunderstanding? I just wanted to write this simple-to-understand (imho) explanation.
    1. BigAndFlabby
      BigAndFlabby
      • premium
      • 1,885 posts
      • 108 kudos
      Spot on.
  3. PhoenixKnight13
    PhoenixKnight13
    • member
    • 535 posts
    • 6 kudos
    Worked for the G36 Complex update using my older 1.10.82 version, thanks for this! I'm slowly moving towards updating my game but I haven't played in years and I'm not ready for the hassle yet lol. By chance if anyone knows; will updating from 1.10.82.0 to the latest version and switching from Nexus Mod Manager to Vortex break older mods? I'll need to update my GECK too... ugh
  4. mickhyde
    mickhyde
    • member
    • 7 posts
    • 0 kudos
    I'm getting a ctd opening the armour workbench when I use this mod in fallout 4 vr. Any ideas?
    1. BigAndFlabby
      BigAndFlabby
      • premium
      • 1,885 posts
      • 108 kudos
      And if you disable/remove this mod it doesn't ctd?

      If that's the case then some other mod you're using is the cause. See the second paragraph in the first sticky message above. That's most likely the issue.

      If it is not, then it's a broken mesh included in a mod by some plugin that's being able to load because of this mod.
    2. mickhyde
      mickhyde
      • member
      • 7 posts
      • 0 kudos
      Thanks. This was the only mod loaded apart from F4SE, so I guess that's the problem.
  5. MAAAAAAAGIC
    MAAAAAAAGIC
    • member
    • 9 posts
    • 0 kudos
    I tried using this with my copy of Fallout4VR and it doesn't work.
    I only have two mods that are having version incompatibility issues, and they still keep popping errors.

    I have F4SEVR, and I re-installed it just in case. I've installed this both through a mod manager and manually as described; no dice.
    1. BigAndFlabby
      BigAndFlabby
      • premium
      • 1,885 posts
      • 108 kudos
      I've not actually used Fallout 4 VR so I'm only going on reports that other people got it working. The one thing I can think of that could be possibly related is if the plugin folder name is different for VR. In normal Fallout 4 the F4SE plugin goes in `Data/F4SE/Plugins` In VR it might be `Data/F4SEVR/Plugins`. I don't know for sure. If that is the case though you would have to manually extract the DLL from the archive and put it in the correct location yourself. Perhaps someone on the xSE Discord or someone more familiar with VR can shed more light on it.
    2. MAAAAAAAGIC
      MAAAAAAAGIC
      • member
      • 9 posts
      • 0 kudos
      Thank you for your help.

      I had actually suspected as much, and went ahead and moved the .dll to this location, which for me is [location]\Fallout 4 VR\Data\F4SE\Plugins
      I have two plugins that fail, but really only care about one. Both pop the error when running the game while launching from F4SEVR.
      If you don't have any further suggestions I'll go ahead and visit the Discord per your recommendation. Thank you again for your help.
    3. BigAndFlabby
      BigAndFlabby
      • premium
      • 1,885 posts
      • 108 kudos
      So there is an error provided by my plugin? Or F4SE? Or were you referring to errors on other things?
    4. MAAAAAAAGIC
      MAAAAAAAGIC
      • member
      • 9 posts
      • 0 kudos
      Thank you for your insight, unfortunately the errors are the generic version incompatibility errors after launching F4SE/F4SEVR. It's not a new error, if I didn't check it so thoroughly I'd swear that I didn't install it properly since it is not seeming to interact as expected.
  6. incendia1990
    incendia1990
    • member
    • 87 posts
    • 0 kudos
    (I hope someone can help me :S ) So I have a question. I have Fallout 1.10.163 and F4SE 0.6.21 and I downloaded a couple mods today. When I launched the game, it told me an esp disabled, then I reinstalled the mod, launched the game again, and then it said another esp was disabled. So, (not to be dumb but...) the Fallout 4 Version Check Patcher will fix that issue? (I'm sorry I'm dumb lol)
  7. 7rawr7
    7rawr7
    • member
    • 36 posts
    • 2 kudos
    Oh my goodness, huge thank you for this! I want to confirm this DOES work for VR. I'm pretty sure Bethesda has no more plans to update their subpar VR port so this is a great fix.
    1. ntblood
      ntblood
      • member
      • 2,205 posts
      • 34 kudos
      I also can confirm that after manually installing F4SEVR this mods works. I got Fourville working
    2. xdoublexbladexDBx
      xdoublexbladexDBx
      • member
      • 2 posts
      • 0 kudos
      Hi, please tell me how you made it work for Sim Settlements, thanks
    3. foxhound525
      foxhound525
      • member
      • 109 posts
      • 2 kudos
      What version are you using? I just tried spawning an attack on 009, it spawned, fighting started, then moments later CTD. Its been on for ages but hasn't been spawning attacks even though it was set to...
  8. zebradonkeyzebra
    zebradonkeyzebra
    • premium
    • 187 posts
    • 1 kudos
    Thanks for this mod, makes a bunch of mods playable in VR.
    I'd only suggest adding the F4SE requirement in the Requirements section.
    1. BigAndFlabby
      BigAndFlabby
      • premium
      • 1,885 posts
      • 108 kudos
      Totally didn't realize it wasn't listed. Thanks for the reminder.
  9. sosomomo123
    sosomomo123
    • member
    • 752 posts
    • 8 kudos
    I have somewhat old game....I use that amazing creation of yours....what happen is partial activation
    The esp is active but the gun does not exist in game 
    The mod is m16 black ops 3
    1. BigAndFlabby
      BigAndFlabby
      • premium
      • 1,885 posts
      • 108 kudos
      I'm not familiar with the mod, but you can look inside and check the formID numbers. If they're low under 0x800 then that's why. FormIDs under 0x800 are only supported on the latest FO4 1.10.163. Using plugins what use the lower forms on a game version prior to 163 will cause problems and can corrupt a save.
  10. Cuervoazulado
    Cuervoazulado
    • member
    • 3 posts
    • 0 kudos
    I'm using 1.10.138 FO4 and using this mod causes a CTD. If I disable it the CTD is gone. I have a couple of mods i recently downloaded that require the newst version of the game. What could be the issue in my case?
    1. BigAndFlabby
      BigAndFlabby
      • premium
      • 1,885 posts
      • 108 kudos
      Sounds very suspect. The code for the plugin verifies it can find all the memory locations before patching anything. Precisely to prevent what you describe. I would think it might be one of the mods you installed that needs this that could be an issue. Have you tried launching the game with this installed but not the newer mods?
    2. Trygveko
      Trygveko
      • premium
      • 93 posts
      • 0 kudos
      I was testing this and found that this MIGHT be true in my case also, with the newest version of sim-settlements and some of the add-ons. I currently have no outdated mods.
      Anyhow, Ive enjoyed Fo4 lately thanks to you BigAndFlabby. Thanks for the mod!
    3. RickyTheOx
      RickyTheOx
      • supporter
      • 5,348 posts
      • 121 kudos
      I'm running 130 and this works.
    4. RickyTheOx
      RickyTheOx
      • supporter
      • 5,348 posts
      • 121 kudos
      Gaahh, nexus dbl posted
    5. glenchester
      glenchester
      • member
      • 21 posts
      • 4 kudos
      I get a ctd too, game version 130. so many mods. without a fix, it works well
    6. glenchester
      glenchester
      • member
      • 21 posts
      • 4 kudos
      У меня тоже есть ctd, версия игры 130. Очень много модов. без исправления работает хорошо
  11. Satanicomoderno
    Satanicomoderno
    • member
    • 51 posts
    • 0 kudos
    Hello. 
    I have the version 1.10.138 of Fo4. 
    I had to install the last version of Workshop Framework which asked me to have the last version 1.10.163 even having your patcher.
    Then I downloaded the lastest version of F4SE (0.06.21) and reinstalled your patcher. 
    The problem is that F4SE is telling me that my game is older and need to be actualized. 

    I really don't know what is happening. I did everything right but the patcher isn't being recognized. 
    1. RickyTheOx
      RickyTheOx
      • supporter
      • 5,348 posts
      • 121 kudos
      U need the F4se vers. for  Ur game vers.
      So if U running 138 U need - f4se_0_06_17

      The patcher wotk for me on game vers 130
      If U wanna run Workshop Framework U have to use a older vers. when running game vers. 138
  12. lucasbdv
    lucasbdv
    • member
    • 3 posts
    • 0 kudos
    Thank you so much S2