Fallout 4

File information

Last updated

Original upload

Created by

Kinggath and Friends

Uploaded by

kinggath

Virus scan

Safe to use

3052 comments

  1. kinggath
    kinggath
    • premium
    • 3,439 posts
    • 2,316 kudos
    Locked
    Sticky
    Thanks for the support everyone and please continue to report bugs - I'll be working tirelessly to eliminate them all and make this a smooth gameplay experience - we can and will have automated settlement building!
  2. kinggath
    kinggath
    • premium
    • 3,439 posts
    • 2,316 kudos
    Locked
    Sticky
    We're still working on the wiki pages if you prefer to read things, but for those of you who like video guides, the in-depth series is up and will show you how all of the systems work in Rise of the Commonwealth:

  3. kinggath
    kinggath
    • premium
    • 3,439 posts
    • 2,316 kudos
    Locked
    Sticky
    If you're not able to activate the City Plan on the desk, be sure you are on version 3.0 of Sim Settlements. Any desks built before the 3.0 patch will need to be picked up and set back down in order to create the updated items.

    You'll know if it worked because you'll have a safe on the desk just above the file cabinet drawer.
  4. kinggath
    kinggath
    • premium
    • 3,439 posts
    • 2,316 kudos
    Locked
    Sticky
    It's become clear to me that I can't be a one man army on the support front, I had kept up with it until about October of last year, but now things have grown to the point where I need regular help. If you receive a response from damanding or kalimac, they are helping me out to keep up with everything to ensure everyone gets there questions answered and bug reports added to my fix list.

    I will still try and pop in periodically to respond to some things personally, but balancing my time between fatherhood, my job, and continuing to develop the mod has become close to impossible without help - hope everyone understands!
  5. kinggath
    kinggath
    • premium
    • 3,439 posts
    • 2,316 kudos
    Locked
    Sticky
    Patch 4.0.1 is now available, this shaves off some unnecessary models to reduce the overall file size.
  6. Nillkarn
    Nillkarn
    • premium
    • 131 posts
    • 0 kudos
    dont know if anyone has asked this yet.. but is it my game or is it a bug.. in Abernathy farm build. there are two agricultural plots almost on top of each other.
    1. rizzla
      rizzla
      • member
      • 463 posts
      • 7 kudos
      Can confirm, and it has been noticed by others as well. Just delete or move one of them.
    2. Nillkarn
      Nillkarn
      • premium
      • 131 posts
      • 0 kudos
      ahh, okay, thanks for the reply. should I just move it to the that empty farm location thats next the the main building, and behind one of the security building spots?
    3. uituit
      uituit
      • premium
      • 4,041 posts
      • 91 kudos
      Just delete it
  7. sanenomore
    sanenomore
    • supporter
    • 81 posts
    • 0 kudos
    I’m tired of building settlements and would really love to use this system (probably going to). I just don’t get why they make everything look so “junky”. People rebuilding would not leave big holes in walls and trash all over.
    1. uituit
      uituit
      • premium
      • 4,041 posts
      • 91 kudos
      Junky is the Art style of fallout 4 .so we tried to keep ROTC cps with the same style :)

      Try some of the city plans from the contest packs or the non ROTC plans.
  8. SubZeroUk
    SubZeroUk
    • member
    • 7 posts
    • 0 kudos
    Hi team,

    Just installed Sim Settlements, ROTC and the Industry mod.

    For ROTC, when I place a desk, and assign a leader, nothing happens.
    I can't select a city plan, and no popup appears about the foundation level beginning.

    Am I missing something?

    Thanks,
    1. uituit
      uituit
      • premium
      • 4,041 posts
      • 91 kudos
      try manual install https://simsettlements.com/web/wiki/index.php?title=Install

      try selecting a city plan before u select a leader
    2. SubZeroUk
      SubZeroUk
      • member
      • 7 posts
      • 0 kudos
      Thanks, but I just reinstalled both SS and ROTC, and uninstalled the Industry, and not it's working.

      Also downloaded the Megapack 3. Did I need this originally?

      I reckon the reinstallation was the ticket, but could also be the megaback.
      Wasn't aware if they were manadatory?
    3. uituit
      uituit
      • premium
      • 4,041 posts
      • 91 kudos
      No megapacks are not required.

      sounds like it was just a bad install
  9. Nebula68
    Nebula68
    • premium
    • 3 posts
    • 0 kudos
    Hey, just wondering if you guys have added the missing vanilla settlements yet like Starlight drive-in and Bunker Hill
    1. uituit
      uituit
      • premium
      • 4,041 posts
      • 91 kudos
      ROTC has city plans for both of those settlements.
      Are they not showing up for you?
    2. PiercePotato
      PiercePotato
      • member
      • 3 posts
      • 0 kudos
      none show up for me at all
  10. birdman808
    birdman808
    • member
    • 2 posts
    • 0 kudos
    Currently trying to build but noticed some things has an offset. After assigning a leader, the buildings are being built within the existing vanilla building. most things like the city desk are clipped into the floor or walls. I've tried refreshing it in the 1.) holotape > settlement tools > refresh local and also 2.) config tools > rebuild local data. but nothing. Any advice?


    Thank you in advance!
    ***EDIT: I found out i was using the "simple and clean" mod sorry. just mod conflicts
    1. uituit
      uituit
      • premium
      • 4,041 posts
      • 91 kudos
      yeah Clean and simple is a good mod it just dosnt play well with city plans ;) but works fine when you free build .
  11. deliriousgpanda
    deliriousgpanda
    • member
    • 1 posts
    • 0 kudos
    I've just installed ROTC and it is awesome! I've always wanted to be hands free in the settlement building system while I adventure. However, I came across this peculiar thing that the settlers do not move within the settlement. They remain wherever they are (e.g. standing on the bed, sitting in a chair, and plain standing, among other things) when I enter the settlement. They do change their position whenever I leave and return to the settlement, but they do not move once I'm there. How might I fix this?

    I have the ff running in my vanilla game (just
    1. Sim Settlements 4.2.0.
    2. ROTC
    3. True Storms - Wasteland Edition (Thunder-Rain-Weather Redone)
    4. Outcasts and Remnants - Quest Mod Plus
    5. Project Valkyrie
    6. Power Armor Animation Changes
    7. Towbie's Realistic Weapon Sounds
    8. Survival Mode Console Enabler
    9. Reverb and Ambiance Overhaul
    1. rizzla
      rizzla
      • member
      • 463 posts
      • 7 kudos
      ROTC is very script heavy and the settler AI takes a backseat. Waiting around in a settlement for 10 minutes can help and you can try the console command tai (twice), which turns the AI off and then on again and can "jumpstart" the settlers back into action. Once all (current) settlements are fully upgraded it should get better/return to normal.
    2. uituit
      uituit
      • premium
      • 4,041 posts
      • 91 kudos


      do you have any of these ? https://simsettlements.com/web/wiki/index.php?title=Problematic_Mods

      do you use scrap mods?
    3. Zombie307
      Zombie307
      • member
      • 5 posts
      • 0 kudos
      ì got thad to even companes wont enter the city
  12. Markking
    Markking
    • member
    • 1 posts
    • 0 kudos
    Kinggath…. I stepped away from F4 for a couple of years. came back to find this! Absolutely fantastic work. Modder of the decade goes to u
    you and your team.

    Thanks
    1. uituit
      uituit
      • premium
      • 4,041 posts
      • 91 kudos
      Thanks Mate , Kinggath and the Team appreciate your kind words
  13. Iere
    Iere
    • member
    • 1 posts
    • 0 kudos
    Hi fellas, I'm having a bit of an issue. I set up a city plan and settlement manager in Vault 88, and left it to build, and then went to do the same for Nordhagen Beach. But when i used the settlement plan on the desk it said that it was using the plan and settlement leader from Vault 88, which did nothing for nordhagen. I dismissed the leader and plan and set up the correct ones for Nordhagen, but when i returned to vault 88 it was using the plan for nordhagen, AKA nothing at all in vault 88. How should i fix this?
    1. uituit
      uituit
      • premium
      • 4,041 posts
      • 91 kudos
      Remove both city plans using the desk in both settlements.
      Scrap using the town gavel in both.
      build desk in both
      assign leaders in both
      then build city plam.

      see if that helps. this problem pops up every once in a while if it still happens please post on simsettlements.com
  14. Loozszy
    Loozszy
    • member
    • 8 posts
    • 0 kudos
    Hi! Im using SS 3 in 1 last version and year 1-2-3 plans, but if i try to push ^E^ to activate city plan on planners desk the menu of companions or upgrades wont work/ Someone knows how to solve that problem?
    1. uituit
      uituit
      • premium
      • 4,041 posts
      • 91 kudos
      For Leaders you will need a least one companion who is your current follower or a mod that allows other NPCs to be leaders.
      Also you can turn of leader requirement if you don't have enough leaders . City building section in the holotape/MCM.

      For Upgrade you need the city to be a 100% and 100% scrap collected and at least 70 happiness.

      If you have that and you cant upgrade try these
      > Scrap desk and rebuild it.
      >Refresh city plan form the city planners desk
      > rebuild Local Data from city holotape Tools> Config tools
    2. Loozszy
      Loozszy
      • member
      • 8 posts
      • 0 kudos
      Sorry for my bad eng, but It looks like you misunderstood me. I cant activate city plan on planners desk even i have active companion or living in settlement and available for mayors post. Ive already tried to rebuilt desk, reinstall ss. I can activate donate module, flag change, crafting workbrench with holotapes and storage of different plans for plots, but i cant use city plan. I see the "press e to activate city plan", but nothing happens. I hope I explained correctly
    3. uituit
      uituit
      • premium
      • 4,041 posts
      • 91 kudos
      Make sure you have the 3 in 1 installed and not just the standalone version of sim settlements.

      If that is already installed try a manual install https://simsettlements.com/web/wiki/index.php?title=Install

      Try downloading another city plan and see if that works https://www.nexusmods.com/fallout4/mods/categories/64/

    4. Loozszy
      Loozszy
      • member
      • 8 posts
      • 0 kudos
      Ive manually reinstall 3 in 1 version, nothing happened.
      Ive tried to install standalone version and rotc and ir, nothing happened.
      Ive tried to install new city plan, nothing happened.
      Menu of city plan isnt appear, i thing that the script that open the menu wont work correctly.
      https://imgur.com/E0WN9x5 i push the "E" and nothing happened.
      If I manually bring a companion to a settlement and assign it to work on the mayor's Desk, I am offered a choice: 1) demolish everything and build according to a certain plan 2) leave everything as it is and build up yourself. If I choose the first, then a random city plan is selected. There is also a problem that there are no new settlers, but it seems to me that this is no longer related to the mod's performance.
      Here is the list of installed SS aspects https://imgur.com/lADyMpG
    5. uituit
      uituit
      • premium
      • 4,041 posts
      • 91 kudos
      If that is all the mods you have it should work fine.

      Is this a new save or old one? As a test try on a new game and see if it has the same problem.
    6. Loozszy
      Loozszy
      • member
      • 8 posts
      • 0 kudos
      I have more than 200 active plugins, most of them targeted to another gameplay options and only SS aimed to building.
      Also i have a problem with starting new game which include an endless loading. Idk how to solve that problem. Thats why i disable Conqueror

      UPD: I have new problem, ive disable all the mods exclude SS plugins and i dont have initialization of Conqueror after editing my character and i cant just exit the vault, same problem, endless loading :)
    7. uituit
      uituit
      • premium
      • 4,041 posts
      • 91 kudos
      The endless loading means you have reached the script limit of fallout 4 and you would have to remove some mods.

      How many city plans do you have? If you have the complex city plans , remove them as they are script heavy.

      If you are getiing stuck on laoding screan on new game with only simsettlements and ss mods ,either you have to many city plans or something wrong with your game files. Verify your fallout 4 game files and make sure your game version is current one.
    8. Loozszy
      Loozszy
      • member
      • 8 posts
      • 0 kudos
      The problem of endless loading is caused by workshop framework. Firstly I think that the problem appears only in RU version, but after installing original plugin nothing was changed. Do you know how to solve?

      And maybe you know why in my game there are no new settlers and water purifiers wont produce purify water? Seems like its same script block both of processes.

      UPD: i check problem with inability to use city plan, and after disabling workshop framework that problem dissapears too.
    9. uituit
      uituit
      • premium
      • 4,041 posts
      • 91 kudos
      Could you please post on simsettlements.com about this issue im not familiar with the workings of WSFW or please post on WorkshopFramework mod page.

      Are you using the RU version for all simsettlement mods?
    10. Loozszy
      Loozszy
      • member
      • 8 posts
      • 0 kudos
      Nope, resource that translated the SS did not update the mod version for a long time, so i downloaded all the plugins from nexus.

      K, ill write some description of that problem on simsettlements.com, could you tell me the topic or the way to the topic where i can write that problem?

      And I also want to say thank you for your help, so I would not have thought to check all the mods that add new scripts)

      UPD: Ive also mark that issue on the WSFW page
    11. uituit
      uituit
      • premium
      • 4,041 posts
      • 91 kudos
      Here https://www.simsettlements.com/site/index.php?forums/ss-help-mod-questions-here.2/

  15. SteynerX
    SteynerX
    • supporter
    • 4 posts
    • 0 kudos
    Hi! first of all, thank you so much for share such a damm great work, your mods are awesome! I'm enjoying your mods, specially this one, but I have a question. Sanctuary is the first place that I'm doing this (
    or rather, they are doing for me lol), I'm at level 2, and the performance of the place is badly, I play in 4k and 60 fps, but in sactuary I have 50-55 fps, but yesterday I was trying to fix it myself lowering the resolution, and even in 1080p resolution, in Sactuary still hits the same frames, 50-55. There's something I can do for fix this? thank you. I have to repeat myself... I love this awesome mod and the buildings are unbelievable, it loks like a bethesda work, or even better.
    1. uituit
      uituit
      • premium
      • 4,041 posts
      • 91 kudos
      You could try some of these https://simsettlements.com/web/wiki/index.php?title=Performance

      Are you using the complex version of sanctuary? optimized version will help but it has smaller number of settlers.

      If you have red rocket/Abernathy built up as well that can affect performance in that area.
    2. SteynerX
      SteynerX
      • supporter
      • 4 posts
      • 0 kudos
      Hey! thank you so much, I will give it a shot :)