12148 comments

  1. kinggath
    kinggath
    • premium
    • 3,292 posts
    • 1,674 kudos
    Locked
    Sticky
    Known Trouble Mods: https://simsettlements.com/web/wiki/index.php?title=Problematic_Mods

    Note that these are not necessarily incompatible, they have just proven to create issues for some players. If you are having strange problems, check the list and read the explanation of the problem next to each mod.
  2. kinggath
    kinggath
    • premium
    • 3,292 posts
    • 1,674 kudos
    Locked
    Sticky
    Patch 4.0.3 is now available for Sim Settlements, Three-in-One, and Conqueror!

    Conqueror is now live! The third expansion pack for Sim Settlements adds the ability to start your game with settlements built up, the ability to attack and conquer settlements, tons of Raider themed options, and even a raider-based quest line!: Conqueror
  3. kinggath
    kinggath
    • premium
    • 3,292 posts
    • 1,674 kudos
    Locked
    Sticky
    SimSettlements.com is now live! Includes a wiki with detailed information on the mod (still a work in progress! ) and forums for comments, suggestions, bug reports, or just hanging out!

    Please make suggestions and bug reports here: SimSettlements.com

    Thanks!
  4. kinggath
    kinggath
    • premium
    • 3,292 posts
    • 1,674 kudos
    Locked
    Sticky
    Three-In-One Version Now Available in the Files tab!

    This includes Sim Settlements, Industrial Revolution, and Rise of the Commonwealth as a single ESM. You should be able to switch in an existing save without issue.

    FYI: Regarding updates to the Three-in-One, be sure to do them manually! NMM does not handle giant files very well and may fail to overwrite everything. Also note that each patch day the Three-in-One will be updated last, after I get confirmation that the individual mods uploaded correctly.
  5. kinggath
    kinggath
    • premium
    • 3,292 posts
    • 1,674 kudos
    Locked
    Sticky
    Patch 3.5.0 introduces a new optional file - RotC Complex City Plans.

    If you were using any of the City plans and had your performance options set to Ultra, you will want to download this mod as well! It's all ESL files, so it won't affect your mod count.

    To read about why I made this change, learn about the newly discovered Fallout 4 limit here: simsettlements.com/scriptlimit

    If you were getting stuck in the Main Menu with the 3.4.6 patch, you will need to pick and choose which, if any, of these ESL files that you use, as the reason you were getting stuck is that you hit the this new-found limitation on your load order.


    Patch 3.5.1 further reduces the script data usage of Sim Settlements. The complex plans were also updated to reduce their usage. In total, we were able to shave over 15 MB of data!
  6. damanding
    damanding
    • premium
    • 3,861 posts
    • 135 kudos
    Locked
    Sticky
    For all those having trouble with Sanctuary, Red Rocket, and Abernathy farm please check this out.

    Triangle Of Death
  7. dzorro
    dzorro
    • member
    • 1,017 posts
    • 16 kudos
    I was wondering if someone can explain this part for me. when you check the mcm. menu for performance tab and look at the options like pets and npc does turing this option on will skip creating npc and pets or will turn this off will skip creating npc and pets ? the description is different then the one given on the hollowtape witch makes it confusing for me since english not my native language.
  8. aki_
    aki_
    • member
    • 87 posts
    • 0 kudos
    Who can help with CTD? I update SS from ~3.0.5 to 4.0.2 and in all settlements where i have SS elements my game just do CTD. I turn off SS and all fine. How to fix that?
  9. casterlyrockn
    casterlyrockn
    • member
    • 118 posts
    • 0 kudos
    Will RotC upgrade building similar to SS upgrade? Or I’ll still have to manually upgrade buildings?
    1. uituit
      uituit
      • member
      • 1,924 posts
      • 56 kudos
      You can have them setto auto upgrade or manuall upgrade.
      check the settings in the holotap Gameplay section
  10. tekmage
    tekmage
    • member
    • 676 posts
    • 21 kudos
    Amazing mod! It runs beautifully on my potato of a PC and you have single-handedly fixed the main aspect that kept me away from Fallout 4 for a number of years. Now, the game feels like what it was probably intended to be. People trying to rebuild from a horrific holocaust. Thank you so much for your tremendous efforts.
  11. MrAllSunday96
    MrAllSunday96
    • member
    • 2 posts
    • 0 kudos
    Hello there, im a bit new to all this about modding but the thing is since ive updated Sims Settlement its happining something wierd, my settlers just stand there, in the middle of the place, not doing anything, has someone had the same issue? Id unistalled a few mods to see if there was anything to do with it but i keep having the same problem. Thanks in advance!!! By the way awesome work Kinggath. (This happens mainly in The Castle)
    1. rizzla
      rizzla
      • member
      • 359 posts
      • 6 kudos
      It's not an unusual complaint and basically a Vanilla issue. It's probably the number of scripts running, straining your system. Here's something kinggath wrote: "When you fast travel to a settlement, all of the settlers are dumped to a central point in the settlement and then told by a script to re-check their AI packages. When your scripts get backed up, that re-check doesn't happen quickly (or sometimes at all)." One suggestion is to open the console and type tai, which toggles the AI off, and after a minute or two do it again to toggle it on again. You can also try the ini settings suggested here:

      https://simsettlements.com/web/wiki/index.php?title=Performance
    2. MrAllSunday96
      MrAllSunday96
      • member
      • 2 posts
      • 0 kudos
      Mate, thanks, all this was dragging me crazy, ive tryed out with the IA and everything started going as usual.
  12. hdharris
    hdharris
    • supporter
    • 7 posts
    • 0 kudos
    I'm having an issue with the mod (i went through and checked each mod one by one first) where the 3 in 1 version (checked again with individual and that does it too, btw!) is causing my game to freeze when I quit. Is this a known issue?
    1. rizzla
      rizzla
      • member
      • 359 posts
      • 6 kudos
      To be honest, happens to me quite regularly. But I don't care. Just save, open the task manager and stop fallout 4 immediately, it's faster. :)
  13. krbrown1994
    krbrown1994
    • member
    • 1 posts
    • 0 kudos
    Any ideas on why sim settlements wont work for me? I've gone as far as trying the nexus and bethesda ported one alone and nothing will work??
     
    Edit: specifically with the rise of the common wealth (as thats all im really interested in) its not even showing me the option in the crafting stations
    1. rizzla
      rizzla
      • member
      • 359 posts
      • 6 kudos
      Have you picked up and loaded the holotape? The installation isn't complete until you do. Check the top floor of the Museum of Freedom.
  14. titanicandthomasfan0
    titanicandthomasfan0
    • member
    • 2 posts
    • 0 kudos
    When I installed the mod, Starlight Drive In deleted the main bar area. Is there anyway to fix this? Thanks.
    1. rizzla
      rizzla
      • member
      • 359 posts
      • 6 kudos
      You'll have to be more specific, I think. Installing the mod should do nothing until you start building in each settlement individually, unless you use the Conqueror addon. And the diner shouldn't get deleted in any case, ROTC integrates it into its build.
  15. Th0raxeThe1mp4ler
    Th0raxeThe1mp4ler
    • premium
    • 99 posts
    • 0 kudos
    I'm having an issue I'm sure I remember seeing in a video somewhere, but it was years ago and the digging is turning up no results. I'm having an issue with certain settlers forgetting their assignment to crops, and keeping their residential assignment. One settler keeps doing their assignment while having their residence, which is a salvager. The other one, assigned to food, seems to forget their food assignment every other in game day.

    EDIT: After having them swap jobs, it seems they swapped back on their own somehow, and my food is still resetting to 0 with completely unworked food. If anyone has any idea what is causing this plz lmk. Im fairly certain it's related to this mod, and potentially another one

    EDIT2: I'm thinking it may just be a Triangle of Death issue.
    1. uituit
      uituit
      • member
      • 1,924 posts
      • 56 kudos
      Do you have any of these mods https://simsettlements.com/web/wiki/index.php?title=Problematic_Mods

      how built up are the triangle of death settlements
    2. Th0raxeThe1mp4ler
      Th0raxeThe1mp4ler
      • premium
      • 99 posts
      • 0 kudos
      No. After reading through the triangle of death post, it seems the only thing I did to potentially cause an issue is turn down the timescale. The issue happens 100% of the time that I come back from roaming for loot, and doesn't happen for 100% of the time I stay near Red Rocket.

      The only settlement I have built in at all is Red Rocket, and I experienced the issue at 2 people, as soon as I had someone working food. Sanctuary doesn't even have Preston and Pals.

      EDIT: I haven't tried turning off auto assignment, so if it begins to annoy me more than reassigning the food worker every time I return then I may try that.
      Mods
      Spoiler:  
      Show
    3. belinda
      belinda
      • member
      • 52 posts
      • 1 kudos
      I'm having the same issue as Th0raxeThe1mp4ler, that my settlers somehow loose their important assignments when I leave the settlement and come back later (e.g. food harvesting in default sanctuary place, never build a ss plot for food). From the triangle of death places, I only build in sanctuary so far. 13 settlers, 13 residential plots, minor other stuff (e.g. few turrets, generators, water pumps).

      My timescale is set to 10 though (from default 20). Please post here if you find a solution, I would be happy to hear if this is solveable on my end.
    4. Th0raxeThe1mp4ler
      Th0raxeThe1mp4ler
      • premium
      • 99 posts
      • 0 kudos
      @belinda I'm using the same timescale. Red Rocket is only 4 Residential, 1 Martial, 1 Industrial, and 1 Commercial. Half of them aren't even assigned at all yet, ala not being used. My settler is also assigned to actual crops instead of an agricultural plot, I will also see if that gets around this issue or not.

      Turning off Auto assign and using Agricultural Plots didn't help, and it only seems to be happening for food and housing.
    5. belinda
      belinda
      • member
      • 52 posts
      • 1 kudos
      I reset timescale to 20, played a few hours, but the problems persists.
    6. Th0raxeThe1mp4ler
      Th0raxeThe1mp4ler
      • premium
      • 99 posts
      • 0 kudos
      After playing last night I have confirmed the following:

      • So far, ONLY the citizens working crops OR agricultural plots forget their assignment, and usually their residential assignment as well. This has happened 100% of the time that I return from roaming, and about 15% of the time that I sleep for long periods of time (6-10 hours).
      • Turning off auto assignment does not stop the citizens from forgetting their assignment
      • Problem began as soon as I had settlers working food (2 to be exact)
      • In 1 particular instance, one of the offending settlers became bugged, and would only assign to a single crop per command, instead of as much as they could detect in the area. Changing which settler I used fixed this.


      I feel like there's something else I can confirm about the relationship between farmers' (both crop and plot) assignments between work and residential. Seems like everytime the issue happens, I have to make at least one of them move back into their own residential lot but I have more testing to do.
    7. uituit
      uituit
      • member
      • 1,924 posts
      • 56 kudos
      try a manual install and refresh everything in that settlement
    8. Cicattrix
      Cicattrix
      • member
      • 437 posts
      • 6 kudos
      You can reinstall SS and whatever mods you want, the issue will remain, because is baked into that save. Once you changed the timescale, that save will start to crack in a spiral. It seems that the workshop scripts dont like such major changes and the settlement system gets bugged.
      I have fallen too for the ”timescale” lowering. I went to 6, as some recommend, for immersion. After that I started to have issues. I have forced that save with many experimental mods, installed, removed, went forth, it resisted at a lot of stress, with the help of Fallrim Tools, ofc. Until I hit it in the head with the timescale change. I tried everything to save that ”save”, for no good.
      This tweak may be fine for an exclusive shooter run, but is deadly bad if you wanna play builder too. Better start a new game, removing at least the timescale changes.
  16. qways
    qways
    • supporter
    • 13 posts
    • 0 kudos
    hello

    im having a wierd problem i hope u guys can help me with
    before using the city manager desk the games works fine for a couple of hrs
    the moment i place the desk and assign a leader and start building ill get some wierd animation wihin the hour

    my chars view goes to 1st person and the kamera starts floating to the right and i hear death music like my char died only the game does not reload it just keeps floating away

    i tried a few game trough and like i said if i dont build the desk and activate it with a leader the that animation never shows for multiple gamplay hrs... the moment i do it within the next 20-60 mins will start happeing, also it seems like its timed coz i once save the game like 2mins before the animation poped up and every time i reloaded the game the animation started at the same time
    p.s.
    oh yea the thing was happening on version 4.0.2 now im dling 4.0.3 to see if it will fix it
    thx

    p.s 2
    seems i can open the map while floating and teleport, game works now now will see if the bug repeats again
    1. uituit
      uituit
      • member
      • 1,924 posts
      • 56 kudos
      you can turn off cinematic mode off in the holotape and see if that's the cause of the bug. Gameply>City Building
    2. qways
      qways
      • supporter
      • 13 posts
      • 0 kudos
      u might be on to somthing i just the bug just repeated itself while i was in sanctuary and it went from lvl 0 to lvl 1 the moment it hapend i started floating away after teleporting back to sanctuary it was upgraded to lvl 1 will turn off cinematics and see if it repeats thx
Top