X: Rebirth

File information

Last updated

Original upload

Created by

MadJoker

Uploaded by

mad_joker

Virus scan

Safe to use

105 comments

  1. jeedge
    jeedge
    • premium
    • 279 posts
    • 7 kudos
    Author's comment from stame chop shop (intended):
    "IMPORTANT NOTE: This mod is not compatible with the newest versions of the game. There are no plans to continue development. However, if someone wants to pick this up, feel free to contact me."

    That was from Feb 2015 so long dead mod...
    1. Magneto555
      Magneto555
      • member
      • 19 posts
      • 1 kudos
      Thanks for the info.
  2. kraken035
    kraken035
    • member
    • 26 posts
    • 0 kudos
    sad story still no UPDATE
  3. MichaelSeph
    MichaelSeph
    • member
    • 48 posts
    • 0 kudos
    Sucks it looks like it wont be for Home of Light pack...
  4. kokok
    kokok
    • member
    • 318 posts
    • 35 kudos
    It's not working for me. It says "LibMJ script is missing". Where csn I get it?

    I'm using Steam version 3.61 of the game
    1. adekan
      adekan
      • member
      • 31 posts
      • 0 kudos
      Mod maker hasn't updated it since the last major patch, and probably won't. Dead mod.
    2. kokok
      kokok
      • member
      • 318 posts
      • 35 kudos
      too bad. good mod based on description
  5. sigmaservice
    sigmaservice
    • member
    • 1 posts
    • 0 kudos
    Hi Sir, may I have an UPDATE compatible for version 3.53 please? Without this very good MOD, the fleet don't work. Ty in advance
    1. ntnssc
      ntnssc
      • member
      • 128 posts
      • 1 kudos
      And here I was about to try "demo version" in hopes that this game is no longer a s*** stain product.
  6. jecooll2000
    jecooll2000
    • member
    • 5 posts
    • 0 kudos
    SIr we need this mod can you update it to v3.60 plss tnx
  7. ElHyperion
    ElHyperion
    • member
    • 5 posts
    • 0 kudos
    So is this mod dead?
  8. jecooll2000
    jecooll2000
    • member
    • 5 posts
    • 0 kudos
    sir can you create a compatible version for v3.50 plsss thanks
  9. athropos20
    athropos20
    • member
    • 2 posts
    • 0 kudos
    XR 3.5 compatibility will be much appreciated.
  10. zrd52
    zrd52
    • member
    • 1 posts
    • 0 kudos
    Can update for XR 3.5?
    Thanks