Watch Dogs
0 of 0

File information

Last updated

Original upload

Created by

Vik

Uploaded by

Luke2135

Virus scan

Safe to use

Tags for this mod

22 comments

  1. Norvell1984
    Norvell1984
    • premium
    • 21 posts
    • 0 kudos
    I still; own the game so I play everyso often... Does this mod still apply or has the game been heavily updated since then?
  2. IdealLogic
    IdealLogic
    • member
    • 391 posts
    • 7 kudos
    There is a critical bug that may be able to be resolved by you with this editor.

    In the Bad Blood DLC, the R/C gadget, "Eugene," has a glitch that when you use it, the camera for it is sent underground instead of behind it, and get's locked there. This is a fatal error because the gadget is extremely useful and required in the DLC's story.

    The bug originates from either modified cameravehiclepreset.lib or cameracontext.lib files, and I'm more willing to bet it's the latter.
    People have already tested and confirmed that Marduk's Merged Mod and cmh175's configurable TheWorse Mod both do not create this issue and most likely contain the code required for it to work properly.

    I've also notified Yizan about this since I favor his camera modification above all others.

    Edit 1: After further research and tinkering, I found out Yizan's cameracontext.lib lacked a Vehicles.dlc01_DLC_ToyCarActionCam.xml file when I decompiled it and compared it to the cameracontext.lib from cmh175's configurable TW mod. Testing now to see if adding it to yours prior to recompile will fix the issue.
    This leads me to believe that a fix for the issue entirely is to offere a checkable step for mod installation determined by the user where Vehicles.dlc01_DLC_ToyCarActionCam.xml is added to cameracontext.lib through the installation, by queing cameracontext.lib to be decompiled, add the .xml into the decompiled librarires, then recompile and name to the proper .lib file and install.

    Edit 2: It didn't fix it, but found it was both the .lib files as the other should also have Vehicles.BaseVehiclePreset.Speed.dlc01_01_ToyCar.x ml and Vehicles.BaseVehiclePreset.Speed.dlc01_01_ToyCarLa rge.xml. Good news is, mystery solved entirely.
    1. Luke2135
      Luke2135
      • supporter
      • 205 posts
      • 25 kudos
      I'm glad the mystery is solved, because I can't do anything about it. If Yizan (or anybody else) updates his cameracontext.lib file, all you need to do is copy it to the WDConfigTool/Mod_select/WunkleyYizanSuperS folder overwriting the one in there. At least I think that's the correct folder. Editing .lib files for Watch_Dogs is not my specialty.
  3. DEmonCrypt
    DEmonCrypt
    • supporter
    • 5 posts
    • 0 kudos
    Will there be an update for the newest v1.6 patch?
    1. Luke2135
      Luke2135
      • supporter
      • 205 posts
      • 25 kudos
      Ubisoft patch v1.06.329 didn't change anything in the patch.dat and patch.fat files so it is not necessary.
  4. BadNewsBearJew
    BadNewsBearJew
    • member
    • 1 posts
    • 0 kudos
    getting an issue, where I don't get audio from certain npc's and player. Thoughts?
    1. Luke2135
      Luke2135
      • supporter
      • 205 posts
      • 25 kudos
      I think the Disrupt.bin tool is not perfect, and not all files were identified. Probably that's why some audio files are missing.
  5. younggun821
    younggun821
    • member
    • 25 posts
    • 0 kudos
    Error - could not find file: HQ_mods/HQ_mod_warm/patch.fat.
    1. Luke2135
      Luke2135
      • supporter
      • 205 posts
      • 25 kudos
      You have to put the HQ warm mod into the appropriate folder. Otherwise the config tool won't find it.
  6. DunderJack
    DunderJack
    • member
    • 11 posts
    • 0 kudos
    Please excuse my last comment. I understand it now.
  7. DunderJack
    DunderJack
    • member
    • 11 posts
    • 0 kudos
    I don't quite understand what you do after you select your settings and hit the install button. Could someone please elaborate?
  8. mercurius44
    mercurius44
    • premium
    • 5 posts
    • 0 kudos
    same as socola here,need fix plz!
    1. Luke2135
      Luke2135
      • supporter
      • 205 posts
      • 25 kudos
      You mean in version 1.4? The path should be fixed now. Anyway, you can manually copy the created patch.dat and patch.fat to your game directory from the config tool's Mod_patch directory.
  9. socola
    socola
    • member
    • 10 posts
    • 0 kudos
    it doesn't work...

    Game directory: D:\Program Files\Ubisoft\WATCH_DOGS

    Step 1 finished successfully.
    Step 2 finished successfully.
    Step 3 finished successfully.
    Step 4 finished successfully.
    Step 5 finished successfully.
    Error - could not write file: D:/Program Files/Ubisoft/WATCH_DOGSdata_win64/patch.dat.
    Error - could not write file: D:/Program Files/Ubisoft/WATCH_DOGSdata_win64/patch.fat.
    Something terrible happened. Just when I thought I'm about to finish...
  10. kilyan
    kilyan
    • member
    • 51 posts
    • 0 kudos
    just trying to start the tool by double clicking the exe,it gives that error
    1. Luke2135
      Luke2135
      • supporter
      • 205 posts
      • 25 kudos
      What error? The one happened in version 1.0? I looked the code again and there is only one thing at startup that may cause this error, but it is so essential to the program I need to completely redesign it if I want to avoid it. Sorry, can't help with that.
    2. Luke2135
      Luke2135
      • supporter
      • 205 posts
      • 25 kudos
      Ok, I think we managed to figure out what was the problem. Try version 1.3. It should work now.