Security update for Nexus Mod Manager

  • Comment

Today we are releasing some security updates for the Nexus Mod Manager to bring us in line with the new EU GDPR rules coming into force next month.

NMM has been "end-of-line" since 2016, which means we no longer provide any official support for the software, but we thought it was prudent to spend the time and money to release this update so our users could continue to use the software's online services while ensuring we're compliant with the new regulations. We also did not want people to think we were using the GDPR as an excuse to force people on to our new mod manager, Vortex, either. The alternative was to simply turn off the old services completely, essentially making NMM, and any other software using our old login services, offline only.

To prevent any drama with this process, we've even patched up version 0.52.3 of NMM (the last version before the profile functionality was added) so there are no complaints.

In order to be compliant, we need to turn off our old, less secure login to the web services completely. We plan to do this on Tuesday the 8th of May. This will mean anyone who does not update their NMM will no longer be able to use NMM online. This will prevent you from being able to login, check for new file versions or download mods from the site directly in to NMM. This will also affect any other software that uses the old login destination and method, for example, Mod Organizer. We do not officially support Mod Organizer, nor is it made, updated or maintained by us, so any updates needed to ensure it works with our new login service will need to be handled by the team behind Mod Organizer. If you are currently a coder with software making use of the old Nexus login system, please do get in contact via PM or Discord and I will put you through to the appropriate person to help you get on to the newer system as soon as possible.

For convenience, both updated versions of NMM can be found on a new file page setup to make this a little easier. Remember, download 0.65.0 if you are using a version of NMM that is 0.60.x or later. Download 0.52.4 if you are using version 0.52.3 of NMM.

Apologies for the inconvenience caused, but it's 8 year old code now and, at some point, this was going to happen!

440 comments

  1. UnstableTexan
    UnstableTexan
    • member
    • 3 posts
    • 0 kudos
    Apparently, if the NMM is on version 0.65.2, it will not update when it automatically tries to on startup after booting up my PC, or even if i launch the updater manually.
    Apart from that, it functions flawlessly and runs really smooth.
  2. AngelPhoenix69
    AngelPhoenix69
    • member
    • 135 posts
    • 0 kudos
    I am sure this question was asked, but how do I update?
  3. CG26511
    CG26511
    • member
    • 1 posts
    • 0 kudos
    hey i am having the same problem but my firewall is allowing NMM through but i still get the cannot contact server problem
  4. tbarnes10
    tbarnes10
    • member
    • 3 posts
    • 0 kudos
    So, I updated like it said and, I still cant't update. I still get an error message when I try to log in WHAT AM I DOING WRONG!!!!!!!
  5. TheGreatFalro
    TheGreatFalro
    • premium
    • 555 posts
    • 19 kudos


     
    In response to post #59936501. #59937496, #59943296, #59945531, #59946251, #59950841, #59955056, #59955076, #59959966, #59967171, #59973026, #60019421, #60030726, #62346667, #62348552 are all replies on the same post.


    Spoiler:  
    Show

    Hi,Andarus, would you be kind enough to explain this in PC Idiot, because I have no idea what u trying to say. Would it be possible to address this as a step by step process, certainly do not want to to inconvinence you. But , you would be greatly helping one of the oldest player here (1956) tahnking you in advance for any guidance to this problem.
     


    I don't know your skill level, so apologies if this is too much info.
    The Mod Organizer developers have released a patch that makes this unnecessary.  Click here: https://www.nexusmods.com/skyrimspecialedition/mods/6194?tab=files and scroll down a little until you see "Miscellaneous files", and under it "Mod Organizer 1 Legacy" and a light blue check mark next to it.  Click the words "Mod Organizer 1 Legacy", and the box will expand.  Then click "Manual Download" and wait for your web browser to download it.  Open the file called "Mod Organizer 1 Legacy-6194-1-3-15.zip" and you should see a list of files.  Press (on your keyboard) CTRL and A at the same time, and it will select all of them.  Then press (again on your keyboard) CTRL and C to copy them.  Then go to where you have installed Mod Organizer (most likely C:\Program Files (x86)\Mod Organizer or C:\Games\Mod Organizer ) and press CTRL and P to paste them.  Say "yes" or "overwrite" if it asks you.  Then you're done!
    1. Onespirit10
      Onespirit10
      • premium
      • 5 posts
      • 0 kudos
      Thank you!
    2. awjnash
      awjnash
      • premium
      • 522 posts
      • 10 kudos
      Thank you very much!
  6. SquidBox
    SquidBox
    • supporter
    • 48 posts
    • 0 kudos
    If you're still getting the firewall message when using 0.65.9 then it's likely exactly that, your firewall isn't letting NMM connect to the Nexus servers.
  7. tbarnes10
    tbarnes10
    • member
    • 3 posts
    • 0 kudos
    I'm really bad at this stuff so maybe I'm doing something wrong. I updated Nexus to 0.52.3 from the link in the post. It still said "either your firewall is blocking NMM or the login server is down". Then I saw a post by "cery30" saying to go to "https://github.com/Nexus-Mods/Nexus-Mod-Manager/releases" and now I have version 0.65.9. but I still get the same error message when I log in. What am I doing wrong?
  8. cery30
    cery30
    • member
    • 6 posts
    • 0 kudos
    Thank you!!!!!! Finally i'm able to mod again (quite dumbass without nexus, i owe my left testicle to NMM)
    https://github.com/Nexus-Mods/Nexus-Mod-Manager/releases
    That site is legit as it can be, for those who might be afraid. Works like a charm!
    1. acm2000
      acm2000
      • member
      • 2 posts
      • 0 kudos
      Thanks to you too it works !!!
    2. Lizski
      Lizski
      • member
      • 2 posts
      • 0 kudos
      Amazing thank you - worked for me
  9. soilpants
    soilpants
    • member
    • 3 posts
    • 0 kudos
    now i can't get nexus to update no matter what i do !
  10. Athelbras
    Athelbras
    • member
    • 5,068 posts
    • 172 kudos
    Go to this link for the current version of Nexus Mod Manager:

    https://github.com/Nexus-Mods/Nexus-Mod-Manager/releases


    [ the "new file page" link in the article above is for a much older version that is very buggy -- do not use NMM v0.65.2 ]
    1. epicmainbro114
      epicmainbro114
      • supporter
      • 92 posts
      • 3 kudos
      There's an issue with the latest update for NMM - it stops you from moving mods in the plug-in section of NMM (0.65.8) It is being looked at by Squid-Box I believe

      https://github.com/Nexus-Mods/Nexus-Mod-Manager/issues/482
    2. Athelbras
      Athelbras
      • member
      • 5,068 posts
      • 172 kudos
      Yes, there continue to be various issues, even with the latest version. For example, if a mod contains an .esl file, instead of .esp, then NMM may seemingly install the mod, but the .esl file might not actually be enabled. That, too, has been reported. But even so, the latest version works better than v0.65.2.

      For those who are interested, here is a link to the current list of reported issues:

      https://github.com/Nexus-Mods/Nexus-Mod-Manager/issues
    3. surefirebeast05
      surefirebeast05
      • member
      • 2 posts
      • 0 kudos
      Thank you so much!
    4. DragonStar99
      DragonStar99
      • supporter
      • 693 posts
      • 21 kudos
      Thanks for posting this link here.
REPORT BUG
Top