Skyrim Special Edition

File information

Last updated

Original upload

Created by

Icecreamassassin

Uploaded by

icecreamassassin

Virus scan

Safe to use

242 comments

  1. icecreamassassin
    icecreamassassin
    • premium
    • 22,543 posts
    • 990 kudos
    Locked
    Sticky
    New version 4.0 is available. Incorporates the much better textures, reworks much of the functionality of the weapons, removed the level up notices and prevents stacking power ups from reloading saves while the game is running. I have no looked into this speed glitch because I only now noticed it and I never had it occur in testing, so if it does persist in this iteration, let me know and I'll look into it specifically. Most perks were reworked to some degree or another, so I HOPE this is not an issue in V4.

    Thane Weapons Reborn V4

    -Optimized weapon leveling script to prevent same-game instance save reload from stacking level up bonuses
    -Removed notifications for weapon maintainance and leveling.
    -Fixed missing TWR load screen graphic

    Scripts to clean: These scripts should be cleaned using Falrim tools if you are
    upgrading a game in progress:

    twr__qf__03006f54
    TWR_LevelupOnLoad
    TWR__QF_TWR_Quest2_03005446

    It would be best to remove your previous version of TWR entirely before installing this version or do a full replace when installing.
  2. sirjesto
    sirjesto
    • supporter
    • 12,123 posts
    • 299 kudos
    Locked
    Sticky
    June 3rd, 2018

    Thane Weapons Reborn V4.2

    - Updated the auto thane weapon updater which fires the first time you load TWR which exchanges the vanilla reward for the TWR one.
    - Fixed "no longer contains that property" harmless spam on the player level up script

    Script to clean: This script should be cleaned using Falrim tools if you are upgrading a game in progress:

    TWR__QF_TWR_Quest2_03005446
  3. icecreamassassin
    icecreamassassin
    • premium
    • 22,543 posts
    • 990 kudos
    Locked
    Sticky
    Just a special note to Legacy of the Dragonborn users, that as of V5 of Legacy SE, Thane Weapons Reborn will be integrated into Legacy and TWR should no longer be installed separately if you are using Legacy. TWR for SE will remain on Nexus for non-legacy players to continue enjoy however.
  4. nicebagdad
    nicebagdad
    • premium
    • 172 posts
    • 0 kudos
    for some reason I am not receiving any weapons as a thane reward. Nothing, I got the housecarl but nothing else.
    any idea where I could look to troubleshoot this?
  5. rmn498
    rmn498
    • premium
    • 16 posts
    • 0 kudos
    I just completed Dragon Rising and ran into a strange issue. I got messages indicating that I received both the Sword of Winterrun and the Axe of Winterrun. The sword appears to have no abilities and the axe does not appear in my inventory. Is this a known issue?
    1. dann1telecom
      dann1telecom
      • premium
      • 50 posts
      • 3 kudos
      same here
    2. sirjesto
      sirjesto
      • supporter
      • 12,123 posts
      • 299 kudos
      Do you guys use any other mods that modify Thane Weapons?
      Also, getting both weapons is normal.
      The Weapons powers are added by script which is not the usual way weapon powers are granted (by an object enchantment).
  6. JesusInAPotatoSack
    JesusInAPotatoSack
    • supporter
    • 44 posts
    • 1 kudos
    I just got the staff of Winterhold (Using LOTD V5) and the staff says "this item cannot be unequipped". No idea what's going on. Any ideas?

    Edit: I'm a moron and just clicked a different staff and it worked just fine
  7. Neecher
    Neecher
    • member
    • 1 posts
    • 0 kudos
    Hey, the unique effect for the Blade of Solitude has a spelling error in it, just so you know!
  8. dylanthebanana
    dylanthebanana
    • member
    • 35 posts
    • 0 kudos
    I have a few of these on my play-through but they don't level up with me, they actually suck and are about as good as steel weapons. Has anyone had a similar problem like this or know a way to fix this?
    I have this on xbox btw
    1. sirjesto
      sirjesto
      • supporter
      • 12,123 posts
      • 299 kudos
      The way to fix it is to uninstall it and get a different mod then. One that doesn't "suck".
      Also, the version on xBox wasn't ported by us, so you'll need to get support there.
    2. pasjaskyrim
      pasjaskyrim
      • member
      • 118 posts
      • 0 kudos
      you can buff them in creation kit. I have lotd and i replaced all the models and buffed the stats to elven pretty easily. the script effects are really unique so this mod is great if only for that!

      edit: although I must say, not sure if the legacy version is very representative of this one but the stats are extremely questionable.
      sword versions swing at 1.1 compared to vanilla 1, while greatswords swing at .7 compared to vanilla .75?
  9. blobbygobster
    blobbygobster
    • premium
    • 3 posts
    • 0 kudos
    Hi,

    I have no idea if I glossed over something or not, but I just went to get the Bow of Falkreath but while I got the Bow I also got the regular thane weapon as well as my bow is now showing the error sign. Unsure what's conflicting with the files but for some reason it's just the bow, not any of the other weapons. Again, I don't know if I didn't read something somewhere so I have no clue if this is a load order issue or what. It just seems very interesting that the bow is only being effected.
  10. Qwafee
    Qwafee
    • supporter
    • 161 posts
    • 16 kudos
    Hihi! Can I share my adds to this on nexus?
  11. malone423
    malone423
    • member
    • 103 posts
    • 0 kudos
    Do the weapons’ intended effects still work when used by followers?
  12. itsbosco1025
    itsbosco1025
    • supporter
    • 49 posts
    • 0 kudos
    I am using LoTD V5 and i cannot get the Falkreath bow, it just gives me the normal weapon, is there anyway to get it using console commands or cheats ?

    P.S. I have tried the console command on LoTD wiki, it does not work
    1. sirjesto
      sirjesto
      • supporter
      • 12,123 posts
      • 299 kudos
      If you use LotD v5, you should NOT have this mod installed.
      A little reading (Like the sticky right above this comment, for one) would have saved you from having to start over, which you will need to do now, after removing this mod from your load order.
    2. itsbosco1025
      itsbosco1025
      • supporter
      • 49 posts
      • 0 kudos
      When I mean i was using LotD v5 I mean i am using thane weapons reborn integrated version, but I still do not have the weapon for some reason,other weapons worked just fine
    3. sirjesto
      sirjesto
      • supporter
      • 12,123 posts
      • 299 kudos
      You should be commenting on the Legacy page then.
  13. xcal68
    xcal68
    • member
    • 439 posts
    • 12 kudos
    If I'm using LotD V5, will I still benefit using the 4k texture from here? Or is that the texture quality included in LotD V5? Sorry if that was asked/answered, but I may have missed it when searching.
    1. sirjesto
      sirjesto
      • supporter
      • 12,123 posts
      • 299 kudos
      Yes, you can use the texture pack from here.
    2. xcal68
      xcal68
      • member
      • 439 posts
      • 12 kudos
      Awesome, thank you.