2024 comments

  1. Chesko
    Chesko
    • supporter
    • 6,385 posts
    • 2,876 kudos
    Locked
    Sticky


    Hey guys, I put together a short survey. I'd really like to know what you think and how I could improve the mod. I take your feedback very seriously. Thanks!
  2. Chesko
    Chesko
    • supporter
    • 6,385 posts
    • 2,876 kudos
    Locked
    Sticky
    Frostfall 3.3.1 is now available on PC on the Nexus!

    The big changes in this release:

    - Detailed out-of-the-box compatibility with all equipment in Immersive Armors SE!

    - Fixed tons of bugs. Most of the bugs were related to clothing detection. I also fixed the issue where the game would crash to the desktop / Xbox Home screen when selecting Quit to Main Menu.

    - Bound cloaks are available once again. This means that all classic Frostfall spells are now available.

    - When equipping gear, you'll see the grade of its protection (poor, good, excellent, etc). This will help give some much-needed context to the numbers and help you compare equipment.

    - The Inspect Equipment power was added. Using this power, you can configure the protection of nearly any kind of gear, including mod-added equipment. (If you change the position of your armor mods in your load order, you may lose your custom settings, if you've set any. You'll have to set it again in that case.)

    - Added a few new tutorials regarding fire, shelter, and equipment protection, as a result of survey feedback.

    - The Endurance skill now progresses 25% faster.

    - Cloth cloaks now grant a bit more protection.

    - Mod authors can now add their own default equipment protection using injected keywords. Just follow this tutorial.

    For full patch notes, see this page.

    Cheers,

    - Chesko
    1. dizzyXcore
      dizzyXcore
      • member
      • 973 posts
      • 8 kudos
      This should be a sticky, glad I surfed through the comments to read that Immersive Armors SE is compatible now with Frosftfall 3.3.1! I am bumping this post so others who come here wondering the same easily find it!
    2. Chesko
      Chesko
      • supporter
      • 6,385 posts
      • 2,876 kudos
      Great idea; done
  3. BunnyAng97
    BunnyAng97
    • premium
    • 133 posts
    • 1 kudos
    Not sure if this has been asked before but I'm using Better Vampires which makes vampires realistically don't breath and unaffected by the cold. If this is installed will my vampire suffer from hypothermia?
    1. Dracotorre
      Dracotorre
      • supporter
      • 1,240 posts
      • 70 kudos
      Yes and no. Frostfall includes a vampire setting to choose mortal-like or immune to hypothermia. However, current version 3.4.1 contains a bug (author fixed for next update) so your vampire may still succumb to frostbite and hypothermia. All vampires (including "Better Vampires" or "Sacrosanct") get a warmth bonus, so less likely to suffer cold. After gaining a few Frostfall Endurance perks (improves warmth), a vampire should no longer be concerned about the cold. My vampire with max endurance perks travels all night long in ordinary clothes never suffering frostbite or hypothermia.
  4. wenderli78963
    wenderli78963
    • member
    • 2 posts
    • 0 kudos
    Chesko help please https://imgur.com/fD3HBlT..
    1. Seekr
      Seekr
      • premium
      • 12 posts
      • 0 kudos
      Im getting this too.. Just started to play Skyrim SE and never had this problem on oldrim. What is this?
    2. Seekr
      Seekr
      • premium
      • 12 posts
      • 0 kudos
      Heres the fix: https://www.nexusmods.com/skyrimspecialedition/mods/17925?tab=description
  5. bioboygamer
    bioboygamer
    • member
    • 4 posts
    • 0 kudos
    I'm having a bug where my equipped clothing/armor isn't affecting my total Warmth/coverage at all. In addition, I don't have the equipment configuration in the Powers menu. I've tried several of the suggestions and fixes people have given me, and even messaged Chesko with no response. Does anyone have any advice, suggestions, or anything?
    1. Dracotorre
      Dracotorre
      • supporter
      • 1,240 posts
      • 70 kudos
      Sounds like you have SKSE64. Make sure have latest version of Campfire 1.12.1. Install PapyrusUtil SE and let overwrite file (PapyrusUtil.dll) that came with Campfire. (edit: if new to Frostfall) Load a save from before first starting Frostfall then startup Frostfall. Your armor warmth and coverage will work.

      To get the Power spells back use console commands Help to find ID of those spells and player.AddSpell. If you want MCM or Frostfall meters, either wait for Chesko's official update or try Sthaagg's Unofficial Patch which is based on my workaround instructions using Chesko's updated scripts and the SkyUI interface files from 32-bit Frostfall.
    2. bioboygamer
      bioboygamer
      • member
      • 4 posts
      • 0 kudos
      Well, given how far along I now am, I don't know how viable the first part is, although I tried doing just that before my current playthrough, and it didn't do anything.

      I am actually using the unofficial patch, and the meters are working fine - it's just the total Warmth and Coverage that aren't working.
      Also, I never had the Powers in the first place, so it's not a matter of getting them 'back'.
    3. isaac1207zeede
      isaac1207zeede
      • member
      • 4 posts
      • 0 kudos
      I don't think you have to load from before the first loading of frostfall. Just inspect clothing and then click the "reset defaults" option.
    4. DoctuhD
      DoctuhD
      • member
      • 3 posts
      • 0 kudos
      I also had this problem and just fixed it. Try to install *both* Papyrus and SSE engine fixes, in case you forgot one, as detailed in the Unofficial Patch's instructions. Worked for me on my current save without having to reinstall Frostfall or anything. Once I was back in the game I just re-equipped my gear and it worked without having to do anything or adjust the widget layout. I run my mods in MO2 if that matters.
    5. bioboygamer
      bioboygamer
      • member
      • 4 posts
      • 0 kudos
      If we're talking about the option in the MCM, I've done that, and it did nothing.
    6. Dracotorre
      Dracotorre
      • supporter
      • 1,240 posts
      • 70 kudos
      I am actually using the unofficial patch, and the meters are working fine - it's just the total Warmth and Coverage that aren't working.

      The only causes for warmth and coverage being zero is PapyrusUtil SE incorrect for your version of SKSE64 or bad SKSE64 installation. That's it. Update PapyrusUtil SE (v3.6b for SKSE64 2.0.11 and 2.0.12) and make sure new PapyrusUtil.dll file overwrites old file in folder, Data\SKSE\Plugins. If using MO, sort PapyrusUtil SE last.

      With correct PapyrusUtil.dll file warmth and coverage will work. Each time updating Skyrim and updating SKSE64 also update PapyrusUtil SE. (edited for clarity).
    7. Dracula420
      Dracula420
      • member
      • 938 posts
      • 45 kudos
      the current skse64 build is 2.0.12 not 2.0.11. are we suppose to use the slightly older version?
    8. Dracotorre
      Dracotorre
      • supporter
      • 1,240 posts
      • 70 kudos
      the current skse64 build is 2.0.12 not 2.0.11. are we suppose to use the slightly older version?

      Yes, and sorry, my post could have been more clear. In this case PapyrusUtil SE 3.6b works with SKSE 2.0.11 and 2.0.12. Your armor warmth should be non-zero. Sometimes SKSE will update--such as 2.0.12 for fixing a bug--and PapyrusUtil.dll file continues to work since no changes to Skyrim. The reason PapyrusUtil stops working is when a Skyrim game update changes enough so that the SKSE and PapyrusUtil DLL files need to be rebuilt.

      Now more clearly stated: after a Skryim game update followed by SKSE update expect a PapyrusUtil update. If armors have warmth values greater than zero, PapyrusUtil is working.
  6. gabrielpatty
    gabrielpatty
    • member
    • 34 posts
    • 0 kudos
    Im still having 25 warmth and zero coverage. Im wearing things that have warmth 110 but it doesnt add up to the total.
    1. MikeAlpha310
      MikeAlpha310
      • member
      • 10 posts
      • 0 kudos
      Same problem, 38 warmth and zero coverage. I tried several things to test what's going on but to no avail. Checking in mcm, disabling and reenabling in order, uninstalling and reinstalling in the right order to. I have the SKSE 2.0.12, latest Papyrus, and the unofficial update for campfire and frostfall.
    2. duke5567
      duke5567
      • premium
      • 14 posts
      • 0 kudos
      I found that campfire installed a Papyrus.dll that messed it up. If you install latest papyrus after campfire it should work as it will overwrite the incorrect file.
    3. Berniebobs
      Berniebobs
      • member
      • 6 posts
      • 0 kudos
      Had the same problem, Thanks for the advice.
  7. DIABULUSKIRA
    DIABULUSKIRA
    • member
    • 1 posts
    • 0 kudos
    Hi. I am new with skyrim.. I know it is old game, but first time i am playing it and i started using mods. And very important thing is that ia have skyrim, not skyrim SE. I have installed frostfall and everything i need to run frostfall (SKSE1.7.3, campfire, SkyUI), but meters are not there. everything is set as it should be text shows in upper left corner that show if it cold, warm etc. but it would be a lot easyer to see meters. Important thing is that i have low spec PC and i play with lower resolution so i could get about 30 or more FPS. I have not tried to change my resolution, but i think it should not be problem with that because everything else is fine. Can anyone help me to solve this? Maybe there is some patch or something i need to install to work properly.Thanks.
    1. Dracotorre
      Dracotorre
      • supporter
      • 1,240 posts
      • 70 kudos
      First, the Frostfall for original Skyrim is over here: www.nexusmods.com/skyrim/mods/11163/?

      During installation make sure to include SkyUI-Addon. In game, go to MCM Frostfall and look for the meters section. For testing enable always on. Try switching corners. Back in game if you see don't see meters then try another corner. When you see meters then go back to MCM to disable always on.
      (edit) also note that setting options for Weathersense to display numbers reveals same information as text
  8. _Fra_
    _Fra_
    • member
    • 92 posts
    • 1 kudos
    @Chesko? Official updates? <3 <3 <3
  9. Dracula420
    Dracula420
    • member
    • 938 posts
    • 45 kudos
    I may have located the problem with the warmth and coverage not displaying correctly but I do not know how to fix the problem. the issue seems to be the script that strips and then re equips your gear when you start frostfall. it takes forever for it to actually fire and the warmth and coverage does not function until it does. once that happens and you get the "Done! frost fall is enabled" message everything works fine for me in the latest version. before the latest patch (which seems to be a minor reversion to a previous release) this same function was taking forever too. I hope this helps! o7
  10. OldBrunny
    OldBrunny
    • member
    • 6 posts
    • 0 kudos
    All, my Script Log is full of this error, lots of times per second. Anybody know the cause and how to fix it ??

    [12/31/2018 - 12:14:57AM] error: Unbound native function "IntListSet" called
    [12/31/2018 - 12:14:57AM] Warning: Assigning None to a non-object variable named "::temp105"
    stack:
    [_Frost_System_Clothing (4E064B04)]._frost_armorprotectiondatastorehandler.SetArmorDataByKey() - "_frost_armorprotectiondatastorehandler.psc" Line ?
    [_Frost_System_Clothing (4E064B04)]._frost_apdatastoredefaultdata.SetDefaults_Body() - "_frost_apdatastoredefaultdata.psc" Line ?
    [alias _Frost_PlayerAlias on quest _Frost_MainQuest (4E064AF8)]._frost_compatibility.PopulateDefaultArmorData() - "_frost_compatibility.psc" Line ?
    [alias _Frost_PlayerAlias on quest _Frost_MainQuest (4E064AF8)]._frost_compatibility.CheckDatastore_SKSE() - "_frost_compatibility.psc" Line ?
    [alias _Frost_PlayerAlias on quest _Frost_MainQuest (4E064AF8)]._frost_compatibility.CheckDatastore() - "_frost_compatibility.psc" Line ?
    [alias _Frost_PlayerAlias on quest _Frost_MainQuest (4E064AF8)]._frost_compatibility.RunCompatibility() - "_frost_compatibility.psc" Line ?

    <truncated stack>
  11. checkplese
    checkplese
    • premium
    • 14 posts
    • 0 kudos
    Causes an occasional inventory bug where if you press i your game crashes a reinstall of campfire and frostfall fixes it
  12. Doydyl60
    Doydyl60
    • member
    • 9 posts
    • 0 kudos
    hey guys maybe someone can help me out here. I've been using chesko's mods for awhile now with no issues, but last night something happened where I could not navigate the campfire/hunterborn menu (e.g. skinning, confirming campfire location) with my keyboard. I have to always use my mouse which is just a little irritating. I was adjusting some other mods last night that might of cause this but not sure how.

    I was adjusting Campfire, Frostfall, and PapyrusUtil last night to get frostfall to work properly. I am using SkyUI so it might be an issue with that I just don't know as I'm very new to modding. Anyone able to help fix this so i can easily navigate the menus?
    1. thumbincubation
      thumbincubation
      • member
      • 1,578 posts
      • 26 kudos
      Try re-installing PapyrusUtil so it overwrites the other .dlls, and installing it last after every update.
Top