Red Dead Redemption 2

What's new in Vortex 1.2?

  • Comment
Since we last checked in back in November, Tannin and Nagev have been hard at work fixing bugs and adding new features to Vortex based on your feedback. We've just released Vortex 1.2 into the wild for you all to enjoy, so here's a round-up of what's new. 


Updates for modders

Mount & Blade II: Bannerlord support

The wait is finally over! Bannerlord is here and it's great. We were lucky enough to get access to the Bannerlord beta (thanks TaleWorlds!) a short time before the Early Access release and created a basic Vortex extension for it. In v1.2 we've further refined it to include a fully featured load order tab where you can reorder, sort and toggle all your installed modules. Vortex will now also open the game in single player by default, instead of opening the launcher. 

More Info: Modding Bannerlord with Vortex



Halo: The Master Chief Collection Support

You can now install your mods for Halo: The Master Chief Collection through Vortex. All mods packaged relative to the root game folder will be automatically compatible, we have been reaching out to authors ahead of this release to ask them to ensure their mods are packed in a Vortex friendly way. Map mods will show an icon indicating which Halo title they're intended for and you can group your mods by this property. We've also added a shortcut to Assembly to the dashboard for those who use the map patches. Let us know what you think! 

More Info: Modding Halo: The Master Chief Collection with Vortex
 

Wolcen: Lord of Mayhem support

Another new addition to our lineup is support for Wolcen. With Vortex you can install and manage the priority of conflicting XMLs, Vortex will then merge them in order and deploy the combined file to your game. 




The Witcher 3 enhancements

After "The Witcher" landed on Netflix, we saw a dramatic increase in users modding Witcher 3. The community provided some excellent feedback on areas of Vortex that could be improved for a better user experience. As a result, we've added load order management for Witcher 3 as well as closer integration with the Witcher 3 Script Merger by AnotherSymbiote. This allows you to easily create the load order you want, take care of conflicts, and merge script changes from several mods.

More Info: Modding The Witcher 3 with Vortex



Stardew Valley enhancements

Based on the super helpful reports from the community, we've further improved Vortex support for Stardew Valley. Something that's been in the works for a while now. The most reported problem was how Vortex handled new files created by mods while the game was running. We've put a system in place that looks at new files in your mods folder and associates them with the correct mod so that they will be removed properly if the mod is disabled or uninstalled. This should prevent the harmless (but annoying) errors in the SMAPI log. 

You will also be able to install and update SMAPI directly inside Vortex like any other mod, which makes keeping this vital file updated or toggling between the current and beta versions easier than ever.

More Info: Modding Stardew Valley with Vortex



Monster Hunter World enhancements

In the recent Vortex releases, we made significant improvements to this extension already. Including detection and installation of Stracker's Loader and the ability to install and manage ReShade Presets. Version 1.2 features some additional refinements to preset detection and some handy shortcuts on the dashboard for HunterPie, MHW Transmog and SmartHunter Overlay.

More Info: Modding Monster Hunter: World with Vortex



Game extension updates are now delivered much faster

It's been the case up until now that important bug fixes for game support had to wait until the next full Vortex release, we felt that this wasn't a great experience for users. In version 1.2 and above if a game extension is updated to include an important fix you'll get the update next time you restart Vortex. 




Resizable Dashlets

You can now right-click any dashlet to adjust the width and height to suit your personal tastes.The close button has also been moved into this menu to prevent it being clicked by accident. 




Vortex now supports over 100 games!

On top of the new games we officially support, the awesome developers in the community have created a bunch of new game extensions including:


You can see all the available extensions by clicking "Find more" at the bottom of the extensions tab in Vortex or in the "User Extensions" category here. To help you show your appreciation to the extension authors, a new dashlet has been added to showcase new uploads and remind users to endorse the ones they have already installed. Roll on 200 games! 



Updates for developers

Simplified game detection

We've made it easier for Vortex to find games from several of the popular game stores. The new GameStoreHelper class can easily detect games installed with Steam, GOG, Epic, UPlay, Origin or the Windows Store. The example below will check for both the Steam and Windows Store app IDs, then return the installation path for the game. 

This function can also be extended by the community to include more game sources. 
Documentation (Coming soon) | Example


Improved support for Vortex Mod Loader

In 1.1 we released the initial version of our Vortex Mod Loader (powered by Harmony). We've since made refinements to allow the mod patches to be applied to and removed from the game assemblies as part of Vortex's deploy and purge events. Users can now expect their game to be fully reverted to its vanilla state when purging their mods. Harmony extensions can also take advantage of a load ordering page (if required). We're also working on some enhancements to the Vortex In-Game Overlay (aka VIGO) to make it even more powerful for extension developers. 
Documentation | Example


Mod Load Order Page

Several Vortex extensions utilise a page which allows users to adjust the priority of mods based on a load ordering system independent of file conflicts. Instead of requiring developers to build this from scratch each time, we've included a handy function as part of the context object to register a simple Load Order page for your game and offers several customisation options. 

Documentation (Coming Soon) | Example


Other Changes

  • Registrations with the API will generate an error if they're not inside the context.once() function when loading the extension rather than silently failing.
  • Vortex has been updated to run on Electron v8 (from v4) and includes the bug fixes, security enhancements and performance improvements that come with it. 

136 comments

  1. assassindude2447
    assassindude2447
    • member
    • 1 posts
    • 0 kudos
    I have been reading the comments of the users and honestly i do got a feeling like users and all of these problems they have with vortex, they all just making them up and the people they are just having a bad habit of ''always sending a destructive feedback instead of juiceing the engineers whom built vortex'' . ive been working with vortex since it was released on nexus, and i didnt had a single problem with this software at all and there are 2 of my closest friends that im pretty sure they gonna say the same, and each time that i update the thing, ive noticing there are more games added to the list that vortex having a support for them and never minding the theme keeps changing for better;) , each new or retro games which is really praiseworthy .
    keep up the good work vortex and thank you all for this amazing software
  2. MrWolfe226
    MrWolfe226
    • premium
    • 83 posts
    • 1 kudos
    yeah Vortex was ok , I just started moding my games on PC this year and Vortex don't play nice, sorry going MO2 so I don't have to delete and re-install Fallout 4 for the 8th time because I tried to disable a mod causing conflict
  3. onymaru9
    onymaru9
    • supporter
    • 1,559 posts
    • 70 kudos
    Instead of adding games to this maybe work on the ui and features . This vortex compared to the NMM is tremendously horrible. There's no categories, no way to just drag plugins to a certain order, you need to do it individually and if you have 100 mods and your plugin that needs to be in lets say #15 you have to individually do 70 steps to get it there. And dont get me started with the 'deploy' and the 'parse' thing where you need to manually pick which one to load last..like if i am overwriting something , let it overwrite it. So complicated and annoying compared to nmm. R.I.P. NMM. No offense or anything i know y'all work hard on this and its appreciated but when you compare both its a super downgrade from what we had.
    1. Pickysaurus
      Pickysaurus
      • Community Manager
      • 11,846 posts
      • 255 kudos
      Instead of adding games to this maybe work on the ui and features . This vortex compared to the NMM is tremendously horrible.

      That's your opinion, not a fact.

      There's no categories,

      Not sure where you got that impression?
      It has mod categories:

      And you can even group by them like in NMM


      no way to just drag plugins to a certain order, you need to do it individually and if you have 100 mods and your plugin that needs to be in lets say #15 you have to individually do 70 steps to get it there. And dont get me started with the 'deploy' and the 'parse' thing where you need to manually pick which one to load last..like if i am overwriting something , let it overwrite it. So complicated and annoying compared to nmm. R.I.P. NMM


      This just overall sounds like you're not understanding Vortex. If you try and make it be NMM you'll have issues because it's a new, better mod manager. Objective fact. If you need help with Vortex we have a bunch of friendly users who frequent the support forums for anything you may get stuck on.

      It's clear you don't like Vortex and that's fine. Stick with NMM. Vortex is the #1 most used mod manager for a reason though, so maybe you'll take the time to learn how it works and give it a proper chance one day? Please don't knock it until you've given it a proper try. Thanks.
    2. miricha
      miricha
      • member
      • 8 posts
      • 0 kudos
      From what I remmember NMM was much more simplistic and far easy to learn. My only problem with Vortex is that after an update nothing is working for me like WTF. Skyrim SE for example. Everything is enabled both mods and plugins, everything in LOOT is normal, I rescaned the location of Skyrim (rescan always worked on NMM). BUT when I start my save the game, it says that Skyrim.esp, Update.esp, Downguard.esp, Dragonb..... and so on with all mod .esp files, are not enabled -_-. When I start my game without Vortex, everything loads normaly exept the mods from Vortex. So the problem wasn't with my game had to reinstall vortex and delete all files that are connected to the app and do a clean install. If I have to go through this proces after every update, I'm sorry, but no matter how much more advanced than NMM this is, NMM is better and simpler it doesn't have all the features that Vortex has, but still it does run mods so it's good enough for me. I don't see the big change eighter and I only probably use 10% of all Vortex functions. Buh Bye.
    3. Pickysaurus
      Pickysaurus
      • Community Manager
      • 11,846 posts
      • 255 kudos
      We're currently investigating that issue miricha. We need feedback from users who are having the problem through the app.

      Please send feedback including your log and state information from inside Vortex. Nobody here has been able to replicate that problem.

      Best guess is you have a badly configured version of SKSE
    4. miricha
      miricha
      • member
      • 8 posts
      • 0 kudos
      I don't have SKSE and I had everything fixed by clean installing of Vortex, so I kinda deleted everything, and because I'm a dummy I didn't save my logs (It never crossed my mind). Now everything is fine and works without uninstalling the game or reconfiguring it. Everything in LOOT seems normal no files needed cleaning. And I said that the issue was occuring only when I launched the game from Vortex. If I launched it from Steam, it was loading normaly, the only files missing were the mods loaded with Vortex. Not gonna update the app now because I got everything working and I don't want to deal with this trouble aggain if it occurs.

      I appreciate your hard work on the app, and I wish you best of luck in the following updates.
    5. Pickysaurus
      Pickysaurus
      • Community Manager
      • 11,846 posts
      • 255 kudos
      1.2.9 fixes the issues with the build you were using :)
    6. JoseSnake
      JoseSnake
      • member
      • 229 posts
      • 3 kudos
      You are talking to a wall, I personally just install all my mods through my own custom MOD Manager nowadays.
  4. DokGonz0
    DokGonz0
    • member
    • 1 posts
    • 0 kudos
    Reading through a lot of these comments I dont see the problem Im having. I only play Fallout New Vegas with Vortex and I got a notification to update Vortex, so I did and when it reopened I noticed FNV wasnt in the Dashboard like I never used FNV with Vortex. I re selected the game and now all of my mods are showing disabled or uninstalled. So all that time I spent watching Gopher's videos to install mods with Vortex was a waste of time. I even clicked on some of them to enable one and the "masters" are now missing wtf. I dont know if I ever want to use this program again. I thought Vortex was created to make things easier for people that are new to modding. I guess not, nothing but headaches.
    1. Pickysaurus
      Pickysaurus
      • Community Manager
      • 11,846 posts
      • 255 kudos
      Hi,

      Sorry to hear about this. Please create a thread in the support forum and we'll do our best to help you out!

      Thanks
  5. demonphidos46
    demonphidos46
    • premium
    • 3 posts
    • 0 kudos
    depuis la dernière mise à jour on ne peut plus réduire la fenetre de vortex. Avec la version 1.15 on pouvait le faire!!! Où est le bug????
    1. Pickysaurus
      Pickysaurus
      • Community Manager
      • 11,846 posts
      • 255 kudos
      I'm afraid I don't understand what you mean. You'd have to provide more information, please make a post in the support forum or send feedback through the app.
  6. ociN666
    ociN666
    • member
    • 2 posts
    • 0 kudos
    Though im new to this whole nexusmods thing, and i can not download manually, doesnt matter how - tried so many different ways, also from another computer, with VPN enabled and not - nothing works, my idea was "maybe vortex helps", but due to the fact that the poage is very overwhelming and complicated heres my question:

    How do i download vortex and where???

    //cheers
    1. Pickysaurus
      Pickysaurus
      • Community Manager
      • 11,846 posts
      • 255 kudos
      Hey,

      The Vortex info/download page can be accessed by the big banner at the bottom of each page, or by going here.
  7. Hitman136
    Hitman136
    • supporter
    • 4 posts
    • 0 kudos
    Updated to this latest version, double clicked and it wouldn't even open, kept crashing right from the start almost, tried it few times then lost the will to live. Uninstalled it and went back to previous version and voila, opened straight away. Seems it hasn't been tested enough so for now I'm sticking to the safe version "Vortex-1-1-1-15-1584350950". Thanks.
  8. JohnHerbert
    JohnHerbert
    • member
    • 14 posts
    • 0 kudos
    1.2.10 cannot force steam to be running when I start mount&blade2 but it opens the game launcher directly then there is a reminder says "unable to initialize steam api".
    I can start MB2 directly on old version
    1. Pickysaurus
      Pickysaurus
      • Community Manager
      • 11,846 posts
      • 255 kudos
      Vortex should warn you if Steam is not running when you manage the game. If Steam is not open (not really sure why you wouldn't have it open) Vortex cannot start games that require it properly.
  9. Dimon6921
    Dimon6921
    • member
    • 38 posts
    • 2 kudos
    After update in conflicts menu when I change order in one place it's not changing automatically in second.
    Example: I set Realistic water to load after SMIM and still must choose SMIM after\before Realistic water
    1. Dimon6921
      Dimon6921
      • member
      • 38 posts
      • 2 kudos
      That's not the only problem...
      Now my Modern Brawl Bug fix always disables automatically. When I open the game it's working only in half the time, but when works it can't find realisticwater.esp which is enabled in plugins section. I even tried to reinstall Realistic water problems is not whit the mods or a load order (I'm using LOOT)
    2. Pickysaurus
      Pickysaurus
      • Community Manager
      • 11,846 posts
      • 255 kudos
      So I can try to replicate this, can you specify which game you're modding? .i.e. Skyirm 2011 or SSE.
    3. glspecter
      glspecter
      • member
      • 9 posts
      • 0 kudos
      deleted
    4. Dimon6921
      Dimon6921
      • member
      • 38 posts
      • 2 kudos
      SSE, but after the last update everything is fine
    5. Pickysaurus
      Pickysaurus
      • Community Manager
      • 11,846 posts
      • 255 kudos
      Thanks for getting back to me. Glad to hear it all worked out!
  10. Mctoran
    Mctoran
    • premium
    • 15 posts
    • 0 kudos
    After installing this update, Vortex will not run or open AT ALL for me. Whenever I click on the icon, nothing happens. I don't even get the popup with the logo.
    This has been a problem for me for the past week, and I generally run Skyrim SE from Vortex so this is a major issue for me.
    1. glspecter
      glspecter
      • member
      • 9 posts
      • 0 kudos
      Same here. I went to the Vortex page and downloaded my previous version 1.1.1.15. After making a copy of my data folder, I installed it and ignored the warning with some trepidation. Vortex launched, and my game and all tools worked fine. I surmised that this would be okay since the new version never launched. In Vortex you can turn off automatic updates, which I suggest doing temporarily. However, Windows will attempt to update the program again when you close Vortex because a temporary install file exists. Don't let it or you will need to repeat the install of the old version (caught me the first go round). After you close Vortex you can go the the file location of the temporary update files in your user directory and delete them. After that Vortex will launch and close as expected.

      I'd submit error logs, but these are only allowed for the current version. I understand the reasoning, although it comes off as somewhat arrogant and a little shortsighted. I suggest that a better practice would be to support the previous version until a sufficient number of installations of the newest release, and/or perhaps after a time period. The new version is obviously not backwards compatible in all cases. I've used Vortex since the alpha version. I only explored it then, but used it for gaming all through beta to release. I like it very much, and run around 230 mods. Since very early beta, it has always updated just fine until this version. I've turned off updates for now and will try an update again on a future release.
    2. Pickysaurus
      Pickysaurus
      • Community Manager
      • 11,846 posts
      • 255 kudos
      If nothing at all happens it's possible the update failed, which is normally an anti-virus software preventing some new files from being installed.

      Try redownloading 1.2.9 and see if it launches once you've installed that. https://nexusmods.com/site/mods/1
    3. glspecter
      glspecter
      • member
      • 9 posts
      • 0 kudos
      The install of 1.2.9 completed normally. The vortex directory files all had the new file version. It just would not launch. The vortex graphic would appear slightly faded for a moment and disappear. Task Manager showed several Vortex processes running and using cpu and memory for a while and then drop to 0%. Control Panel => Programs and Features also showed 1.2.9 present. Rebooting did not help either.

      I installed the previous version without uninstalling first, I was hoping that way it would preserve settings and it did.

      I'm running Windows 10 Pro 1909, with updates through March. It could be a windows issue that will be corrected, or Vortex. It could also be a mod that isn't compatible with the newest release. I didn't mention before, but I did try the manual download of 1.2.9 with the same results. Event Viewer faults Vortex, but with error code 1000 which is pretty much unhelpful since that goes not deeper than the exe in question.

      Thanks for the response!
    4. Pickysaurus
      Pickysaurus
      • Community Manager
      • 11,846 posts
      • 255 kudos
      Can you go to Appdata/Roaming/Vortex and copy your Vortex.log file, then create a thread in the support forum with the info it contains?

      We will get a better idea of what's going wrong if you can provide this info.
    5. glspecter
      glspecter
      • member
      • 9 posts
      • 0 kudos
      I have created a thread "Version 1.2.9 failure to launch" I've attached the vortex log contents, and also diagnostic files from v1.1.15 and 1.2.9 in case they provide any help.

      Regards
    6. Pickysaurus
      Pickysaurus
      • Community Manager
      • 11,846 posts
      • 255 kudos
      Thanks for that, you've got a reply from Tannin, our lead Vortex dev https://forums.nexusmods.com/index.php?/topic/8644668-version-129-failure-to-launch/
    7. lordoftheonionrings
      lordoftheonionrings
      • member
      • 27 posts
      • 0 kudos
      Same here. new version will not launch at all. Reinstall older version is working. Cannot report bug as bug reports only allowed on current version. I cant even log in to report the bug...
      Guess I will stick with the older version for the foreseeable future.
    8. Pickysaurus
      Pickysaurus
      • Community Manager
      • 11,846 posts
      • 255 kudos
      Can you chime in on the thread right above your comment? If it's the same issue it'll be worth commenting there so we can try and find the cause.