Palworld
0 of 0

File information

Last updated

Original upload

Created by

yakuzadeso

Uploaded by

yakuzadeso

Virus scan

Safe to use

Tags for this mod

637 comments

  1. yakuzadeso
    yakuzadeso
    • premium
    • 264 kudos
    Locked
    Sticky
    Make sure you've installed the latest version of REUE4SS, version 3 dropped not too long ago with bug fixes and performance improvements!
    Release v3.0.0 · UE4SS-RE/RE-UE4SS (github.com) 

    FAQs/Troubleshooting

    Performance issues after installing REUE4SS

    Uninstall and reinstall REUE4SS. You only need to delete UE4SS.dll and dwmapi.dll and then redownload them and drop them back to your game's folder.
    Make sure you've installed the latest version of REUE4SS, version 3 dropped not too long ago with bug fixes and performance improvements!
    Release v3.0.0 · UE4SS-RE/RE-UE4SS (github.com) 
    Open UE4SS-settings.ini in \Pal\Binaries\Win64 with something like Notepad and set bUseUObjectArrayCache to false, GuiConsoleEnabled to 0 and GuiConsoleVisible to 0.

    My game is crashing after installing REUE4SS

    Open UE4SS-settings.ini in \Pal\Binaries\Win64 with something like Notepad and set bUseUObjectArrayCache to false, GuiConsoleEnabled to 0 and GuiConsoleVisible to 0.

    The mod isn't working on client/server

    Make sure you've installed everything correctly, according to the instructions in the description. Most mods need to be installed on both the server and the clients to work and if the mod includes settings you most probably need to use the same settings in both the client and the server.

    I've installed everything correctly but still nothing

    If REUE4SS is working then you should be getting a file UE4SS.log in \Pal\Binaries\Win64. You can open it with Notepad to see if you're getting something like "Mod '*Mod's Name*' has enabled.txt, starting mod." If there's no such line then the mod was not installed correctly. If there are errors you can share the contents of your log file on Pastebin.com and share the link in the bugs section. You can find log files on both the server and the client folders. You need to specify which is which when sharing them.

    Where do I get help or info on modding the game?

    You can join the Palworld modding discord server: invite 

    How to share bugs/log files/ask for help?

    You can share bugs and your logs in the bugs section of the mod. You need to clarify if you're running the mod on both your clients and server, if the bug is happening in multiplayer, singleplayer, server or coop. You need to share steps to replicate the issue, unless it is completely random. Please make sure to read through the comments/the discord server/other bug reports in case your issue is a duplicate and/or is already resolved. Please make proper bug reports and comments, I can't help you if all you share is "doesn't work".
  2. yakuzadeso
    yakuzadeso
    • premium
    • 264 kudos
    Locked
    Sticky
    I've enabled the forums posts for y'all to share suggestions and your findings. Will be easier to keep track off compared to the comments.
  3. Natsukashii1111
    Natsukashii1111
    • premium
    • 6 kudos
    Locked
    Sticky
    OK I got the basecamp settings to work!

    BaseCampAreaRange
    BaseCampPalFindWorkRange
    palboxAreaRange

    You have essentially to disassemble your current palbox and remake it
    This way it will update the settings you changed
    1. Natsukashii1111
      Natsukashii1111
      • premium
      • 6 kudos
      The blue range indicator doesn't update, the effective base range (placing functional base parts will)
  4. Drasizard
    Drasizard
    • member
    • 0 kudos
    Mod no longer works after today's patch but it is installed in the correct location on a steam install.
  5. SinoX1337
    SinoX1337
    • member
    • 0 kudos
    Hello, can anyone help me to fix this error, i tryed to join on my Dedicated Windows Server.

    stack traceback:
    [C]: in function 'RegisterHook'
    ...\Pal\Binaries\Win64\Mods\GameplayTweaks\scripts\main.lua:27: in function 'DoHooks'
    ...\Pal\Binaries\Win64\Mods\GameplayTweaks\scripts\main.lua:22: in function 'CheckTitleMenu'
  6. LauriEX
    LauriEX
    • member
    • 0 kudos
    Still works on 0.2.2.0 for me.
  7. daddyattitude
    daddyattitude
    • premium
    • 2 kudos
    Please Update as the new release has changed the way your mod affects the game. (Crash)
    Thank you.
    1. RAFFIFAR
      RAFFIFAR
      • supporter
      • 0 kudos
      Same sadly, and none of the carry weight mods seem to work now.
    2. gEbstergAming
      gEbstergAming
      • premium
      • 1 kudos
      I'm able to operate fine with the mod, and carry weight works.. somewhat.  Leveling up weight doesn't follow the logic in the config.
    3. dscythegeo
      dscythegeo
      • member
      • 1 kudos
      I installed this mod on 0.2.1.0 and it seems to work, I only wanted the movement speed and it works when I double the numbers in config.lua. Not sure about the other settings.

      Anyway for those that can't connect to their own dedicated server and always timed out, update your RE-UE4SS here

      https://github.com/UE4SS-RE/RE-UE4SS/issues/452#issuecomment-2039511085

      It solves the issue of not being able to connect to your own dedicated server and timing out.
    4. MigoroTempest
      MigoroTempest
      • member
      • 1 kudos
      Nothing is working for me rn.
    5. MayoiBluewind
      MayoiBluewind
      • member
      • 0 kudos
      I was able to get it to work, when I combined v0.2.1.0 and "UE4SS_v3.0.1-39-g3320fc1".
      Don't forget to set "bUseUObjectArrayCache = false" in "UE4SS-settings.ini".
      If you don't, the game will crash.
    6. LauriEX
      LauriEX
      • member
      • 0 kudos
      Can confirm it was changing the arraycache to false to make it work
      Also make sure you have gameplaytweaks folder in the mods folder and not just copy paste the content of gameplaytweaks into the mods folder
    7. daddyattitude
      daddyattitude
      • premium
      • 2 kudos
      Thank you
  8. aedgar2
    aedgar2
    • premium
    • 0 kudos
    Does this mod conflict with any other mods? 
    1. daddyattitude
      daddyattitude
      • premium
      • 2 kudos
      Not with the mods I use.
      100M Default Max Inventory Weight - Needs update
      Low Cost Pals Condensation - Needs update
      Gameplay tweaks (Movement speed - stamina - weight and more) - gameplay tweaks - Needs update
      UE4SS
      Unreal Pak Tool
      White Light Hip Lantern
      Remove Spoil Rate
      DekModConfigMenu
      Paldar Minimap
  9. xTelrunyax
    xTelrunyax
    • member
    • 0 kudos
    Can this be update for UE4SS v3.0.1 ? 
    My crash report shows a LOT of UE4SS in a row thinking that something is a monster.
    This is the only mod on my server that has IsPalMonster
    inside the .lua.
    1. yakuzadeso
      yakuzadeso
      • premium
      • 264 kudos
      It was working fine with 3.0.1 last time I checked. You can share your log file with pastebin. Check the pinned comments.
    2. xTelrunyax
      xTelrunyax
      • member
      • 0 kudos
      https://pastebin.com/dk9NC5y4 (log)
      https://pastebin.com/YKPSNSBB (crash log)

      Hope you notice something in here
    3. yakuzadeso
      yakuzadeso
      • premium
      • 264 kudos
      The log looks fine and there's no mention of the IsPalMonster function. No mention of it in the crash log either.
  10. malichai11
    malichai11
    • premium
    • 0 kudos
    Would LOVE if you could add a line to make the Pals breed faster.
  11. Elitexmonky68
    Elitexmonky68
    • member
    • 0 kudos
    the movement speed doesnt work on multiplayer 
  12. HanaRima
    HanaRima
    • member
    • 0 kudos
    Mod seems to work for the most part but the movement speed adjustments cause jitter. It seems like it increases the movement speed but on the screen your character is moving the same speed so it has to suddenly catch up with where the character is.
    1. yakuzadeso
      yakuzadeso
      • premium
      • 264 kudos
      I assume you are on a server and either didn't install on both the server and the client and/or didn't use the same settings for both?
  13. yuejiewudi1997
    yuejiewudi1997
    • member
    • 0 kudos
    Can this be used on 0.1.5.1?