File information

Last updated

Original upload

Created by

pilamin

Uploaded by

pilamin

Virus scan

Safe to use

151 comments

  1. pilamin
    pilamin
    • member
    • 70 posts
    • 57 kudos
    Locked
    Sticky
    Updated the texture patches. Road LODs should now match better for users of NMC and Ojo/Poco Bueno.
  2. VariableEagle
    VariableEagle
    • supporter
    • 238 posts
    • 12 kudos
    Hello pilamin, I'd like to report an issue with the waterjet LODs at Hoover Dam and how it was fixed. The resource nifs had their position values set in the NiNode rather than the TriShape blocks. When used by FNVLODGen, the generated block placed those waterjets according to their zeroed postions, rather than where they should be. Setting the TriShape positions placed them properly in the block.
     
    Thank you again for this wonderful mod.
    1. Wubbledee
      Wubbledee
      • member
      • 710 posts
      • 7 kudos
      Could you please explain how you fixed this? Would I need to use NIF Skope?
    2. zedas
      zedas
      • member
      • 101 posts
      • 5 kudos
      Seconded. A more detailed explanation of the Nifskope stuff would be handy if possible.
    3. VariableEagle
      VariableEagle
      • supporter
      • 238 posts
      • 12 kudos
      Yeah, you can do this in NifSkope. If you open up hdwaterjet01_lod.nif and hdwaterjet02_lod.nif, you'll notice that the 1 NiNode branch has translation values (-1363.692261, -4272.844727, -1589.579834). You need to copy those translation values into the two NiTriShape branches beneath it (the spray plane and the impact plane). If you look here the highlighted block is the one whose translation you'll need to copy, then you zero it after.

      Once you do that for both files, just regenerate LOD and check "Meshes\Landscape\LOD\WastelandNV\Blocks\WastelandNV.Level4.X16.Y0.nif" at wherever your output is.
  3. Killerband4256
    Killerband4256
    • supporter
    • 1,070 posts
    • 5 kudos
    In the troubleshooting section, when you say to disable some lod esp files when running the FNVLODGen and then enable them after, does that include FNVLODGen.esp and MuchNeedLOD.esp?
  4. Erafox
    Erafox
    • supporter
    • 238 posts
    • 11 kudos
    i read and read and read ... and stiil do not understand howto install xD
  5. rangerofnewvegas
    rangerofnewvegas
    • member
    • 14 posts
    • 0 kudos
    How much does this affect performance?
  6. MildlyFootwear
    MildlyFootwear
    • premium
    • 130 posts
    • 11 kudos
    After spending the better part of a day trying to figure out what was wrong with LOD generation, I narrowed it down to a conflict between this and Vurt's Flora Overhaul+"LOD Resources for VFO".
    When using both (well... all three, technically), about half the cells wind up with the "textures not on atlas" error. When using one or the other even with NMC+Ojo+Poco I got no errors.

    I have no clue if you have any interest in attempting to patch this. If I had any idea where to start I probably would, but at the least here's a heads-up for anyone else who is using both.
  7. BiccyThiccy
    BiccyThiccy
    • member
    • 22 posts
    • 0 kudos
    Combine this with https://www.nexusmods.com/newvegas/mods/46451?tab=files and get the NMC + NMC washed out downloads and god LOD actually looks good..


    You have done probably the greatest service to the texture modding community besides ENBdev makers.

    Good job sir/mam
  8. GamblingTaco
    GamblingTaco
    • member
    • 18 posts
    • 0 kudos
    I'm having a really weird texture issue with all lods, where the meshes are normal but the actual textures are completely wrong. I've looked into the archive of every lod mod I have and all the normal textures were where they need to be. I've regenerated lod several times, and taking out a mod then putting it back into the load order (while going into the game to check if lods are ok) but the issue stays. The second issue is that the problem is not from one single mod. I took out much needed LOD and other structures still had the same issue.
    Here are some pictures showing the issue. This is just off of hidden valley, with the ncr prison on the right for reference.
    https://imgur.com/a/I8ubrCg

    My Load order for Lods go:
    FNVLodgenResources
    Much Needed LOD
    LOD Additions
    LOD Additions-update
    Less Horrendous Vikki and Vance Casino
    Limestone LOD
    NMC LOD Patch

    I do use both NMC with Ojo Bueno on top, but I don't really mind small discrepancies. I will try and load with just the LODgen resources at first and see if I can slowly reintroduce mods. Any help is appreciated :)

    EDIT: Alright, so after disabling every other LOD mod and leaving just the original resources, I'm still having the issue
    Picture of same area as earlier post's final photo: https://imgur.com/a/dOhidtB
    Since this is something that still happens even without this specific mod, I'm also going to be posting this on the original LODGen mod on Nexus. Here's hoping it might have an easy fix.
    1. zilav
      zilav
      • premium
      • 3,606 posts
      • 389 kudos
      LOD generation creates meshes and a combined texture atlas of all used LOD textures. Your issue happens ONLY when meshes and atlas don't belong to the same generation process or overwritten by other mods. So you either are not installing generated LOD files correctly (if you redirected the lodgen's output into the custom folder) or you have other mods which contain generated LODs and overwrite generated lodgen's files like "NMC with Ojo Bueno on top". No mod should ever overwrite generated lodgen files, they must be always "on top".
    2. GamblingTaco
      GamblingTaco
      • member
      • 18 posts
      • 0 kudos
      Ahh okay, figured it was more like basic texture mods in that sense. I'll try and fix the order of it
  9. Jax765
    Jax765
    • premium
    • 732 posts
    • 6 kudos
    Testing up the road from Nipton, noticed that when I had this mod enabled before using FNVLODGen, it would result in a distant rock not appearing as it should, specifically the one on the right (the one on the left disappearing seems to be cause by the resources files from FNVLODGen.
    https://puu.sh/C9oEa/09b6e517e2.png
    https://puu.sh/C9oEb/9bd9901e8e.png
    1. pilamin
      pilamin
      • member
      • 70 posts
      • 57 kudos
      Are the rocks on the right fine after running it with FNVLODGen? Not all of the large rocks disappear, right? It seems random? If this is the case, then that could be caused by vertex limitations. My assumption is that the added LOD objects pushes the engine to load more LOD vertices than it expected, and so a few seemingly random LODs tend to vanish from rendering.
    2. Jax765
      Jax765
      • premium
      • 732 posts
      • 6 kudos
      The issue seemed to be fixed by setting the atlas in FNVLODGen to max (8192).
  10. DAVIDINTEL
    DAVIDINTEL
    • premium
    • 361 posts
    • 3 kudos
    Is your patch "Much Needed LOD - NMC Patch" needed if I use the mod NMC LOD Texture Patch? Or if I use both, which do I install first?

    Thanks for the great mod!

    1. pilamin
      pilamin
      • member
      • 70 posts
      • 57 kudos
      Yes, my patch is still absolutely needed. Both patches do their own thing, though there is minor overlap. At this point having them in any order shouldn't cause much discrepancy, but it wouldn't hurt to give priority to the NMC LOD Texture Patch standalone mod.
    2. DAVIDINTEL
      DAVIDINTEL
      • premium
      • 361 posts
      • 3 kudos
      Thanks for taking the time to reply, have a great day!
  11. zilav
    zilav
    • premium
    • 3,606 posts
    • 389 kudos
    Thanks for updates!
    By the way the latest FNVLODGen on Nexus generates LOD for the following record types: STAT, SCOL, ACTI and MSTT. So you can create LODs for moveable statics.
    1. pilamin
      pilamin
      • member
      • 70 posts
      • 57 kudos
      Thanks for the tip. Does this mean that exploding vehicles can be generated for LOD?
    2. zilav
      zilav
      • premium
      • 3,606 posts
      • 389 kudos
      Yes, but if moveable static is actually moved in the game or change state to be visually very different, better not create LODs for it obviously.
      Support for MSTT was added because of those big farm tents near the Strip (don't remember how the place is called, some NCR farm with a quest for water) because Obsidian made them as moveable statics for some reason even though they never move or change state.
Top