Mount & Blade II: Bannerlord
0 of 0

File information

Last updated

Original upload

Created by

LiZhenhuan1019

Uploaded by

LiZhenhuan1019

Virus scan

Safe to use

316 comments

  1. lfsmwilliamson
    lfsmwilliamson
    • supporter
    • 22 posts
    • 0 kudos
    literally the only reason i play this game is b/c this mod
  2. tyrantrex
    tyrantrex
    • member
    • 134 posts
    • 0 kudos
    What an ambitious work... Thanks for the effort.
  3. dragon011
    dragon011
    • member
    • 93 posts
    • 0 kudos
    Question How can i Switch to Free Camera, that my Charakter not auto Moving?
  4. Agrr1
    Agrr1
    • member
    • 2 posts
    • 0 kudos
    Hi! Is the RTS camera (v. e3.5.3.231875) mod compatible with M&B II v. 1.4.2? I'm constantly getting ctd at launch then trying to add this mod.
    No other mods are active except of Native.

    Update: tried other versions of Bannerlord from 1.4.0 to 1.4.2.

    Update2: Vortex installation fixed my issue. Seems working for now, thanks :)
  5. kickinradical
    kickinradical
    • supporter
    • 5 posts
    • 0 kudos
    Hey there. Love your mod, it might be my very favorite I have found so far actually.

    However, unfortunately I am getting a crash when trying to start a new campaign though, and after a evening spent troubleshooting I narrowed it down to this mod. Kinda odd, but it happens every time and if I disable it I can get to the faction selection no problem.

    Maybe a conflict? I did try disabling a few others to see if that made a difference and no dice so far.

    I'll include my load order in case that helps. Just let me know if you need any other info.

    Thanks a ton for all your work! :)

    Native
    SandBoxCore
    CustomBattle
    Sandbox
    StoryMode
    RTSCamera
    Bannerlord.MBOptionScreen
    Bannerlord.MBOptionScreen.MBO
    Bannerlord.MBOptionScreen.ModLib
    ModLib
    CustomSpawns
    RighteousExecutions
    AutoBlocker
    BetterQuicksave
    BreakIn
    DeveloperConsole
    DontStopMeNow
    EditLord
    FixPersuasion
    FreePlay
    zCulturedStart
    ImprovedGarrisons
    NobleTroops
    PartyScreenEnhancements
    RealisticWeaponCollision
    KillBanditsRaiseRelations
    ArmyFormationsMadeEasy
    thinkerCommander
    VsMod_RoyalArmoury
    XorberaxCutThroughEveryone
    YellToInspireBoiZoi
    zzCustomWanderers
    z0UnlimitedWanderers
    LootLord
    SoundTheAlarm
    zzBannerlordTweaks
    1. LiZhenhuan1019
      LiZhenhuan1019
      • member
      • 133 posts
      • 11 kudos
      What's the version of the game? I will try to find the reason.
    2. kickinradical
      kickinradical
      • supporter
      • 5 posts
      • 0 kudos
      I am on 1.4.1 release.

      I got excited for a moment when you asked that because I thought maybe I had accidentally left it on beta in Steam, that would have been an easy fix, but no luck.

      :(

      Thanks a ton just let me know if I can do anything to help.
    3. kickinradical
      kickinradical
      • supporter
      • 5 posts
      • 0 kudos
      Okay, false alarm. I think I managed to fix it by reordering some things.

      Thanks again for the awesome work on this mod, looking forward to more in the future! :)
  6. herman925
    herman925
    • premium
    • 48 posts
    • 0 kudos
    It seems I have to 'apply' the player formation every time i enter a battle. If not, the player will be stuck at the infantry party. I have to switch back and forth to see the effect. Can it be applied on automatically instead?
    1. LiZhenhuan1019
      LiZhenhuan1019
      • member
      • 133 posts
      • 11 kudos
      I will add an option for it.
    2. herman925
      herman925
      • premium
      • 48 posts
      • 0 kudos
      Thanks!!
  7. TheGamerMan12
    TheGamerMan12
    • supporter
    • 35 posts
    • 0 kudos
    Game crashes on the newest stable version (1.4.1) with the newest mod version.

    When in a custom game, hovering over an enemy formation to highlight it causes the game to crash. I have yet to test any battles while in the campaign.
    1. LiZhenhuan1019
      LiZhenhuan1019
      • member
      • 133 posts
      • 11 kudos
      Could you please provide the list of mods enabled?
    2. TheGamerMan12
      TheGamerMan12
      • supporter
      • 35 posts
      • 0 kudos
      AdonnaysTroopChanger
      Aragas.AltSaveMissingModuleFix
      BannerPaste
      BOR (My own custom troop mod)
      Breakabl eshields
      BearMyBanner MCM
      BetterExceptionWindow
      CombatModCollection
      Custom Battle with Selectable Troops
      Helmet Hair Cover
      CommunityPatch
      CustomSpawns
      DeveloperConsole
      Dismemberment
      DontStopMeNow
      EditLord
      EnhancedMission
      EnhancedMissionChangeAI
      FreePlay
      ImprovedSmithing
      KaosesPartySizes
      ModLib
      NobleTroops
      ResponsiveSoldiersBoiZoi
      XorberaxCutThroughEveryone
      CulturedStart
      UnitFixes
      BannerlordTweaks
      FactionColorEnabler
      ArmorDoesSomething
      BuyPatrols

      I've heard that the CustomBattles mod might have some issues with yours. Do you think its a compatibility issue?
    3. LiZhenhuan1019
      LiZhenhuan1019
      • member
      • 133 posts
      • 11 kudos
      Investigating. Currently there's no evidence shows that they have compatibility issue.
      I tested and it seems that this problem is only related to this mod. I'm sorry for that and will fix it as soon as I can.
    4. TheGamerMan12
      TheGamerMan12
      • supporter
      • 35 posts
      • 0 kudos
      Glad you found out the issue, thanks for the fix!
  8. lexx7900
    lexx7900
    • member
    • 48 posts
    • 0 kudos
    what version to download for patch 1.4.0?
    1. LiZhenhuan1019
      LiZhenhuan1019
      • member
      • 133 posts
      • 11 kudos
      The latest version should be compatible with 1.4.0
  9. LiZhenhuan1019
    LiZhenhuan1019
    • member
    • 133 posts
    • 11 kudos
    If game crashes or loses response when you select a troop, please disable "Show Contour" option in game menu, opened by pressing O.
    Sorry for this problem. I will try to solve it as soon as possible.

    Edit: Just now I uploaded a new version that disabled this feature. It will not be enabled until I find a way to solve this problem. Sorry for this again!
  10. alekian1313
    alekian1313
    • member
    • 71 posts
    • 0 kudos
    With you're last update all working fine when i test with custom battle, but in an actual siege in game i press O..nothing, tried F10...nothing?

    Its working fine with you're previous version
    1. LiZhenhuan1019
      LiZhenhuan1019
      • member
      • 133 posts
      • 11 kudos
      It works fine as I test in e1.4.0. What are the other mods enabled?
      By the way does it has contour effect when you select troops?
    2. alekian1313
      alekian1313
      • member
      • 71 posts
      • 0 kudos
      It would take hours to list all my active mods ;), but as i said before it's working fine with you're e3.3.0 version, I'm on 1.4.0 stable. It's ok i guess i'll just revert to the older version. I just can't stand the slow walk during beginning of sieges. Thats why i jumped to you're latest version because switching teams doesn't really interests me.

      cheers
    3. LiZhenhuan1019
      LiZhenhuan1019
      • member
      • 133 posts
      • 11 kudos
      I will try to resolve this problem. You can delete the game key config file at "(user directory)\Documents\Mount and Blade II Bannerlord\Configs\RTSCamera\GameKeyConfig.xml". I would appreciate it if you can tell me the content in it.
    4. LiZhenhuan1019
      LiZhenhuan1019
      • member
      • 133 posts
      • 11 kudos
      By the way, you can list mods in Modules folder by opening cmd or powershell( in Modules folder click File->Open Cmd/Windows PowerShell). In cmd you can type dir /B. In powershell you can type dir -N.
      Then left drag to select the output, and right click to copy selected items.
    5. alekian1313
      alekian1313
      • member
      • 71 posts
      • 0 kudos
      <?xml version="1.0" encoding="utf-8"?>
      <GameKeyConfig xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      <OpenMenuGameKey>
      <Id>0</Id>
      <StringId />
      <GroupId>RTSCameraHotKey</GroupId>
      <Key>O</Key>
      </OpenMenuGameKey>
      <PauseGameKey>
      <Id>1</Id>
      <StringId />
      <GroupId>RTSCameraHotKey</GroupId>
      <Key>OpenBraces</Key>
      </PauseGameKey>
      <SlowMotionGameKey>
      <Id>2</Id>
      <StringId />
      <GroupId>RTSCameraHotKey</GroupId>
      <Key>Apostrophe</Key>
      </SlowMotionGameKey>
      <FreeCameraGameKey>
      <Id>3</Id>
      <StringId />
      <GroupId>RTSCameraHotKey</GroupId>
      <Key>F10</Key>
      </FreeCameraGameKey>
      <DisableDeathGameKey>
      <Id>4</Id>
      <StringId />
      <GroupId>RTSCameraHotKey</GroupId>
      <Key>End</Key>
      </DisableDeathGameKey>
      <ControlTroopGameKey>
      <Id>5</Id>
      <StringId />
      <GroupId>RTSCameraHotKey</GroupId>
      <Key>F</Key>
      </ControlTroopGameKey>
      <ToggleHUDGameKey>
      <Id>6</Id>
      <StringId />
      <GroupId>RTSCameraHotKey</GroupId>
      <Key>CloseBraces</Key>
      </ToggleHUDGameKey>
      <ConfigVersion>1.3</ConfigVersion>
      </GameKeyConfig>

      Is this what you need to know?
    6. LiZhenhuan1019
      LiZhenhuan1019
      • member
      • 133 posts
      • 11 kudos
      Thanks. They are all normal. The problem may be caused by a mod conflict.
    7. LiZhenhuan1019
      LiZhenhuan1019
      • member
      • 133 posts
      • 11 kudos
      I need confirmation of this problem from more players. Does anyone encounter the same problem?