Monster Hunter: World

File information

Last updated

Original upload

Created by

AsteriskAmpersand

Uploaded by

AsteriskAmpersand

Virus scan

Safe to use

Tags for this mod

93 comments

  1. osopana
    osopana
    • member
    • 1 posts
    • 0 kudos
    if somebody want this addon working on blender 2.8x , follow this video https://www.youtube.com/watch?v=K4_zJIkwE3Q&t=19s , is only a rename of the file but resolve the 2.8 error, i'm not even taste it right ,but in first view resolve the error, is late, i will try to test it and update on the week, sorry my bad english im from chile we speak spanish here i dont have the habits
    1. AsteriskAmpersand
      AsteriskAmpersand
      • member
      • 437 posts
      • 219 kudos
      Please don't do this. The addon is designed for 2.79 as well as the entire ecosystem. 2.8 and 2.9 are not supported. Any bugs or issues with those blender versions will be ignored and are completely lacking in documentation and tutorials.
  2. Cabbliamte
    Cabbliamte
    • member
    • 52 posts
    • 1 kudos
    i have a problem with it... it says "requires upgrade to 2.8x ... do you have a fix for this ?
    1. AsteriskAmpersand
      AsteriskAmpersand
      • member
      • 437 posts
      • 219 kudos
      Use 2.79
  3. shadsterwolf
    shadsterwolf
    • supporter
    • 67 posts
    • 3 kudos
    Looking forward to the Blender 2.8 version for this!
    1. Aerogers
      Aerogers
      • member
      • 31 posts
      • 0 kudos
      same
    2. AsteriskAmpersand
      AsteriskAmpersand
      • member
      • 437 posts
      • 219 kudos
      Never going to happen. The API for 2.8+ is a monstrous mess that doesn't address my core issues with the existing 2.79 API (namely the mess that is working with custom normal loops). There is far too much tooling that would have to be ported for literally no benefit given it's possible to copy paste meshes from one instance of blender into another anyway.
    3. CharlieJuliet96
      CharlieJuliet96
      • premium
      • 68 posts
      • 14 kudos
      Well, yes, but I tried copying a body mesh into 2.83 from 2.79 editing it, and then copying it back to 2.79 and re-weighing the vertices using weight transfer, but it turned out all messed up in the game. Am I missing something here?

      EDIT: It seemed like even importing a mod3, and then re-exporting it as-is without changes is giving me issues. There's some data loss after exporting, and I can't figure out why.
    4. AsteriskAmpersand
      AsteriskAmpersand
      • member
      • 437 posts
      • 219 kudos
      There's workflows for this covered in the MHW Modding Wiki. It's related to Split and Split Slash Weights being required for some meshes.
    5. ranaragua
      ranaragua
      • member
      • 216 posts
      • 402 kudos
      I think this is a basic question but as a newbie I can't find any solution to this on Mod wiki.
      I imported an unpacked wst mod3 file(pl022_0000), with all option checked, weight format: split weight notation, import skeleton: animation armature, I changed the size of a mesh a little bit, then export to mod3 file with all option checked.
      but the console says "Error: No candidate empty roots for the skeleton." and fail to export.

      did I miss anything during import or export.

      also, I tried weight format: split slash notation, the result is same.
    6. ranaragua
      ranaragua
      • member
      • 216 posts
      • 402 kudos
      sorry for the trouble, I tried import skeleton: Empty tree, and everthing works fine now. 
      I changed it during some try and error then forget to change it back. I recomend you add this to Plugin-Importer-Settings page on Mod wiki.

      Thaks again for the Great work.
    7. Gollum587
      Gollum587
      • member
      • 3 posts
      • 0 kudos
      How about now? Are there any changes to the Blender API for 2.8?

      And if not, there was once a version of the Mod3 Importer - Exporter for Blender 2.8, but it was taken down... So is there any chance it somehow still works?
  4. Dipanjanc33
    Dipanjanc33
    • supporter
    • 1,382 posts
    • 17 kudos
    hey , do you know where i can find 3ds max tool for import and export support?
  5. AlatreonDrakknight
    AlatreonDrakknight
    • member
    • 1 posts
    • 0 kudos
    Can anyone help me out , total newbie to this and I don't even know the first steps to pulling a model from a game. I'm trying to pull Castle Schrade to view in blender because I actually want to build the thing in minecraft (I'm weird like that) and the model would be of really good reference since there is practically NO images or flyover videos or anything on the web.
  6. SeregirDraike
    SeregirDraike
    • member
    • 30 posts
    • 0 kudos
    Theoretically, could I use this to rip my favorite armor for use in VRChat or Beat Saber?
  7. kapustusz
    kapustusz
    • member
    • 23 posts
    • 0 kudos
    I would like to know how to set blocklabel? I get an error when exporting after transfering mesh data from a mesh from another skeleton.
  8. Xinerfapre
    Xinerfapre
    • member
    • 57 posts
    • 0 kudos
    I don't have button import-export for mod3 in 2.8x version. Why?
  9. sabateur12
    sabateur12
    • premium
    • 152 posts
    • 24 kudos
    question everytime i try to export a model i get the error Error: Declared blocklabel is incompatible with mesh. Lower blocktype errors to warning to allow overwriting explicit blocklabels, remove blocklabel from mesh properties or set blocklabel to IASkin8wt1UVColor. how can i fix it this when i put blocklabel to warning when i change it to error i get this Error: Missing UV at vertex implies orphan vertex or corrupted UV Map. i dont understand what is wrong with the UV
    1. lurio202
      lurio202
      • member
      • 1 posts
      • 0 kudos
      Me too when I add something to the model.
      As it gives me the error "Missing UV at vertex implies orphan vertex or corrupted UV Map" I reassigned the uvs to the modified piece of the monster but it keeps giving me that error.
  10. TrapnPoltergeist
    TrapnPoltergeist
    • premium
    • 1 posts
    • 0 kudos
    i haven't been able to correctly add this onto my blender 2.79b, i was hoping to find some tips on getting it to accept this addon.
    1. Maeglin64
      Maeglin64
      • member
      • 288 posts
      • 1 kudos
      I had this problem, selecting the addon and enabling it, my mistake was not hitting save settings in the lower left of the add-on window, I also enabled the other couple of files that included MHW in the names