Mass Effect Legendary Edition

File information

Last updated

Original upload

Created by

Kinkojiro

Uploaded by

KkJiro

Virus scan

Some files not scanned

749 comments

  1. KkJiro
    KkJiro
    • member
    • 930 posts
    • 217 kudos
    Locked
    Sticky
    Just like to say thanks for all the positive comments and encouragement. Very much appreciated.
  2. KkJiro
    KkJiro
    • member
    • 930 posts
    • 217 kudos
    Locked
    Sticky
    BETA - Issues

    If you are testing the Bonus Squadmates please report any bugs.  This is in beta so expect some.  Please report which squadmate and which mission you are having issues with.

    Known issues:


    Frequently asked Questions:

    Some of the EGM settings are greyed out:
    This is port of the very large ME3 mod. It will take some time. Features which cannot yet be used are greyed out.

    Bonuses for ME2 galaxy map upgrades:
    Bonuses are not yet developed (including engineer bonuses).

    Will you spoil the game for me and everyone else by telling me how to find/do xyz?
    No

    I think EGM has caused a bug?
    Before posting know that EGM mainly changes the Normandy. Anything on the Citadel or other than launching missions from the Normandy is extremely unlikely to be EGM.  This includes the Wrex in casino bug which someone on reddit blamed on EGM but wasn't.
  3. Axelite3
    Axelite3
    • member
    • 1 posts
    • 0 kudos
    Unsure if EGM is affecting these, but both N7: Cerberus Attack and N7: Communication Hub are both resulting in black screens with music playing in the background, while every other mission is proceeding as normal. Tried both Alt+Tab and switching between fullscreen and windowed mode to no avail. Unsure how to proceed with those, but I think I'd just have to skip them until it can be figured out.
    1. Epiquec
      Epiquec
      • member
      • 19 posts
      • 0 kudos
      That is a known bug, you can see in the bugs section. You can try disabling EGM and playing said mission until after you are past the cutscene and try enabling EGM again. I did that and it worked fine so far.
    2. FFantasykid69
      FFantasykid69
      • supporter
      • 334 posts
      • 6 kudos
      I FIGURED OUT THE ISSUE. ITS THE NEW VERSION OF THE LE3 COMMUNITY PATCH THAT CAUSES THIS GLITCH WHEN USED IN CONJUCTION WITH EGM I BELIEVE ITS 1.5.1. I JUST TESTED THIS WITH 1.4.5 AND IT WORKS
    3. Cherrries
      Cherrries
      • premium
      • 7 posts
      • 0 kudos
      When I disable EGM to do the missions it just puts me in an infinite loop when choosing characters. Update: Just disabled the Community Patch instead and it let me in, I'll just do that for the Communications Hub as well.
    4. PickMyLucy
      PickMyLucy
      • member
      • 15 posts
      • 0 kudos
      @FFantasykid69 I don't know how it worked for you, but I have done the same and it did not work for me. Uninstalled version 1.5.1, reinstalled version 1.4.5, but to no avail. Is there a particular order of steps that need to be followed to make it work with version 1.4.5, or...? Because I keep scratching my head with this one.
    5. KkJiro
      KkJiro
      • member
      • 930 posts
      • 217 kudos
      There is definitely an incompatibility with Framework 1.5.1 on Cerberus Attack.  I can't find an issue with the Comms mission.+
      Unfortunately I can't release a full patch until the next version of Mod Manager goes live (which is itself being delayed by a bug in the Microsoft .net 6 release).  In the meantime I have made a patch file:
      EGM_CerbAttackFix.zip
      Add to game:  Open your game ...\ME3\BIOGame\DLC\DLC_MOD_EGM\CookedPCConsole folder and drop the contents in.
      Run Mod Manager Tools -> AutoTOC -> AutoTOC Mass Effect 3 Legendary Edition.
    6. FFantasykid69
      FFantasykid69
      • supporter
      • 334 posts
      • 6 kudos
      WOW TY SO MUCH FOR THIS!!
    7. skynetassassin
      skynetassassin
      • member
      • 251 posts
      • 1 kudos
      Not sure what I'm doing wrong, after putting the patch file in ME3\BIOGame\DLC\DLC_MOD_EGM\CookedPCConsole and running AutoTOC Mass Effect 3 Legendary Edition, the mission still wouldn't load for me

      Edit: disabling the community patch and framework got me through most of the mission. After the game crash before I returned to the ship. Fortunately the mission loaded to where I last saved after enabling the community patch and framework, perhaps it's just the start of the mission that's incompatible
    8. luseiken
      luseiken
      • member
      • 6 posts
      • 0 kudos
      thx you
  4. SabuChan28
    SabuChan28
    • member
    • 114 posts
    • 1 kudos
    Hello!

    So, this is a weird one and hopefully, you'll be able to help me.
     
    From the beginning of this playthrough, I've been playing with EGM installed without issues up until I had to play Cerberus Attacks. Having encountered the infamous black screen, I came here to find a fix and I read that simply disabling EGM fixes the issue. So I did just that and yep, I was able to play Cerberus Attacks.
     
    I reenabled EGM but the game acted as if EGM was not installed. None of the options I chose, showed in-game: no ship manifest, the crew is not in casual outfits, no shooting range.... So, I restored the game from the backup and re-installed all my mods and textures.
     
    And that's when it's super weird: I loaded my save and the game *still* acted as if EGM is not installed! What could possibly be the issue?

    Here is my diag, if that helps and thanks in advance:
    https://me3tweaks.com/modmanager/logservice/logviewer?logid=b16ecd2f917210fd5fd2ccf9953ababb

    EDIT: Ok, after many tests, I found the problem: Unlimited Fuel ME3 (LE3) is not compatible with Expanded Galaxy Mod, alas.
    To be sure, I installed only EGM and Unlimited Fuel ME3. The game acts as if EGM is disabled. If I disable Unlimited Fuel ME3 (LE3), EGM and all its features are shown in game as intended.
    I don't know if it's really a bug or something so I thought I'd post my comment about this issue here. I'll post in the Unlimited Fuel ME3 (LE3) posts section too. I really hope there will be a patch to make both mods compatible.
  5. drag0ns4pets
    drag0ns4pets
    • member
    • 11 posts
    • 0 kudos
    Just wanted to say, looking forward to the next update, love the mod. Plus want to be able to play the Spectre Expansion one
  6. cptnchknfkr
    cptnchknfkr
    • premium
    • 5 posts
    • 0 kudos
    Can anyone help me figure out why the extra menu selections on the com panel next to the galaxy map disappeared after I installed another mod? I can't figure out which mod killed it and I'd kinda like to get it back. 

    Thanks All!

    BTW: LOVE THIS MOD!
  7. TestaMobile
    TestaMobile
    • member
    • 1 posts
    • 0 kudos
    hi, I'm an Italian player and I wanted to know if my language is integrated or will it be integrated. Thanks for everything.
  8. Revanskywalker77
    Revanskywalker77
    • member
    • 10 posts
    • 1 kudos
    No to rush or anything but all I need is the Miranda Mod for LE and I'm set to buy the Legendary Edition
  9. ShepN7B0rk
    ShepN7B0rk
    • member
    • 21 posts
    • 0 kudos
    I have one potentially dumb question. Has the function of having the helmets as separate options in the armor locker been implemented and I am missing it? Or has that simply not been brought forward to the LE version of this mod?
  10. 4access69
    4access69
    • member
    • 3 posts
    • 0 kudos
    Can someone please tell me is it the EGM or the Community patch enabling console key bindings?

    I am using Tab key to reload and I keep opening the console in the middle of a fight.

    EDIT: Never mind, figured it out.
  11. QueenofUtopia
    QueenofUtopia
    • member
    • 1 posts
    • 0 kudos
    Hi loved this mod since og me3, will there be all the star systems in the future? would love to explore it all again 
    Keep up the good work!
  12. JootDoctor
    JootDoctor
    • member
    • 2 posts
    • 0 kudos
    Hi this is the first time playing through  with the mod and I don't know how to get EDI in her Eva Core skin. Using the EGM settings to make it happen on the bridge is fine but the option for her to wear it in combat doesn't appear in the squad menu. I picked up the formula on Sanctum but that was before Mynae so I'm not sure if that has anything to do with it. I had the mod settings for her skin to automatic but forced the skin on to check if it was there on the Normandy bridge, which it is.

    Thank you
    1. KkJiro
      KkJiro
      • member
      • 930 posts
      • 217 kudos
      This is not yet published (will be soon).
    2. JootDoctor
      JootDoctor
      • member
      • 2 posts
      • 0 kudos
      Ok thank you. Wasn't sure if that was the issue or not because I can force the skin for the Normandy using the mod settings menu.