File information

Last updated

Original upload

Created by

valda

Uploaded by

valda

Virus scan

Some manually verified files

About this mod

An alternative port of the "Wrye Bash" for Fallout 3.

Requirements
Permissions and credits
Mirrors
Wrye Flash is a powerful mod management utility adapted to Fallout 3 by Valda from the TES IV: Oblivion and TES V: Skyrim versions.

Its features include:

  • A mod installation and conflict manager
  • A plugin load order manager
  • Increased mod compatibility
  • Lifting of the 255 plugin limit through automatic merging of compatible mods
  • .ini and settings files tweak management
  • Screenshot management
  • Many, many more features

Wrye Bash can appear daunting at first. To help make it more manageable, the documentation has been split into a few readmes that are targeted towards different usage requirements.

The General Readme covers only the most commonly used features, so that the average user can start using Wrye Bash without being overwhelmed. Information on the less commonly used features and more technical details of the features covered in this readme may be found in the Advanced Readme. Information on some of the syntaxes and file formats that Wrye Bash uses are found in the Technical Readme.

Wrye Flash for Fallout 3 is currently as Valda left it. On occasion, when reported, minor changes are made to the record definitions. Other then that this version is not maintained. Compatibility for Fallout 3 will be added to the Oblivion and Skyrim version in the future.

Documentation:

This documentation is for the Oblivion version but some still applies since this version of Wrye Flash is based off of Wrye Bash for Oblivion. Some of this will not apply until this version is integrated into the Oblivion and Skyrim version. So please do not post asking why the documentation mentions a feature that is not available in Wrye Flash.

Old Wrye Bash Documentation: This only covers Wyre Bash up until version 271.
General Readme
Advanced Readme
Technical Readme

Instalation:

Installation from Nexus

1. Click download manually from the files tab
2. Unzip the Wrye Flash NV 7zip archive
3. You will see 2 folders, Data and Mopy
4. Copy Data and Mopy to your FalloutNV folder where the FalloutNV.exe is located.  Overwrite the files if needed.

Additional Installation Notes
 
First, if you're using Windows XP, Wrye Flash needs the MSVC++ 2005 SP1 Redistributable with ATL Security Update installed, the x86 version. This is required for the custom 7z executable that Wrye Bash uses to run. Later versions of Windows already have this installed.
 
This is a Python version, so install the dependencies manually until there is in automatic installer.

Note that the 32-bit versions are required even if you are on a 64-bit operating system
 
Python 2.7.8
wxPython 2.8.12.1 unicode for Python 2.7
comtypes 0.6.2
PyWin32 for Python 2.7

Other setups may work, but this is the only officially supported setup.
Python 3.x: NOT supported
 
5. Go to the Fallout New Vegas folder, then the Mopy folder and, run Wrye Bash Launcher.pyw (this is the exe file for Python)

Additional Information:

Bethesda Forum
Github repository
Wrye Flash NV (Fallout: New Vegas version)

Version history:

Change Log

=== 31.9 [07/04/2018]
* Added Create New Project
* Added Monitor External Install

=== 31.8 [07/02/2018]
* Updated CTDA for FOSE and Base Game [Sharlikran][Hlp]

=== 31.7 [11/5/2017]
* Bug fix for Import Relations [Valda]
* Add form version to Bash Patch [Sharlikran]

=== 31.6 [5/17/2016]
* Bug fix for BOSS Detection [Valda]
* Bug fix for Deselect All in Update Bash Patch window [Valda]

=== 31.5 [1/14/2016]
* Bug fix for MreTerm - resolved DNAM issue in deleted Terminal record in mod Better Game Performance

=== 31.4 [6/13/2015]
* Bug fix for False Flagged ESP Files [Valda]

Wrye Flash will now sort .esp files flagged as ESM files together with other .esm files.

=== 31.3 [6/10/2015]
* Bug fix for class MreCsty for CSSD error

=== 31.2 [3/1/2015]
* Bug fix for class NamesTweak_AmmoWeight

=== 31.1 [2/20/2015]
* Updated DNAM in MreArma, MreArmo
* Added MICO to MreLigh

=== 31.0 [1/28/2015]
* Removed def setRace since it is not used in Fallout
* Removed unused records
* Normalized records with 306 and FNV when applicable
* Minor fixes to MreArma, MreArmo, MreWeap and Graphics patcher
* Normalized Routines and patchers between FO3 and FNV when applicable

=== 30.9 [1/19/2015]
* Fixed typo in MreClas for ATTR

=== 30.8 [1/12/2015]
* Additional bug fixes for Weapons Patcher

=== 30.7 [1/12/2015]
* Fixed bug in Weapons Patcher
* Fixed bug in Sounds Patcher

=== 30.6 [1/11/2015]
* Updated MreAchr, MreAcre, MreAlch, MreArma, MreArmo, MreArmo, MreBook, MreBptd, MreClas, MreCrea, MreDebr, MreDial, MreEfsh, MreFact, MreFlst, MreIdle, MreIdlm, MreImad, MreInfo, MreIngr, MreIpct, MreIpds, MreLigh, MreMgef, MreNavi, MreNpc, MreRefr, MreRegn, MreScpt, MreSoun, MreTerm, MreTxst, MreWeap, MreWthr
* Added MreCams, MreCobj, MreCpth, MreImgs, MreLgtm, MreMesg, MrePgre, MrePmis, MreRads, MreRgdl, MreScol, 

=== 30.5 [10/4/2014]
* Updated CellImporter
* Added ALCH to SoundPatcher

=== 30.4 [08/24/2014]
* Updated Record definitions
* Fixed typo for attribute in MreCrea patcher

=== 30.3 [08/08/2012]
* Updated BAPI DLLs. Support for BOSS 2.1.

=== 30.2 [04/04/2012]
* Fixed a bug that could not start Mod Checker.
* Fixed a bug that fails in starting of BOSS in non-unicode mode.

=== 30.1 [04/02/2012]
* Added a NAVM (Navi-mesh) record support.
* Fixed a REFR record structure.
* Support for BOSS 2.0 (from WryeBash 296svn).

=== 29.1 [09/04/2011] Cronc

* Rebase to Wrye Bash 294.2 + bugfixes from 295(svn).
* Program-wide Changes:
* Wrye Bash has a new directory layout! Now the Mopy directory just contains important files that you can run. All other files have been moved into subdirectories.
* Please delete the old Mopy directory before copying the new one in to get rid of the old files
* Your configuration will get converted to a new format on first load which will not be readable by older versions of Wrye Bash, so be sure to back up your settings when you upgrade so they will be available if you ever need to downgrade again
* Python 2.5x and under compatibility: warn that those are unsupported versions but if the user really wants to use em anyways make some changes so that it is less likely to fail as much.
* Updated Japanese Translation (contributed by Cronc).

Credits:

Wrye Team for Wrye Bash
ElminsterAU for FO3Edit
Random007, WrinklyNinja and the BOSS team for Better Oblivion Sorting Software - BOSS v2.3
xatmos for FaceGen Exchange
TheLORDofDOOM for Wrye4Fallout3
Top