Enclave

Site Maintenance - User login sessions

  • Comment
It's almost Christmas! We hope you've all managed to keep off the naughty list during 2020. 


There's a good chance if you're reading this you might be wondering why you were logged out of the website recently. Don't worry, there's nothing wrong with your account. This happened because we had to clear everyone's active login session as part of a routine - but essential - database maintenance task. 


If you haven't been logged out yet please make sure your account email address is up to date as you may still be logged out in the next hour. 


We understand that this will be a minor inconvenience to some of our users, however, this change is necessary to prepare the website for what is shaping up to be another busy festive period and to enable us to continue to improve our services moving forwards.


If you're having trouble logging back into your account, please see the self-help articles below for assistance:



Of course, if you're still not able to get into your account again, you can contact our Community Team by emailing [email protected]. (Please make sure you send your email from the address used with your account, where possible.) 


So you know, over the holiday period it may take longer than normal to respond to support requests, we apologise in advance for any delays. 


Thank you for your patience and for being a part of the Nexus Mods community in 2020! We look forward to catching up with you all in 2021. 

86 comments

Comments locked

A moderator has closed this comment topic for the time being
  1. Pickysaurus
    Pickysaurus
    • Community Manager
    • 14,614 posts
    • 337 kudos
    I'm going to lock this comment thread now, however if anyone is still having problems, please see this thread on the forums: https://forums.nexusmods.com/index.php?/topic/9407708-issues-with-staying-logged-in-anyone-else/
  2. R0NlN
    R0NlN
    • supporter
    • 1,609 posts
    • 36 kudos
    Since the update, I'm randomly logged out when I open a new tab or refresh a tab, while on your site. For example,  if I click a link to a tracked mod, NEXUS will show me as logged out when I get to that page. This happened twice today within about 5 minutes.

    (I was logged out on the 15th of course when I visited the site, and so I logged back in. This behavior has been occurring after that. Edit: I just logged myself out and logged back in; that may have fixed it.)
    1. Pickysaurus
      Pickysaurus
      • Community Manager
      • 14,614 posts
      • 337 kudos
      If you can't stay logged in, something on your PC is preventing the site from saving your login details (usually "tin foil hat" browser addons) see: Troubleshooting Website Issues
    2. R0NlN
      R0NlN
      • supporter
      • 1,609 posts
      • 36 kudos
      To be clearer, when I first open the NEXUS site, I _am_ logged in. I go to my Notifications page-- still logged in. I click on a link to go to a mod's page (or to come here to see your reply) and that new page says I'm logged out. When I click the "Log In" button, I get a message saying:

      YOU'RE ALREADY LOGGED IN
      Would you like to continue as RONIN?

      If I select "Continue", then it works as normal. Until it doesn't- which is at least upon my next visit to the site.
      This has ONLY been happening since the Site Maintenance that this page is announcing. I'm using Chrome, I don't have Add Block enabled on NEXUS.

      Also, this _doesn't_ happen when I click on a link on my NEXUS home page-- whether that's to check out a new mod, or a Media screenshot, or to go to my Notifications page. So far, it has ONLY happened when clicking on links on my Notifications page.

      It seems others are having issues, too. Perhaps you should consider this is being caused by NEXUS' code, rather than sending people to a generic page about troubleshooting.
    3. Pickysaurus
      Pickysaurus
      • Community Manager
      • 14,614 posts
      • 337 kudos
      As you may be able to tell from Dark0ne's recent comments, we are investigating this. However in many cases when users have had issues it's caused by over zealous "privacy" browser add-ons or settings, so I always recommend the troubleshooting guide to rule that out.

      It seems this might be on our end after all but oddly it's only happening for a small number of users. The developers will be looking at it as a priority during the week. 
    4. R0NlN
      R0NlN
      • supporter
      • 1,609 posts
      • 36 kudos
      Thanks, Pickysaurus. I'm glad they're looking into it. (The same thing happened again today.)
    5. BigBizkit
      BigBizkit
      • Community Manager
      • 5,914 posts
      • 323 kudos
      We've deployed a potential fix for this issue. Please let us know if the issue still occurs for you or not. Thank you! 
    6. R0NlN
      R0NlN
      • supporter
      • 1,609 posts
      • 36 kudos
      Thanks, BigBizkit. Today it worked just fine, as I opened about a dozen tabs from my Notifications page without running into the issue. 
    7. BigBizkit
      BigBizkit
      • Community Manager
      • 5,914 posts
      • 323 kudos
      That's good to hear. I hope we got the issue sorted then
    8. Mitsuriou
      Mitsuriou
      • supporter
      • 402 posts
      • 27 kudos
      Hello,
      I'm not getting disconnected anymore, but now I'm obtaining "500 Error" for my pinned tabs that automatically re-open when launching my browser.
      This is a very small problem since I only need to press F5, and since I don't lose the page URL anymore, it just refreshes the page and I'm good to go.
      so, I'd say it's 95% fixed.
    9. Pickysaurus
      Pickysaurus
      • Community Manager
      • 14,614 posts
      • 337 kudos
      Which pages do you have pinned? It sounds like it might be trying to use some expired session data that is stored in the browser cache. 
    10. Mitsuriou
      Mitsuriou
      • supporter
      • 402 posts
      • 27 kudos
      I have
      https://www.nexusmods.com/skyrimspecialedition/mods/34179
      and
      https://www.nexusmods.com/skyrimspecialedition/mods/20061?tab=files

      This is always the second one, "SSE CreationKit Fixes" that leads to a "500 error". It's always the one pinned to the right of the other one, too.

      EDIT: I just removed all my cache, cookies, … I'll come back tomorrow if I have anything new.

      EDIT 2: Okay, the problem is still here. And it has nothing do to with the order of the pinned tabs, visibly. This time, it's the first one that lead to a 500 error, so I guess that's the first that loads that ends up having a 500 error response.
  3. MONSTERaider
    MONSTERaider
    • premium
    • 1,434 posts
    • 536 kudos
    After this maintenance every time I open the site I have to log in, and it always say that I'm already logged in, is this temporary?
    Thanks and Merry Christmas to you all
    1. Pickysaurus
      Pickysaurus
      • Community Manager
      • 14,614 posts
      • 337 kudos
      That is the message you will see, yes. If you are seeing it every time, that's probably caused by browser add-ons preventing the site from setting cookies. (See I'm getting errors on the login page.)

      You can also try logging all the way out of your account and logging back in. 
    2. MONSTERaider
      MONSTERaider
      • premium
      • 1,434 posts
      • 536 kudos
      Trying the log all the way out was the first thing I tried before posting, but it didn't fix it, I've been using Nexus for so many years and this never happened before.
      I'll try to disable Google Chrome extensions and delete all cookies and test it again.
      Thanks.
    3. Pickysaurus
      Pickysaurus
      • Community Manager
      • 14,614 posts
      • 337 kudos
      Let me know how it goes :) 
    4. MONSTERaider
      MONSTERaider
      • premium
      • 1,434 posts
      • 536 kudos
      After I removed all cookies and disabled all extensions, the issue still persists, I also ran into another issue I tried to log in but the Two-factor authentication didn't work, I had to recover my account using my recovery code (Thank God that I still have it saved on my PC) anyway after I logged in I tried to re-enable the 2fa again but I couldn't, it always say that I'm entering the wrong code, this issue never happened before, and I'm also noticing that I'm not the only one with log-in issues after the maintenance. I don't think it's the browser, I think something is faulty with the site.
      Thanks again for the help, and I hope this issue will be resolved for all of us.
    5. AllenWalkerHU
      AllenWalkerHU
      • member
      • 669 posts
      • 3 kudos
      It's definitely not on our side. I'm using Edge (don't judge me too hard) with barely any extensions (like three of them, 2 of which are ad blockers and the one is Dark Reader) and I'm still experiencing this log-in issue. I lost some of the opened pages I put aside for a bit later because of it too. Haven't been this annoyed in a while. This started happening right after this log-in update.
    6. Loveblanket
      Loveblanket
      • supporter
      • 1,528 posts
      • 42 kudos
      You have to stop copy pasting this response. I have no addons, period and I'm not only logged out constantly but now pages that I have saved in tabs to download later are reverting to the main nexus page upon a reload. This is 100% on your end.
    7. Dark0ne
      Dark0ne
      • Site Owner
      • 21,275 posts
      • 2,537 kudos
      We can take a look at the issue in more detail but we're still not sure it's on our end as we haven't done anything except log people out ONCE and force them to log back in again. We are not deleting people's login tokens for maintenance now and have only done it the one time mentioned in the news article. We have not changed our login mechanism. Nothing else has changed.

      In order to help us we need to know:

      • What browser you are using
      • What addons you are using (and have turned on) in your browser 
      • What exactly is happening. Can you navigate the site logged in or does every page load log you out? When do you get logged out? After how long?
    8. MONSTERaider
      MONSTERaider
      • premium
      • 1,434 posts
      • 536 kudos

      • What browser you are using
        - Google Chrome
      • What addons you are using (and have turned on) in your browser 
        - IDM Integration Module - Adobe Acrobat - AdBlock (with an exclusion for Nexus site so it won't run on it) - Lunar Reader (Dark mode theme)
      • What exactly is happening. Can you navigate the site logged in or does every page load log you out? When do you get logged out? After how long?
        - Yes I can navigate the site logged in with no problem and it doesn't log me out with new pages. - I get logged out randomly, sometimes after an hour sometimes after reopening the browser (not all the time though)
    9. MONSTERaider
      MONSTERaider
      • premium
      • 1,434 posts
      • 536 kudos
      @Loveblanket This happened to me as well, lost some few pages that I was planning to download later, poof they went back to main page, but gladly I used "reopen closed tab" and I got them all 'cause I closed the whole browser previously.
    10. Mitsuriou
      Mitsuriou
      • supporter
      • 402 posts
      • 27 kudos
      I'll confirm something too:
      The disconnection issues happened when I had pinned tabs that re-opened automatically at Google Chrome's launch.
      I deleted the pin tabs yesterday, and I've not been logged out today. Maybe this is what causes the issues :/

      I've repined 2 tabs today, I'll comment tomorrow if I'm disconnected again, so anyone can have more details on the issue.
    11. Mitsuriou
      Mitsuriou
      • supporter
      • 402 posts
      • 27 kudos
      Okay, I've been logged out while editing my mod's requirements, randomly. Pinned tabs or not do not make any difference since I did not reboot my browser during all this time ^^ So there's definitely something wrong
    12. BigBizkit
      BigBizkit
      • Community Manager
      • 5,914 posts
      • 323 kudos
      For you and anyone else who ran into this issue of being randomly logged out: we've deployed a potential fix. Please let us know when/if you're still experiencing the issue.
    13. MONSTERaider
      MONSTERaider
      • premium
      • 1,434 posts
      • 536 kudos
      @BigBizkit Thank you very much! So far I'm still logged-in with no issues, if I ever run into it I'll let you know, thanks again
  4. Wolpeti
    Wolpeti
    • member
    • 18 posts
    • 0 kudos
    How much extra work do you burned yourself with cause passwords get lost after they require now six million letters in capital and numbers because someone could steal doomgamer69s account and his Skyrim anime retextures.
  5. docteure
    docteure
    • premium
    • 3,310 posts
    • 1,547 kudos
    I have an issue with this apparently "logged out" every time I come back to Nexus on a new tab. After clicking, it says "you're already logged in." Then I'm in. This already happens twice.

    ===
    EDIT: saw the comments and I'm not the only one. :)
    1. Mitsuriou
      Mitsuriou
      • supporter
      • 402 posts
      • 27 kudos
      Hello docteure, have you got any pinned tab in your browser? For me, that's the issue, but I don't know if I'm the only one in this situation.
    2. docteure
      docteure
      • premium
      • 3,310 posts
      • 1,547 kudos
      No I don’t. I also tried on mobile and same issue. Hope they can fix it soon.
  6. Nidhoegger
    Nidhoegger
    • member
    • 15 posts
    • 0 kudos
    Your "maintenence" literally deleted my password. First, I thought my account was gone, but when I tried to open a new one, I got an email telling me it still existed. This was highly inconvenient and kind of bizarre. Fortunately, everything is working well now.
    1. Pickysaurus
      Pickysaurus
      • Community Manager
      • 14,614 posts
      • 337 kudos
      I'm afraid that's not possible. All we did was log you out. It's more likely that you changed your password last year and forgot it. Glad to hear you got back into your account though
  7. NinaRNina
    NinaRNina
    • premium
    • 2 posts
    • 1 kudos
    Thanks, I guess.  But, security is sooo overrated, darlings.  If someone wants to really hack a site, there's not much that can stop that person, no matter how much 'maintenance' you perform.

    I do free-climbing.  I don't care much about a 'feeling' of security.  When I do rockfaces at higher altitudes I wear a paraglider chute in case I fall and I admit it gives a sense of security but it also keeps me on edge.  A feeling of security makes you bolder and often also more careless.

    See you after the next security breach
    1. baluson
      baluson
      • member
      • 132 posts
      • 5 kudos
      said by someone who has achieved nothing
    2. napsa0500
      napsa0500
      • member
      • 2 posts
      • 0 kudos
      that's Help a lot
    3. Dark0ne
      Dark0ne
      • Site Owner
      • 21,275 posts
      • 2,537 kudos
      Ignoring the fact this is nothing to do with security and all to do with site performance, why bother with the chute? If a chute wants to fail, it will, no matter how much “maintenance” you perform...
    4. Domenicus7
      Domenicus7
      • supporter
      • 254 posts
      • 15 kudos
      medium-quality bait surely
  8. Loveblanket
    Loveblanket
    • supporter
    • 1,528 posts
    • 42 kudos
    Friday the 18th, still having to log in every time, doesn't matter what browser and all I have for anti-virus is windows and malware bytes.
  9. Mitsuriou
    Mitsuriou
    • supporter
    • 402 posts
    • 27 kudos
    Hello,

    I have login issues since your maintenance, too:
    I'm getting disconnected every day I come on NexusMods. So I reconnect myself but the next day I'm logged off again and I must reconnect again.
    I tried disconnecting and reconnecting myself with the button from the menu, clearing the cache, clearing the website cookies, clearing the Local Storage, but nothing helped at the end, I'm still getting disconnected every day.

    Tell me if I can do anything to avoid that issue, but I think that this is more like something is not going right on your side since the maintenance :/
    1. Pickysaurus
      Pickysaurus
      • Community Manager
      • 14,614 posts
      • 337 kudos
      If you can't stay logged in, something on your PC is preventing the site from saving your login details (usually "tin foil hat" browser addons) see: Troubleshooting Website Issues
    2. Loveblanket
      Loveblanket
      • supporter
      • 1,528 posts
      • 42 kudos
      ?No, they're right. I have zero anything added to my browser here and every time I open it, I'm logged out.
  10. Azrubel
    Azrubel
    • member
    • 50 posts
    • 1 kudos
    Neat, keep up the good work, team <3