BattleTech

File information

Last updated

Original upload

Created by

Justin Kase

Uploaded by

JustinKaseToo

Virus scan

Safe to use

551 comments

  1. JustinKaseToo
    JustinKaseToo
    • member
    • 426 posts
    • 17 kudos
    Locked
    Sticky

    Version 1.8.0.0 - BETA! 

     
    ALERT : Currently the Variants CAB folder is included but disabled.  While the CAB can be loaded using a workaround, I am hoping that HBS will finish their adjustments next week for a proper test - at that point, just adding the CAB and activating the folder 'should' work.

     

    REMINDER : the Annihilator, Archer, Assassin, Cyclops, Flea, Javelin, Phoenixhawk, Raven, Rifleman, Vulcan & Packrat models are now moved from the CAB folder to the DLC folder of the mod, as these models were released as part of DLC packs.  In my experience, this seemed to work without issue, however, if you run into an issue with a Raven/Javelin in your inventory, try to put it into storage and bring it back out so it uses the new CHASSISDEF file.

     

     

    PLEASE NOTE : This version is still in test mode for the latest HBS release using their ModManager.

     

    In order to install please do the following :

    Unzip and place in : C:\Users\(((YOUR USER ID)))\Documents\my games\BattleTech\mods\

    NOTE : all the JK mods will now be stored in a single folder called JK_BTMods to make organization easier

    The first time you start the game, it takes a bit to load, and screen will look like it locked up

    Then start the game and click on "mods" button in lower left corner

    Make sure all the mods are checked as active (yellow check)  ((I recomend that you don't activate the JK_VariantsCAB for now))

    Then close the game and restart

     

    *** Warning : If you choose to do a full uninstall of this mod at a future date, and you want to continue with your campaign, you should first sell all 'Mechs, 'Mech Salvage, Weapons, upgrades and Ammo from this mod prior to the uninstall. ***
     
    *** Additional Note : The 1.8.0.0 version of the Mod is dependent on having BATTLETECH Patch 1.8.0, to keep with versioning (you do not need Flashpoints, but it will work with them). ***
     

    This latest version of the JK_Variants mod catches up to 1.8.0 / Flashpoints / Urban Warfare / Heavy Metal and is currently only being provided in a ModTek download version - if anyone sees any errors with it, please let me know so I can work to address those issues. While the files are still the same ones in the core mod, they are organized slightly differently.

     

    Currently the files section you will see 1 new option (with ModTek now working for MAC and Linux, just doing that for now - unless people ask for the old school):

     NOTE: The new mod.json files are meant to work with ModTek 7.1 and later (currently 1.7.1), which allows you to turn on/off which items get added to the MetadataDatabase.db by editing the Mod.json files in each folder.  Read the included PDF instructions for help.

     

    Please continue to report issues and suggested era appropriate (up to 3040-ish) 'Mechs/Vees to add in - thank you all!!!

    1. JustinKaseToo
      JustinKaseToo
      • member
      • 426 posts
      • 17 kudos
      You can find more detailed install instructions with pictures at the Paradox site :

      https://forum.paradoxplaza.com/forum/index.php?threads/mod-jk_variants-1-8-0-0-175-mechs-and-125-vees-rarity-tables-and-more.1091277/page-34#post-26064194
    2. JustinKaseToo
      JustinKaseToo
      • member
      • 426 posts
      • 17 kudos
      NOTE : There appears to be an issue in the Mod Manager where 'Mechs that are meant to only be added to the VersionManifest and not the MDD.db are getting added in, resulting in the Skirmish Hero 'Mechs appearing out in the 'wild'.

      I am working on fixing the Rarity tables for those 'Mechs - but you can delete the Skirmish folder if you want to get rid of them.
  2. ShiffD
    ShiffD
    • premium
    • 9 posts
    • 0 kudos
    Could someone kindly let me know what uses the CommandConsole means?  Literally coming into this mod blind from BTXCE.  Could someone explain that, please?  Thank you!
  3. Sorites163
    Sorites163
    • member
    • 18 posts
    • 0 kudos
    I followed the install instructions, but none of the JK mods appear in the mod list when I launch the game. They just don't show up.

    Is this a known issue?
  4. s13nova
    s13nova
    • member
    • 1 posts
    • 0 kudos
    Hei,

    Upon installation I do see halfammo MG but havent yet found any new variants in shop / missions. Is there something wrong or are they rare or do I have to start new game for them to appear ( so existing old campaign doesnt work ).

    Can you please specify how it should be working?

    Thank you.
  5. projectsombra
    projectsombra
    • member
    • 3 posts
    • 0 kudos
    When will you get the next version of the mod in which the CAB variant works?
  6. apocalypserisin
    apocalypserisin
    • member
    • 132 posts
    • 1 kudos
    Not 100% if this is the cause, but this is the only mod I have that modifies shopdefs, but for some reason I for the life of me cannot find any stores selling any type of lbx ammo, even if the store itself is selling lbx weapons.
    1. theshadow99
      theshadow99
      • member
      • 23 posts
      • 0 kudos
      JK_Variants is the only mod I have installed and the LB ammo has gone missing from the stores for me as well.
    2. BlazeStryker
      BlazeStryker
      • premium
      • 3,217 posts
      • 23 kudos
      Reinstall; you got your ammo updated out of existence.
  7. Hil4nder
    Hil4nder
    • member
    • 2 posts
    • 0 kudos
    Is it normal for this mod to cause the game to take FOR-EVER to load when you first add it? I added it to my mods folder, as per the instructions on this post, reloaded my game after activating them, but now my game is busy loading for over 20 minutes.
    *EDIT* After further investigation, I found that it doesn't matter which mod I am trying to use, whenever I have mods activated in the game menu, it takes forever to load. Will have to bring this up with HBS, I guess.
  8. kato42
    kato42
    • supporter
    • 81 posts
    • 0 kudos
    I have a question you may be able to help with.
    I haven't tried 1.8 yet as I'm waiting for some more mods to be revised for 1.8, but I am wondering about something: some mods say 'use the HBS mod loader' and some say use ModTek - one had an option of different files for each; can you use both? Or do you have to choose one or the other?

    I've heard there is some bugs in the HBS mod loader which I guess is why people still want to use ModTek (although I can never be 100% sure of the veracity of such claims until trying it myself, there seems to be a number of people that gleefully say anything HBS does is crap, no matter the actual situation).
    1. JustinKaseToo
      JustinKaseToo
      • member
      • 426 posts
      • 17 kudos
      Right now there are a couple of issues that HBS is working through on their mod loader, the one that is really impacting a lot of the bigger mods is the inability to load Asset Bundles (which is what the CAB uses). There are also some issues with certain dll mods (another popular type that edits the code in the game at certain points).

      HBS isn't going to be able to spit out their version quick enough for some - especially with the Thanksgiving holiday seeing people out. So, modders are going to mod their own solution (ModTek) to allow them to move forward with the version 1.8.

      EDIT : I'd suggest reading the release notes on whatever the latest version of ModTek is, as the information is changing rapidly.

      Anyway, I've always tried to keep the majority of my stuff on the low impact side, so it could be used with other mods with little chance of conflict, or to act as a base and timesaver for people wanting to do their own mods to take the 'Mechs/Vees and adjust them. So most of my stuff plays well with the current ModManager from HBS. With the exception of the VariantsCAB, which are dependent on the CAB itself. But even my low impact stuff has had some minor issues (like the merge files overwriting each other) - but I'm just happy to see HBS moving into a more official support role for modding.
    2. kato42
      kato42
      • supporter
      • 81 posts
      • 0 kudos
      Thanks for the info. I can see how the dll and asset bundles issue would be a wee bit of a problem.
      I tend to agree with your strategy of low impact, but I can understand where that may not be possible.

      I also agree that its good that HBS has decided to embrace mods, it is one of the greatest advantages of gaming on a full PC, so it's nice when a game handles it natively. Some people still want to use an external manager - the XCom2 Mod Manager for example - but in my experience, once the native manager is stable, I find the external ones to be not really worth the bother (ModTek is a nice simple concept though).

      I'm playing some other games at the moment, so maybe I'll just wait for all this to stabilize a bit before getting back into BT.
    3. Skywarp73
      Skywarp73
      • member
      • 42 posts
      • 0 kudos
      the HBS mod loader is very broken at the moment it has the lovely habit of deactivating modsuse modtek it is way more stable
  9. Skywarp73
    Skywarp73
    • member
    • 42 posts
    • 0 kudos
    Hi lovinf your mod how ever the annihilator is coming back with an error in the annihilator_ANH-1A
    1. JustinKaseToo
      JustinKaseToo
      • member
      • 426 posts
      • 17 kudos
      Hi there @Skywarp73 - couple of quick questions :

      1 - What error are you seeing?
      2 - Do you have Heavy Metal DLC?
      3 - Are you using the ModManager (the built in HBS one) or ModTek (from Github or Nexus)?
      3a - If ModManager - navigate to C:\Users\(((your login ID)))\Documents\my games\BattleTech\mods\HBS and delete the Cache and Database folders. Then restart the game, make sure all the mods are checked off, and close/restart again.
      3b - If ModTek - navigate to BATTLETECH\Mods\ and delete the .modtek folder and restart

      Let me know. Thanks!
    2. Skywarp73
      Skywarp73
      • member
      • 42 posts
      • 0 kudos
      I am using modtek and yes when i was getting this error i was using 1.8 heavy metal it was rather strange cos this only came up after the offical modloader decided to deactivate all my mods which i had to reactivate again
    3. Skywarp73
      Skywarp73
      • member
      • 42 posts
      • 0 kudos
      Hi thanks for getting back to methe annihilator ANA 1 is coming back there is a proble with the chrPrfMech_annihilatorBase-001
      Yes i have heavy metal DLC
      I am using the modtek from github
      I deleted the modtek and reinjected still was getting the same problemi was trying to play the arno campaign but found it so bugged i ended up going back to 1.7.1
  10. unclecid66
    unclecid66
    • premium
    • 303 posts
    • 1 kudos
    like i said on forums thanks for getting all these mods going for 1.8
    they are part of my 'essential' QoL mods i always use.

    anywho.....installed all the JK mods into the new HBS mods folder and started game...went into modloader....

    jkcab was enabled and jkrarity, appearance, and campaign jj were disabled.

    tried to swap that around and wouldn't work.
    as soon as i enable any of those 3 Cab would also enable and disabling cab again would disable the other 3
    exiting game and removing cab folder completely from mod directory fixed that.
    1. unclecid66
      unclecid66
      • premium
      • 303 posts
      • 1 kudos
      ok so weirdness time.
      i installed your mods at the point in the campaign where i was about to do the liberate smithon (ammo dump) mission.
      everything went fine....finished, saved and quit.
      came back into game later on and got infinite loop in contract room
      so went to another planet...same deal.
      tried disabling the mods but nothing seemed to work
      eventually had to remove all JK mods and reload save from just before install.
      and stupid me forgot to grab a copy of the output.log before i started up again.
      i REALLY hate that it got moved from where it was easily accessible
    2. JustinKaseToo
      JustinKaseToo
      • member
      • 426 posts
      • 17 kudos
      It sounds like JK_VariantsCAB is Enabled. For now I'd suggest just deleting that one folder and then rerunning.

      Going to repost 1.8.0.1 as this same thing without the CAB folder.
    3. leonseye
      leonseye
      • premium
      • 63 posts
      • 0 kudos
      I'm having this same issue; I deleted the CAB folder and tried restarting, but still just getting the spinning "connecting" icon whenever I try to go to the Contracts screen. Tried jumping to a different system and same thing.
    4. paulobrito
      paulobrito
      • member
      • 274 posts
      • 1 kudos
      Yep - with this new update i also get that problem.
    5. leonseye
      leonseye
      • premium
      • 63 posts
      • 0 kudos
      So, I got this to work by uninstalling the mod, going to my appdata/LocalLow/HarebrainedSchemes folder and deleting the Battletech folder, then reinstalling this mod (minus the CAB folder).

      I guess it was still referencing something in the CAB folder in the cache or something (no idea how any of this works, I'm just taking a stab in the dark here), but either way, that seems to have fixed it and the contracts are loading now. : )
    6. paulobrito
      paulobrito
      • member
      • 274 posts
      • 1 kudos
      In my case i fixed it by - inside the my games/battletech/mods/hbs deleting the cache and database folders and starting the game after that
    7. JustinKaseToo
      JustinKaseToo
      • member
      • 426 posts
      • 17 kudos
      I posted some slightly better instructions on the Paradox site - https://forum.paradoxplaza.com/forum/index.php?threads/mod-jk_variants-1-8-0-0-175-mechs-and-125-vees-rarity-tables-and-more.1091277/page-34#post-26064194

      I'd also recommend deleting the JK_VariantsCAB folder from the JK_BTMods for now, as it seems to autoactivate if you try to turn on dependent mods (optional dependencies aren't working).

      I posted an updated 1.8.0.0 file here as well that doesn't have that folder.

      Also - as noted - you may need to go into the mods/HBS/ folder and delete the cache there.

      @Leonsete - I'll look into that as well and add that to the troubleshooting steps - THANK YOU!
  11. RyuDraconis
    RyuDraconis
    • premium
    • 18 posts
    • 1 kudos
    So Im at a loss, I cant get this to work at all, I am getting ILS when activating the mods in this folder and starting a new game (using 1.7.1.1_ I check the modtek loader and it seems to load fine, but cant kick the ILS when loaded. There are no errors in the logs, so Ill have to deactivate until a solution is found, but its frustrating. My modtek us up to date, as is the game, any help would be appreciated if possible, thanks.

    edit: it seems to be when I set one of the files to a fresh install without changing the .mod tot he activated json json fixes the problem for now (looks like it was labelled 1.6.25, the one in JK variants CAB, apologies, and thanks for the mod! )
    1. JustinKaseToo
      JustinKaseToo
      • member
      • 426 posts
      • 17 kudos
      Try the latest with the new mod manager as well. Let me know if it works kindly!