SKYRIM
Brawl Bugs Patch - Plugins - Modder Resource by jonwd7
Skyrim » Modders resources and tutorials
Added: 12/09/2012 - 04:30AM
Updated: 20/09/2012 - 07:22AM

16,072 Endorsements

1.0 Latest version

214,015 Unique D/Ls

380,776 Total D/Ls

816,068 Total Views

Uploaded by jonwd7

Description

Last updated at 7:22, 20 Sep 2012 Uploaded at 4:30, 12 Sep 2012

Brawl Bugs Patch, Plugins, and Modder's Resources
by jonwd7

v1.0
Original Thread


The Brawl Bugs patch was borne out of my work on my own Footprints mod. I am
slow to release these kinds of things, and my footwork can be seen in previous
versions such as the Brawl Bug Plugin by trebtreb, and in my own Footprints
mod in versions prior to 0.7. This fix is more general and should not require
modders to adapt their work, and should even work on existing mods with the
bug without any changes from the modder. It also addresses more bugs with
the Brawl-type scripts.

For modders, I have included a resource package which they are free to include
in their BSA. Please also check out the tutorial below, which covers how to
prevent the Brawl Bug without inclusion of my patch or scripts.

Modder's Tutorial

USKP Bug Reports
USKP: 'Brawl Bug' report
USKP: 'Healing While Brawling' report
USKP: Additional Brawl bugs


==============================================================================
FAQ (Frequently Asked Questions)
==============================================================================
Q: "How does it work?"
A: It uses a "sieve" approach, in that it only allows magic effect keywords
through that have been considered tangible, detrimental, or harmful.

Q: "Which version should I download?"
A: If you are a user with Skyrim 1.6 or higher, you should download the
"Compatibility Edition" (CE). The CE does not edit any vanilla forms.

Q: "What should I do as a modder?"
A: You should follow this tutorial at the CK Wiki.
It provides steps to circumvent the Brawl Bug in your mod without editing
vanilla forms or vanilla scripts. Additionally, you can download the
modder's resource package here, and include the modified scripts in your BSA.

Q: "What else does it fix?"
A: It covers a bit more than the straight-up 'Brawl Bug'. There were various
issues with the scripts such as OnHit/OnMagicEffectApply clashes, and a lack
of using "states" which prevent a block from running more than once. Using
some types of magic effects during a Brawl could cause Papyrus errors.

It also restores player healing behavior during Brawls which Bethesda had
taken out due to their buggy implementation (which was left commented out in
the scripts). Now, as per the dialogue, you can no longer use magic in order
to heal yourself, buff yourself, or cast summons. This is considered cheating
and the Brawl immediately ends. The opponent gets to keep your money.


==============================================================================
WHAT THIS FIXES
==============================================================================
1. The following scripts were affected in some way by the "Brawl Bug":
- DGIntimidatePlayerScript
- DGIntimidateAliasScript
- C00VilkasScript
- C00TrainerScript
- MS11CalixtoScript (Questionable)
- CompanionsSingleCombatantScript (Questionable)
- BladesSparringScript (Most likely not affected, but included anyway)

2. Player healing behavior during Brawls. As per the dialogue, and Bethesda's
own code which was buggy (and therefore commented out), healing, casting buffs,
or summoning during Brawls is now considered cheating.

3. The scripts did not use states to avoid race conditions. This led to errors
printed to your logs if you would cheat with certain MGEFs, like Flames for
example. Flames would fire continuous OnHit/OnMagicEffectApply blocks and
lead to Papyrus errors. I also short circuit the OnHit event when the source
is a Spell, and let OnMagicEffectApply handle it to avoid block clashing.


==============================================================================
INSTALLATION
==============================================================================
Install the BSA and ESP to your Data folder.
Load as EARLY AS POSSIBLE in your load order.


==============================================================================
UNINSTALLATION
==============================================================================
Remove the ESP and BSA from your data folder. It is NOT recommended to
uninstall ANY mod in the middle of a save game. However, the worst that should
happen by removing this patch is a few warnings in your Papyrus logs.


==============================================================================
COMPATIBILITY
==============================================================================
There are no known compatibility issues. Put early in your load order and
any changes will be overwritten by the later mod. If in doubt, download and
use the Compatibility Edition instead. (This requires Skyrim 1.6+)


==============================================================================
CHANGELOG
==============================================================================
1.0 - Initial Release


==============================================================================
PERMISSIONS / LICENSING
==============================================================================
- Permission is NOT given to redistribute this mod in whole or in part.
- MODDERS: You have permission to include the resource files directly in your
mods. A mention in your credits would be appreciated.