SKYRIM
Brawl Bug Plugin by Hoax2
Skyrim » Modders resources and tutorials
Added: 01/09/2012 - 07:38AM
Updated: 12/10/2013 - 10:16AM

4,497 Endorsements

1.1 Latest version

79,963 Unique D/Ls

112,766 Total D/Ls

353,951 Total Views

Uploaded by trebtreb

Description

Last updated at 10:16, 12 Oct 2013 Uploaded at 7:38, 1 Sep 2012

While I wholeheartedly endorse valve I do not endorse the upload of my mods to SteamWorkshop, please respect this decision.
This mod has been superseded by Brawl Bugs Patch
which patches the issue all together. Users can simply remove this mod (Brawl Bug Plugin), and the mods which currently support it will continue to work as expected and bug free provided that you’ve got the above mentioned patch.

--- I had always intended this to be an interim solution to the problem until Jonwd7 had finished his patch so make sure you throw him an endorsement. ;)

================================================================================
Description: Requires Skyrim ver 1.6

THIS IS NOT A PATCH. It doesn't solve anything on it's own, it requires mod authors to support its features in order to fix anything. It's designed to help authors avoid Skyrim's Brawl / Cloak-Spell Bugs. [USKP Bug 3444] by making their mod compatible with this one.

LOAD-ORDER, is completely irrelevant.
This mod just needs to be enabled for compatible mods to take advantage.

To be clear; the plugin doesn't edit any vanilla forms, the ESP file is blank and used purely so that the BSA (containing replacement scripts) can be elegantly enabled and disabled as needed.

Currently supported by:

For spell modders:
- Recommend users download this plugin
- simply add the keyword "Dummy" (existing in Skyrim.esm) to your spell effect
- Make sure you tick "no hit event" and it will be ignored by brawlers and other scripts with cloak issues.

For script modders
If you want your mod to ignore user made cloak spells the best bet is to set up your OnMagicEffectApply to to check for only relevant effects. OR simply set up your event like this and spells that supports this plugin will be ignored.

If you chose to support or package this plugin with your mod contact me and I'll list your mod here and inform you of updates.


Compatibility
======================================
- You will only get problems with mods that edit the 15 scripts listed below. (see: "What is the Brawl/Cloak-spell Bug?")
- Ver1.1 now works with "Unofficial Skyrim Patch" but should be below (override) it in load order.


Version History
======================================
v1.1 - edits to critter.pex script to match USKP's fixes (thanks to Neovalen)
v1 - main release, edits to 15 scripts.
v0 - proof of concept, edit to DGIntimidateAliasScript only.


What is the Brawl/Cloak-spell Bug?
======================================
[USKP Bug 3444] Many mod authors need to use what's called a "Cloak Spell" in order to attach scripts/effects to NPCs and objects with-in a radius around the player. Unfortunately some 15 vanilla scripts (eg. DGIntimidateAliasScript) don't check what type of effect is being used despite how the spell is set up. This can result in unwanted behaviour from that script if someone were to use a cloak-spell.

The following are scripts which I've identified that seem to have this issue and are avoided with this plugin.
  • BladesSparringScript
  • C00TrainerScript
  • C00VilkasScript
  • CompanionsSingleCombatantScript
  • Critter
  • DGIntimidateAliasScript
  • DGIntimidatePlayerScript
  • dunLabyrinthianMazeTabletScript
  • MG02WallAliasScript
  • MS11CalixtoScript
  • TrapFallingOilLamp
  • TrapFallingOilLampAnim
  • TrapFallingOilLampColLayer
  • trapSoulGemController
  • TrapTriggerBase



Help me!
======================================
This is a helpful community and any bug reports, issues, oddities or even conceptual issues with this mod will help.

If you're interested: I've written an article that outlines the various points of view on how to solve this issue and why i chose this one.